summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-07-16 20:35:15 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-07-17 00:25:56 +0200
commit951c4636254e58a2c531ebee00d47c45ee719dea (patch)
treef67f93ab40b4b4d8717acd660b6e6f179826dbc3 /media-libs
parentmedia-libs/dumb: EAPI-6 bump (diff)
downloadgentoo-951c4636254e58a2c531ebee00d47c45ee719dea.tar.gz
gentoo-951c4636254e58a2c531ebee00d47c45ee719dea.tar.bz2
gentoo-951c4636254e58a2c531ebee00d47c45ee719dea.zip
media-libs/aldumb: EAPI-6 bump
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/aldumb/aldumb-0.9.3.ebuild25
1 files changed, 15 insertions, 10 deletions
diff --git a/media-libs/aldumb/aldumb-0.9.3.ebuild b/media-libs/aldumb/aldumb-0.9.3.ebuild
index b6fd72d59ff7..38c75c096e86 100644
--- a/media-libs/aldumb/aldumb-0.9.3.ebuild
+++ b/media-libs/aldumb/aldumb-0.9.3.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="Allegro support for DUMB (an IT, XM, S3M, and MOD player library)"
HOMEPAGE="http://dumb.sourceforge.net/"
@@ -13,27 +12,33 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug"
-DEPEND=">=media-libs/dumb-0.9.3
- <media-libs/allegro-5"
-
+DEPEND="
+ >=media-libs/dumb-0.9.3
+ media-libs/allegro:0
+"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${P/aldumb/dumb}"
+PATCHES=(
+ "${FILESDIR}"/${P}-PIC-as-needed.patch
+ "${FILESDIR}"/${P}_CVE-2006-3668.patch
+)
+
src_prepare() {
+ default
+
cat << EOF > make/config.txt
include make/unix.inc
ALL_TARGETS := allegro allegro-examples allegro-headers
PREFIX := /usr
EOF
- epatch "${FILESDIR}"/${P}-PIC-as-needed.patch
- epatch "${FILESDIR}"/${P}_CVE-2006-3668.patch
sed -i '/= -s/d' Makefile || die "sed failed"
- cp -f Makefile Makefile.rdy
+ cp -f Makefile Makefile.rdy || die
}
src_compile() {
- emake OFLAGS="${CFLAGS}" all || die "emake failed"
+ emake OFLAGS="${CFLAGS}" all
}
src_install() {