summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2019-06-13 01:08:31 +0300
committerStefan Strogin <steils@gentoo.org>2019-06-13 18:30:44 +0300
commit962d71be9f0f5b8ab5ac5bb676533ff50cbab182 (patch)
treeb789d93dc2a277a93f7218bf5e8e01825e3bda5a /media-libs
parentmedia-video/openshot: add myself as maintainer (diff)
downloadgentoo-962d71be9f0f5b8ab5ac5bb676533ff50cbab182.tar.gz
gentoo-962d71be9f0f5b8ab5ac5bb676533ff50cbab182.tar.bz2
gentoo-962d71be9f0f5b8ab5ac5bb676533ff50cbab182.zip
media-libs/libopenshot: bump version to 0.2.4_pre20190609
- Soname is updated, add subslot. - Add USE=doc, USE=examples. - Tests are fixed upstream now. - EAPI=7. - Add python3_7 to PYTHON_COMPAT. Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Stefan Strogin <steils@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libopenshot/Manifest1
-rw-r--r--media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/libopenshot/Manifest b/media-libs/libopenshot/Manifest
index b8d00e783216..cc5d98ea6eea 100644
--- a/media-libs/libopenshot/Manifest
+++ b/media-libs/libopenshot/Manifest
@@ -1 +1,2 @@
DIST libopenshot-0.2.2.tar.gz 11037768 BLAKE2B c307e41bf17d40ae421a541bbdf4cd53c6ef4d97041a476c6910bd156c10815aa5a5811813b24fdc472401516f29cf8cb68fbda17a0b434767c3f3aa63d6f222 SHA512 b89189e57e82da68a063417bba9c94704c04b0546c0aed227daa23a794eee56341a05988d8e28dbd339edfcdeeaed48103b347060eccf94f32fe1a4bf23d6553
+DIST libopenshot-0.2.4_pre20190609.tar.gz 10268173 BLAKE2B 01e07c0a7c051b5804f24fab1bfb920862a165ef14d3fdd020430b9e3a47858842c8cab3408ba0d161cb15cc6e90531a3b5df9ad327a01f414ff2e7e392fc243 SHA512 bf8c06aba6a899cb1ca6fbe9ac89fc859083b03175338c04af8dce68698f4ac78eac0b5b594e2b02390cd5e64576445b1c95324b254a267506353bed97ca16d1
diff --git a/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
new file mode 100644
index 000000000000..89b540bf332b
--- /dev/null
+++ b/media-libs/libopenshot/libopenshot-0.2.4_pre20190609.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit cmake-utils python-single-r1 toolchain-funcs
+
+COMMIT="0d4ea7fe71e88bcee4a7fd1404bd52c8e2169997"
+
+DESCRIPTION="Video editing library used by OpenShot"
+HOMEPAGE="https://www.openshot.org/"
+SRC_URI="https://github.com/OpenShot/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0/17"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples +imagemagick libav +python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ net-libs/cppzmq
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5[widgets]
+ >=media-libs/libopenshot-audio-0.1.9_pre20190502:0=
+ imagemagick? ( >=media-gfx/imagemagick-7:0=[cxx] )
+ libav? ( media-video/libav:0=[encode,x264,xvid,vpx,mp3,theora] )
+ !libav? ( media-video/ffmpeg:0=[encode,x264,xvid,vpx,mp3,theora] )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+ test? ( dev-libs/unittest++ )
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# From Mageia
+# https://github.com/OpenShot/libopenshot/issues/60
+PATCHES=( ${FILESDIR}/${PN}-0.2.2-imagemagick7.patch )
+
+check_compiler() {
+ if [[ ${MERGE_TYPE} != binary ]] && ! tc-has-openmp; then
+ eerror "${P} requires a compiler with OpenMP support. Your current"
+ eerror "compiler does not support it. If you use gcc, you can"
+ eerror "re-emerge it with the 'openmp' use flag enabled."
+ die "The current compiler does not support OpenMP"
+ fi
+}
+
+pkg_pretend() {
+ check_compiler
+}
+
+pkg_setup() {
+ check_compiler
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ cmake-utils_src_prepare
+ # https://github.com/OpenShot/libopenshot/issues/17
+ use test || cmake_comment_add_subdirectory tests
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_RUBY=OFF # TODO: add ruby support
+ -DENABLE_PYTHON=$(usex python)
+ $(cmake-utils_use_find_package imagemagick ImageMagick)
+ )
+ use python && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
+ -DPYTHON_LIBRARY="$(python_get_library_path)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && cmake-utils_src_make doc
+}
+
+src_test() {
+ cmake-utils_src_make os_test
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.md doc/HW-ACCEL.md )
+ use examples && DOCS+=( src/examples/ )
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ cmake-utils_src_install
+ use python && python_optimize
+}