summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-08-12 18:38:31 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2020-08-12 18:38:47 +0200
commit98b9c838cbb4818ff3970dafdb045fb4f97c3b38 (patch)
tree3e699a04fa482dfb2b868e5faee08eeaa57b354b /media-libs
parentdev-util/android-tools: PYTHON_COMPAT+=(python3_{8,9}) (diff)
downloadgentoo-98b9c838cbb4818ff3970dafdb045fb4f97c3b38.tar.gz
gentoo-98b9c838cbb4818ff3970dafdb045fb4f97c3b38.tar.bz2
gentoo-98b9c838cbb4818ff3970dafdb045fb4f97c3b38.zip
media-libs/ganv: py3
Closes: https://bugs.gentoo.org/735372 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/ganv/ganv-1.6.0-r1.ebuild40
-rw-r--r--media-libs/ganv/ganv-1.6.0.ebuild1
2 files changed, 40 insertions, 1 deletions
diff --git a/media-libs/ganv/ganv-1.6.0-r1.ebuild b/media-libs/ganv/ganv-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..8f7045e0bab4
--- /dev/null
+++ b/media-libs/ganv/ganv-1.6.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+PYTHON_REQ_USE='threads(+)'
+inherit eutils flag-o-matic waf-utils python-any-r1
+
+DESCRIPTION="A GTK+ widget for interactive graph-like environments"
+HOMEPAGE="http://drobilla.net/software/ganv/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fdgl +graphviz introspection nls"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2
+ graphviz? ( media-gfx/graphviz[gtk] )
+ introspection? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection:=[doctool] )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-util/glib-utils
+ nls? ( virtual/libintl )
+"
+
+src_configure() {
+ append-cxxflags -std=c++11
+ waf-utils_src_configure \
+ $(use graphviz || echo "--no-graphviz") \
+ $(use fdgl || echo "--no-fdgl") \
+ $(use nls || echo "--no-nls") \
+ $(use introspection && echo "--gir")
+}
diff --git a/media-libs/ganv/ganv-1.6.0.ebuild b/media-libs/ganv/ganv-1.6.0.ebuild
index 91c0613bf4bb..54805ef9a7f8 100644
--- a/media-libs/ganv/ganv-1.6.0.ebuild
+++ b/media-libs/ganv/ganv-1.6.0.ebuild
@@ -2,7 +2,6 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-# oes not work with python3
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
inherit eutils flag-o-matic waf-utils python-any-r1