summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2016-12-14 13:53:30 -0800
committerMichael Palimaka <kensington@gentoo.org>2017-03-04 10:11:34 +1100
commita0e0030ba45065e47f61c1381d283cf6162a733b (patch)
treeb5f68c8bc66c9d8cd00a42791135369a12d3cc0b /media-libs
parentmail-filter/opendkim: support gnutls-3.4 + eapi bump (diff)
downloadgentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.tar.gz
gentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.tar.bz2
gentoo-a0e0030ba45065e47f61c1381d283cf6162a733b.zip
media-libs/speexdsp: New package
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/speexdsp/Manifest1
-rw-r--r--media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch44
-rw-r--r--media-libs/speexdsp/metadata.xml11
-rw-r--r--media-libs/speexdsp/speexdsp-1.2_rc3.ebuild54
4 files changed, 110 insertions, 0 deletions
diff --git a/media-libs/speexdsp/Manifest b/media-libs/speexdsp/Manifest
new file mode 100644
index 000000000000..222b31323894
--- /dev/null
+++ b/media-libs/speexdsp/Manifest
@@ -0,0 +1 @@
+DIST speexdsp-1.2rc3.tar.gz 901771 SHA256 4ae688600039f5d224bdf2e222d2fbde65608447e4c2f681585e4dca6df692f1 SHA512 29dfa8345df025eeb076561648a9b5c0485692be699b6da3c2a3734b4329187a1c2eb181252f4df12b21f1309ecdf59797437dfb123d160fd723491ab216e858 WHIRLPOOL 74e09df1819f0a857934f7821d1176c2ed410d231e51eaba5042c2e703f800ada54a648ba3400ea5b078b2a36c11c7f367322ec48fe09233d046fdfcb6b62930
diff --git a/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch b/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch
new file mode 100644
index 000000000000..ae29da58438b
--- /dev/null
+++ b/media-libs/speexdsp/files/speexdsp-1.2_rc3-configure.patch
@@ -0,0 +1,44 @@
+diff -Naur speexdsp-1.2rc3.orig/configure.ac speexdsp-1.2rc3/configure.ac
+--- speexdsp-1.2rc3.orig/configure.ac 2016-12-12 20:04:48.710853453 -0800
++++ speexdsp-1.2rc3/configure.ac 2016-12-12 20:05:07.588052415 -0800
+@@ -151,10 +151,17 @@
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-has_sse2=yes
+-CFLAGS="$CFLAGS -O3 -msse -msse2"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
++fi
++])
++
++AC_ARG_ENABLE(sse2, [ --enable-sse2 Enable SSE2 support], [
++if test "x$enableval" != xno; then
++has_sse2=yes
++CFLAGS="$CFLAGS -msse2"
++else
+ has_sse2=no
+ fi
+ ])
+@@ -162,7 +169,7 @@
+ AC_ARG_ENABLE(neon, [ --enable-neon Enable NEON support], [
+ if test "x$enableval" != xno; then
+ has_neon=yes
+-CFLAGS="$CFLAGS -O3 -march=armv7-a -mfpu=neon"
++CFLAGS="$CFLAGS -mfpu=neon"
+ else
+ has_neon=no
+ fi
+diff -Naur speexdsp-1.2rc3.orig/libspeexdsp/Makefile.am speexdsp-1.2rc3/libspeexdsp/Makefile.am
+--- speexdsp-1.2rc3.orig/libspeexdsp/Makefile.am 2016-12-12 20:04:48.690853242 -0800
++++ speexdsp-1.2rc3/libspeexdsp/Makefile.am 2016-12-12 20:08:27.740161974 -0800
+@@ -29,7 +29,7 @@
+ pseudofloat.h smallft.h vorbis_psy.h resample_sse.h resample_neon.h
+
+ libspeexdsp_la_LDFLAGS = -no-undefined -version-info @SPEEXDSP_LT_CURRENT@:@SPEEXDSP_LT_REVISION@:@SPEEXDSP_LT_AGE@
+-libspeexdsp_la_LIBADD = $(LIBM)
++libspeexdsp_la_LIBADD = $(LIBM) $(FFT_LIBS)
+
+ if BUILD_EXAMPLES
+ noinst_PROGRAMS = testdenoise testecho testjitter testresample
diff --git a/media-libs/speexdsp/metadata.xml b/media-libs/speexdsp/metadata.xml
new file mode 100644
index 000000000000..425a1ca399e2
--- /dev/null
+++ b/media-libs/speexdsp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sound@gentoo.org</email>
+ <name>Gentoo Sound project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpe">cpe:/a:xiph:speex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild b/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild
new file mode 100644
index 000000000000..b946550540a9
--- /dev/null
+++ b/media-libs/speexdsp/speexdsp-1.2_rc3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools flag-o-matic multilib-minimal
+
+MY_P=${P/_}
+MY_P=${MY_P/_p/.}
+
+DESCRIPTION="Audio compression format designed for speech -- DSP"
+HOMEPAGE="http://www.speex.org/"
+SRC_URI="http://downloads.xiph.org/releases/speex/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="cpu_flags_x86_sse cpu_flags_x86_sse2 neon static-libs"
+
+RDEPEND="!<media-libs/speex-1.2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-configure.patch" )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ libspeexdsp/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ append-lfs-flags
+
+ # Can also be configured with one of:
+ # --enable-fixed-point (no floating point)
+ # --with-fft=proprietary-intel-mkl (mkl)
+ # --with-fft=gpl-fftw3 (fftw)
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable static-libs static) \
+ $(use_enable cpu_flags_x86_sse sse) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable neon)
+}
+
+multilib_src_install_all() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}