summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2019-03-05 16:28:24 +0000
committerLuca Barbato <lu_zero@gentoo.org>2019-03-05 16:28:37 +0000
commitb8be0e0c3d22a07a194cd850ba0333293d429f9b (patch)
tree253f537b7fa7e91a7add71cf45c99a95b304b5c4 /media-libs
parentapp-admin/filebeat: revert stable version drop (diff)
downloadgentoo-b8be0e0c3d22a07a194cd850ba0333293d429f9b.tar.gz
gentoo-b8be0e0c3d22a07a194cd850ba0333293d429f9b.tar.bz2
gentoo-b8be0e0c3d22a07a194cd850ba0333293d429f9b.zip
media-libs/dav1d: New version
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Luca Barbato <lu_zero@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/dav1d/Manifest1
-rw-r--r--media-libs/dav1d/dav1d-0.2.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/dav1d/Manifest b/media-libs/dav1d/Manifest
index 766c5b355cc5..ad6daef6ec29 100644
--- a/media-libs/dav1d/Manifest
+++ b/media-libs/dav1d/Manifest
@@ -1 +1,2 @@
DIST dav1d-0.1.0.tar.bz2 351745 BLAKE2B 302680ddfdc8d5a3eff90541ed156e820c3322bfb93316da1b2deabeac40062103af19e99dfa810678e62ad668c4aed944ac9bf8160afb301b100063919ed2a1 SHA512 5893ad40af7c4f5c3678ecc604ad360b5d1cd3fadaa16f7183d638745097fed091aeb3456540db61a2f4f0fc8bb93f2a20f428c76a7976d3fd186cc8b8baed53
+DIST dav1d-0.2.0.tar.bz2 408361 BLAKE2B 2c5f4d7777d85ab1453a744335ee5047b2e108a70e884c5116d8d1a56b81c1f852c93666bd0bb3f4d5105f2220bbc6c92f893848f0cf1bfc0bce1ee1f551287c SHA512 378060ed6762f9f6baf7addfa7382cb0873bbc606f0389eee4ed7537dcfc851f5b159a34af0f15d9f8d345a9b2a950f38078a419144b0458aa3464e54ea5d490
diff --git a/media-libs/dav1d/dav1d-0.2.0.ebuild b/media-libs/dav1d/dav1d-0.2.0.ebuild
new file mode 100644
index 000000000000..ddb669829bc1
--- /dev/null
+++ b/media-libs/dav1d/dav1d-0.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+SCM=""
+if [[ "${PV}" == "9999" ]]; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
+fi
+
+inherit ${SCM} meson ninja-utils multilib-minimal
+
+DESCRIPTION="dav1d is an AV1 Decoder :)"
+HOMEPAGE="https://code.videolan.org/videolan/dav1d"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="+8bit +10bit +asm"
+
+ASM_DEPEND=">=dev-lang/nasm-2.13"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ asm? (
+ abi_x86_32? ( ${ASM_DEPEND} )
+ abi_x86_64? ( ${ASM_DEPEND} )
+ )"
+
+DOCS=( README.md doc/PATENTS )
+
+multilib_src_configure() {
+ local -a bits=()
+ use 8bit && bits+=( 8 )
+ use 10bit && bits+=( 16 )
+
+ if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
+ build_asm=false
+ else
+ build_asm=$(usex asm true false)
+ fi
+
+ local emesonargs=(
+ -D bitdepths=$(IFS=,; echo "${bits[*]}")
+ -D build_asm=$build_asm
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ eninja
+}
+
+multilib_src_install() {
+ DESTDIR="${D}" eninja install
+}