summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2019-04-08 21:20:18 +1000
committerMichael Palimaka <kensington@gentoo.org>2019-04-08 21:20:34 +1000
commitb946d6fef0d8294c2be91f0a5a93722dddeb0a88 (patch)
treec2f601a0129b6c980ef658944ebd15b87ae80396 /media-libs
parentdev-libs/nettle: arm64 stable (bug #681096) (diff)
downloadgentoo-b946d6fef0d8294c2be91f0a5a93722dddeb0a88.tar.gz
gentoo-b946d6fef0d8294c2be91f0a5a93722dddeb0a88.tar.bz2
gentoo-b946d6fef0d8294c2be91f0a5a93722dddeb0a88.zip
media-libs/phonon-gstreamer: update icon cache
Closes: https://bugs.gentoo.org/682474 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild10
-rw-r--r--media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild12
2 files changed, 19 insertions, 3 deletions
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild
index e2f6469b9c61..c80af05ae4f4 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-4.9.0-r3.ebuild
@@ -14,7 +14,7 @@ else
inherit git-r3
fi
-inherit cmake-utils
+inherit cmake-utils xdg-utils
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://phonon.kde.org/"
@@ -52,3 +52,11 @@ src_configure() {
local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
index 0d59d267cf77..541cae229fe1 100644
--- a/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
+++ b/media-libs/phonon-gstreamer/phonon-gstreamer-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,7 @@ else
inherit git-r3
fi
-inherit cmake-utils
+inherit cmake-utils xdg-utils
DESCRIPTION="Phonon GStreamer backend"
HOMEPAGE="https://phonon.kde.org/"
@@ -47,3 +47,11 @@ src_configure() {
local mycmakeargs=( -DPHONON_BUILD_PHONON4QT5=ON )
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}