summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuke Peterson <hazelnusse@gmail.com>2020-01-07 21:08:31 -0800
committerJames Le Cuirot <chewi@gentoo.org>2020-01-08 23:21:23 +0000
commitbb868e6b88a71685c5e38841ef6fce3b4d364299 (patch)
tree0bb020e67b13f91467b58821a1346dcc4f5e9465 /media-libs
parentsys-power/nut: Rebase patches (diff)
downloadgentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.tar.gz
gentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.tar.bz2
gentoo-bb868e6b88a71685c5e38841ef6fce3b4d364299.zip
media-libs/glfw-3.3.1 version bump
As of 2019-04-16, glfw has migrated to Github. This commit updates media-libs/glfw-3.2.1 to use the Github release (which has a different SHA) instead of the Sourceforge release. Signed-off-by: Dale Lukas Peterson <hazelnusse@gmail.com> Closes: https://bugs.gentoo.org/683950 Closes: https://github.com/gentoo/gentoo/pull/14273 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/glfw/Manifest3
-rw-r--r--media-libs/glfw/glfw-3.2.1.ebuild4
-rw-r--r--media-libs/glfw/glfw-3.3.1.ebuild46
-rw-r--r--media-libs/glfw/metadata.xml2
4 files changed, 51 insertions, 4 deletions
diff --git a/media-libs/glfw/Manifest b/media-libs/glfw/Manifest
index 4b0900748490..c6bef6eab775 100644
--- a/media-libs/glfw/Manifest
+++ b/media-libs/glfw/Manifest
@@ -1 +1,2 @@
-DIST glfw-3.2.1.tar.bz2 654840 BLAKE2B 3140aea8fbbf5b9cb5106229408bb013cd613da506e1e06be32f68a2b1042e091eddd464417ac1f171f88e978715c14355ceac94df1c39dc3e358d38e1992a14 SHA512 4371285ae72a428c77440baaf5e92fd83e51eafc2c7f024e8ae9f5a4068623c86d73ae70799b3c7775d1f5984de8be408386f3960303522aa9144dd6b2c21bef
+DIST glfw-3.2.1.tar.gz 472450 BLAKE2B abffe6580dee968baa23f8f4f38af164f7479fe0bf3c4d64cc6386b1450aee4a8e8de5f963faecd536e2bbbc925da7ac1dcc16f219984758950263e6b6d022e1 SHA512 c7921f993b9a99b3b9421fefadb039cd475c42d85f5b5a35d7c5401c70491349bb885a02fd31e527de06a8b40d9d49a1fdb92c964e13c04ae092c6b98eb491dc
+DIST glfw-3.3.1.tar.gz 760014 BLAKE2B 72d23a612157b2083dc6950ff7a2531490d1440f24008fca39646860ea7f9e61eedc5d3c96edb024a125f2e9a1ef65780b4a672aa001bcbc6f41d908e904f966 SHA512 f9376002314eae5518ca63738cf1558433007dbf628fb6093a6f54c330f72d85e0ac30049877c50bc99f029e3eb6f69e69508f412d1ec9bdde0ac721dbbeba1e
diff --git a/media-libs/glfw/glfw-3.2.1.ebuild b/media-libs/glfw/glfw-3.2.1.ebuild
index 9042d28f2df1..3f8a54aea0a2 100644
--- a/media-libs/glfw/glfw-3.2.1.ebuild
+++ b/media-libs/glfw/glfw-3.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -6,7 +6,7 @@ inherit cmake-utils
DESCRIPTION="The Portable OpenGL FrameWork"
HOMEPAGE="https://www.glfw.org/"
-SRC_URI="mirror://sourceforge/glfw/${P}.tar.bz2"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
diff --git a/media-libs/glfw/glfw-3.3.1.ebuild b/media-libs/glfw/glfw-3.3.1.ebuild
new file mode 100644
index 000000000000..fed5798ce2ab
--- /dev/null
+++ b/media-libs/glfw/glfw-3.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="The Portable OpenGL FrameWork"
+HOMEPAGE="https://www.glfw.org/"
+SRC_URI="https://github.com/glfw/glfw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="examples wayland"
+
+RDEPEND="
+ x11-libs/libxkbcommon
+ !wayland? (
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcursor
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ )
+ wayland? (
+ dev-libs/wayland
+ media-libs/mesa[egl,wayland]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ wayland? (
+ dev-libs/wayland-protocols
+ kde-frameworks/extra-cmake-modules
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DGLFW_BUILD_EXAMPLES="$(usex examples)"
+ -DGLFW_USE_WAYLAND="$(usex wayland)"
+ -DBUILD_SHARED_LIBS=1
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-libs/glfw/metadata.xml b/media-libs/glfw/metadata.xml
index 1236bfe275a1..19c47b0974ba 100644
--- a/media-libs/glfw/metadata.xml
+++ b/media-libs/glfw/metadata.xml
@@ -6,6 +6,6 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
- <remote-id type="sourceforge">glfw</remote-id>
+ <remote-id type="github">glfw/glfw</remote-id>
</upstream>
</pkgmetadata>