summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-06-07 14:42:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-06-07 14:42:18 +0200
commitc0e7ffe1a6e34be0172d32d11f92b69cfe5a1efc (patch)
treecb3686625f28e94b243726867ce73ce5532c86a1 /media-libs
parentdev-libs/boost: Silence <boost/bind.hpp> warning (diff)
downloadgentoo-c0e7ffe1a6e34be0172d32d11f92b69cfe5a1efc.tar.gz
gentoo-c0e7ffe1a6e34be0172d32d11f92b69cfe5a1efc.tar.bz2
gentoo-c0e7ffe1a6e34be0172d32d11f92b69cfe5a1efc.zip
media-libs/x265: Fix typo for ppc asm on main variant
This was causing cmakeargs to be ignored Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x265/x265-3.4.ebuild18
-rw-r--r--media-libs/x265/x265-9999.ebuild18
2 files changed, 30 insertions, 6 deletions
diff --git a/media-libs/x265/x265-3.4.ebuild b/media-libs/x265/x265-3.4.ebuild
index a3ce2faae8c2..8d6664cdef27 100644
--- a/media-libs/x265/x265-3.4.ebuild
+++ b/media-libs/x265/x265-3.4.ebuild
@@ -73,6 +73,8 @@ x265_variant_src_configure() {
mkdir -p "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" >/dev/null || die
+ einfo "Configuring variant: ${MULTIBUILD_VARIANT} for ABI: ${ABI}"
+
local mycmakeargs=( "${myabicmakeargs[@]}" )
case "${MULTIBUILD_VARIANT}" in
"main12")
@@ -91,7 +93,12 @@ x265_variant_src_configure() {
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
# disable altivec for 12bit build #607802#c5
- [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
+ if [[ ${ABI} = ppc* ]] ; then
+ mycmakeargs+=(
+ -DENABLE_ALTIVEC=OFF
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ )
+ fi
;;
"main10")
mycmakeargs+=(
@@ -108,7 +115,12 @@ x265_variant_src_configure() {
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
# disable altivec for 10bit build #607802#c5
- [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
+ if [[ ${ABI} = ppc* ]] ; then
+ mycmakeargs+=(
+ -DENABLE_ALTIVEC=OFF
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ )
+ fi
;;
"main")
if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
@@ -126,7 +138,7 @@ x265_variant_src_configure() {
-DLINKED_12BIT=$(usex 12bit)
)
if [[ ${ABI} = ppc* ]] ; then
- myabicmakeargs+=(
+ mycmakeargs+=(
-DCPU_POWER8=$(usex power8 ON OFF)
-DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
)
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index a3ce2faae8c2..8d6664cdef27 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -73,6 +73,8 @@ x265_variant_src_configure() {
mkdir -p "${BUILD_DIR}" || die
pushd "${BUILD_DIR}" >/dev/null || die
+ einfo "Configuring variant: ${MULTIBUILD_VARIANT} for ABI: ${ABI}"
+
local mycmakeargs=( "${myabicmakeargs[@]}" )
case "${MULTIBUILD_VARIANT}" in
"main12")
@@ -91,7 +93,12 @@ x265_variant_src_configure() {
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
# disable altivec for 12bit build #607802#c5
- [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
+ if [[ ${ABI} = ppc* ]] ; then
+ mycmakeargs+=(
+ -DENABLE_ALTIVEC=OFF
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ )
+ fi
;;
"main10")
mycmakeargs+=(
@@ -108,7 +115,12 @@ x265_variant_src_configure() {
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
# disable altivec for 10bit build #607802#c5
- [[ ${ABI} = ppc* ]] && mycmakeargs+=( -DENABLE_ALTIVEC=OFF )
+ if [[ ${ABI} = ppc* ]] ; then
+ mycmakeargs+=(
+ -DENABLE_ALTIVEC=OFF
+ -DCPU_POWER8=$(usex power8 ON OFF)
+ )
+ fi
;;
"main")
if (( "${#MULTIBUILD_VARIANTS[@]}" > 1 )) ; then
@@ -126,7 +138,7 @@ x265_variant_src_configure() {
-DLINKED_12BIT=$(usex 12bit)
)
if [[ ${ABI} = ppc* ]] ; then
- myabicmakeargs+=(
+ mycmakeargs+=(
-DCPU_POWER8=$(usex power8 ON OFF)
-DENABLE_ALTIVEC=$(usex cpu_flags_ppc_altivec ON OFF)
)