summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-06-05 17:18:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-06-05 17:19:54 +0200
commitcfb43e2ae25d60d88c0a341fb86a57ef9b9ce12e (patch)
tree50430d42eb0f603fe37891b83d4fbdf71971ef0c /media-libs
parentmedia-libs/x265: forward port ppc changes (diff)
downloadgentoo-cfb43e2ae25d60d88c0a341fb86a57ef9b9ce12e.tar.gz
gentoo-cfb43e2ae25d60d88c0a341fb86a57ef9b9ce12e.tar.bz2
gentoo-cfb43e2ae25d60d88c0a341fb86a57ef9b9ce12e.zip
media-libs/x265: extend arm neon special cases to arm64
Fixes build on arm64 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/x265/x265-3.4.ebuild4
-rw-r--r--media-libs/x265/x265-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/x265/x265-3.4.ebuild b/media-libs/x265/x265-3.4.ebuild
index e40ca0e08769..a3ce2faae8c2 100644
--- a/media-libs/x265/x265-3.4.ebuild
+++ b/media-libs/x265/x265-3.4.ebuild
@@ -86,7 +86,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
- if [[ ${ABI} = arm ]] ; then
+ if [[ ${ABI} = arm* ]] ; then
# 589674
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
@@ -103,7 +103,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
- if [[ ${ABI} = arm ]] ; then
+ if [[ ${ABI} = arm* ]] ; then
# 589674
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index e40ca0e08769..a3ce2faae8c2 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -86,7 +86,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
- if [[ ${ABI} = arm ]] ; then
+ if [[ ${ABI} = arm* ]] ; then
# 589674
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
@@ -103,7 +103,7 @@ x265_variant_src_configure() {
if [[ ${ABI} = x86 ]] ; then
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
- if [[ ${ABI} = arm ]] ; then
+ if [[ ${ABI} = arm* ]] ; then
# 589674
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi