summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-02-07 00:13:43 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-02-22 18:06:15 +0100
commite0e9a97860b81742efd2891f956db03d70950490 (patch)
tree3e92cb4c80a531637f73014c47c7882387e0cb5c /media-libs
parentdev-cpp/libcmis: Add upstream patches to fix bugs 556914, 569614 (diff)
downloadgentoo-e0e9a97860b81742efd2891f956db03d70950490.tar.gz
gentoo-e0e9a97860b81742efd2891f956db03d70950490.tar.bz2
gentoo-e0e9a97860b81742efd2891f956db03d70950490.zip
media-libs/libvisio: Fix tests (bugs 563326, 556922); drop old
All tests passed. Package-Manager: portage-2.2.27
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch25
-rw-r--r--media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch12
-rw-r--r--media-libs/libvisio/libvisio-0.1.3-r1.ebuild20
-rw-r--r--media-libs/libvisio/libvisio-0.1.3.ebuild55
4 files changed, 50 insertions, 62 deletions
diff --git a/media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch b/media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch
new file mode 100644
index 000000000000..f7e703552f4d
--- /dev/null
+++ b/media-libs/libvisio/files/libvisio-0.1.3-fix-importtest.patch
@@ -0,0 +1,25 @@
+From a97d30ad693374deab404ec31fe00665882cc949 Mon Sep 17 00:00:00 2001
+From: David Tardon <dtardon@redhat.com>
+Date: Mon, 18 Jan 2016 13:53:19 +0100
+Subject: [PATCH] tdf#92396 test must be run in specific time zone
+
+Change-Id: Idc9d85ae8c5c1a6eccca7e830baa05a867ac4402
+---
+ src/test/Makefile.am | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/test/Makefile.am b/src/test/Makefile.am
+index 59d3419..23049b5 100644
+--- a/src/test/Makefile.am
++++ b/src/test/Makefile.am
+@@ -29,4 +29,7 @@ EXTRA_DIST = \
+ data/dwg.vsdx \
+ $(test_SOURCES)
+
++# ImportTest::testVsdMetadataTitleUtf8 checks formatted date string
++AM_TESTS_ENVIRONMENT = TZ=CET; export TZ;
++
+ TESTS = test
+--
+1.7.9.5
+
diff --git a/media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch b/media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch
new file mode 100644
index 000000000000..78eb9fe66bc9
--- /dev/null
+++ b/media-libs/libvisio/files/libvisio-0.1.3-tests-without-tools.patch
@@ -0,0 +1,12 @@
+--- a/configure.ac 2015-07-25 09:29:53.000000000 +0200
++++ b/configure.ac 2016-02-07 00:19:30.534383076 +0100
+@@ -317,6 +317,9 @@
+ )
+ AS_IF([test "x$enable_tests" = "xyes"], [
+ PKG_CHECK_MODULES([CPPUNIT], [cppunit])
++ PKG_CHECK_MODULES([REVENGE_STREAM],[
++ librevenge-stream-0.0
++ ])
+ ], [])
+ AC_SUBST([CPPUNIT_CFLAGS])
+ AC_SUBST([CPPUNIT_LIBS])
diff --git a/media-libs/libvisio/libvisio-0.1.3-r1.ebuild b/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
index 0770f0fd1d4a..8c2449a7e3c1 100644
--- a/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
+++ b/media-libs/libvisio/libvisio-0.1.3-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
+inherit autotools eutils
+[[ ${PV} == 9999 ]] && inherit git-r3
DESCRIPTION="Library parsing the visio documents"
HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
@@ -33,12 +33,18 @@ DEPEND="${RDEPEND}
test? ( dev-util/cppunit )
"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-tests.patch"
+ "${FILESDIR}/${P}-fix-importtest.patch"
+ "${FILESDIR}/${P}-tests-without-tools.patch"
+ "${FILESDIR}/${P}-boost-1.59.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-fix-tests.patch" \
- "${FILESDIR}/${P}-boost-1.59.patch"
+ epatch "${PATCHES[@]}"
+ epatch_user
[[ -d m4 ]] || mkdir "m4"
- base_src_prepare
- [[ ${PV} == 9999 ]] && eautoreconf
+ eautoreconf
}
src_configure() {
diff --git a/media-libs/libvisio/libvisio-0.1.3.ebuild b/media-libs/libvisio/libvisio-0.1.3.ebuild
deleted file mode 100644
index 591d1b34eb80..000000000000
--- a/media-libs/libvisio/libvisio-0.1.3.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
-inherit base eutils
-[[ ${PV} == 9999 ]] && inherit autotools git-r3
-
-DESCRIPTION="Library parsing the visio documents"
-HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
-
-LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
-IUSE="doc static-libs test tools"
-
-RDEPEND="
- dev-libs/icu:=
- dev-libs/librevenge
- dev-libs/libxml2
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- >=dev-libs/boost-1.46
- dev-util/gperf
- sys-devel/libtool
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
- test? ( dev-util/cppunit )
-"
-
-src_prepare() {
- [[ -d m4 ]] || mkdir "m4"
- base_src_prepare
- [[ ${PV} == 9999 ]] && eautoreconf
-}
-
-src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable static-libs static) \
- --disable-werror \
- $(use_with doc docs) \
- $(use_enable test tests) \
- $(use_enable tools)
-}
-
-src_install() {
- default
- prune_libtool_files --all
-}