summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 17:34:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-28 17:50:45 +0100
commite7bfacad23ebcfdcdbd1d4b2b2c23bdef2a3e071 (patch)
treeaad920cdacd28cfd9a103a8caeac778deadc04e7 /media-libs
parentmedia-libs/vigra: Sync cmake.eclass and python3_9 to live ebuild (diff)
downloadgentoo-e7bfacad23ebcfdcdbd1d4b2b2c23bdef2a3e071.tar.gz
gentoo-e7bfacad23ebcfdcdbd1d4b2b2c23bdef2a3e071.tar.bz2
gentoo-e7bfacad23ebcfdcdbd1d4b2b2c23bdef2a3e071.zip
media-libs/opencollada: Drop 1.6.63-r1
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/opencollada/Manifest1
-rw-r--r--media-libs/opencollada/files/opencollada-1.6.62-cmake-fixes.patch122
-rw-r--r--media-libs/opencollada/opencollada-1.6.63-r1.ebuild72
3 files changed, 0 insertions, 195 deletions
diff --git a/media-libs/opencollada/Manifest b/media-libs/opencollada/Manifest
index b273d534738d..a06cbc7d0249 100644
--- a/media-libs/opencollada/Manifest
+++ b/media-libs/opencollada/Manifest
@@ -1,2 +1 @@
-DIST opencollada-1.6.63.tar.gz 12094044 BLAKE2B dbe38ab2976f72d47a38bd147e05a58555acc2b70618d4d47d2beff87ace54f7fcd2f116b9ba9908cfb38b5699e547375e902128c2f378c295308f1601a18b17 SHA512 e1b92e932d0256224b026281fb5691219c5171f57b968307288b6e5481b5d6fee39825702e18017055bd0fb0e3d4c40b6ce526d3ce4defe2994138db54220d01
DIST opencollada-1.6.68.tar.gz 12098718 BLAKE2B 45e0cd788b50a9a528b120e3cf8385803fa3dab0baaf8e28026cea8bf9afb0ab6b3d37f1d67803c9a48dae94d41efb9b5da119f75bd22a697c50c332d626cde2 SHA512 1b875ac2f59344aa33486f9e7479f76e94d58d5b567f17438c002cbfb36685fb38420467804c9eb28657d71d7efad550a24873dfe940d781c2a733c831532173
diff --git a/media-libs/opencollada/files/opencollada-1.6.62-cmake-fixes.patch b/media-libs/opencollada/files/opencollada-1.6.62-cmake-fixes.patch
deleted file mode 100644
index 8fc32784daa7..000000000000
--- a/media-libs/opencollada/files/opencollada-1.6.62-cmake-fixes.patch
+++ /dev/null
@@ -1,122 +0,0 @@
-From c3ed65c2c60b8744163b3a57cf24469e688536dd Mon Sep 17 00:00:00 2001
-From: Jonathan Scruggs <j.scruggs@gmail.com>
-Date: Sat, 13 Jan 2018 11:54:44 +0000
-Subject: [PATCH] OpenCOLLADA/CMakeLists.txt
-
-Use CMAKE_BUILD_TYPE which can be overrided with custom distro types
-
-Adhere to GNU filesystem layout conventions. Not all distros and OSes
-have directories in the same locations and they define the
-GNUInstallDirs variables, so use those variables. Also, this enables
-multi lib installations.
-
-Define the version variables to enable SONAME versioning on the
-library files in case there is ABI changes in the future.
----
- CMakeLists.txt | 58 ++++++++++++++++++++++++++++++++++++----------------------
- 1 file changed, 36 insertions(+), 22 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 95abbe21..00ad8d6a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -37,14 +37,41 @@ cmake_policy(SET CMP0010 NEW)
- # Input directories must have CMakeLists.txt
- cmake_policy(SET CMP0014 NEW)
-
--# avoid having empty buildtype
--set(CMAKE_BUILD_TYPE_INIT "Release")
-
--set(CMAKE_CONFIGURATION_TYPES "Debug;Release" CACHE STRING "Only do Release and Debug" FORCE )
--mark_as_advanced(CMAKE_CONFIGURATION_TYPES)
-+# Set Release type for builds where CMAKE_BUILD_TYPE is unset
-+# This is usually a good default as this implictly enables
-+#
-+# CXXFLAGS = -O3 -DNDEBUG
-+#
-+if( NOT CMAKE_BUILD_TYPE )
-+ set( CMAKE_BUILD_TYPE "Release" )
-+endif()
-
- SET(CMAKE_DEBUG_POSTFIX "" CACHE STRING "Add this string to as suffix to Debug libraries, e.g.: xml2_d.lib " )
-
-+# Adhere to GNU filesystem layout conventions
-+include( GNUInstallDirs )
-+
-+
-+# #-----------------------------------------------------------------------------
-+# Initialize project.
-+
-+project(OPENCOLLADA) # must be after setting cmake_configuration_types
-+
-+set(EXTERNAL_LIBRARIES ${OPENCOLLADA_SOURCE_DIR}/Externals) # external libraries
-+set(CMAKE_MODULE_PATH "${EXTERNAL_LIBRARIES}/cmake-modules")
-+
-+set(OPENCOLLADA_VERSION_MAJOR 1)
-+set(OPENCOLLADA_VERSION_MINOR 6)
-+set(OPENCOLLADA_VERSION_PATCH 62)
-+set(OPENCOLLADA_VERSION ${OPENCOLLADA_VERSION_MAJOR}.${OPENCOLLADA_VERSION_MINOR}.${OPENCOLLADA_VERSION_PATCH})
-+
-+if(NOT SOVERSION)
-+ set(SOVERSION ${OPENCOLLADA_VERSION_MAJOR}.${OPENCOLLADA_VERSION_MINOR}
-+ CACHE STRING "Set the SO version in the SO name of the output library")
-+endif()
-+
-+
- #-----------------------------------------------------------------------------
- # Macro's
-
-@@ -58,7 +85,7 @@ macro(opencollada_add_lib
-
- if (USE_STATIC)
- add_library(${name}_static STATIC ${sources})
-- set_target_properties(${name}_static PROPERTIES OUTPUT_NAME ${name})
-+ set_target_properties(${name}_static PROPERTIES OUTPUT_NAME ${name} SOVERSION ${SOVERSION})
- foreach(target_lib ${target_libs})
- if(TARGET ${target_lib}_static)
- target_link_libraries(${name}_static ${target_lib}_static)
-@@ -84,7 +111,7 @@ macro(opencollada_add_lib
- message(${name} " WARNING: Shared library support implemented for UNIX-like OS only")
- endif ()
- add_library(${name}_shared SHARED ${sources})
-- set_target_properties(${name}_shared PROPERTIES OUTPUT_NAME ${name})
-+ set_target_properties(${name}_shared PROPERTIES OUTPUT_NAME ${name} SOVERSION ${SOVERSION})
- foreach(target_lib ${target_libs})
- if(TARGET ${target_lib}_shared)
- target_link_libraries(${name}_shared ${target_lib}_shared)
-@@ -145,19 +172,6 @@ endmacro()
- # end copy
- # --------
-
--#-----------------------------------------------------------------------------
--# Initialize project.
--
--project(OPENCOLLADA) # must be after setting cmake_configuration_types
--
--set(EXTERNAL_LIBRARIES ${OPENCOLLADA_SOURCE_DIR}/Externals) # external libraries
--set(CMAKE_MODULE_PATH "${EXTERNAL_LIBRARIES}/cmake-modules")
--
--set(OPENCOLLADA_VERSION_MAJOR 0)
--set(OPENCOLLADA_VERSION_MINOR 1)
--set(OPENCOLLADA_VERSION_PATCH 0)
--set(OPENCOLLADA_VERSION ${OPENCOLLADA_VERSION_MAJOR}.${OPENCOLLADA_VERSION_MINOR}.${OPENCOLLADA_VERSION_PATCH})
--
-
- #-----------------------------------------------------------------------------
- # Compiler warnings.
-@@ -190,9 +204,9 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${CXX_WARNINGS}")
- #-----------------------------------------------------------------------------
- # Install vars
-
--set(OPENCOLLADA_INST_INCLUDE ${CMAKE_INSTALL_PREFIX}/include/opencollada)
--set(OPENCOLLADA_INST_LIBRARY ${CMAKE_INSTALL_PREFIX}/lib/opencollada)
--set(OPENCOLLADA_INST_CMAKECONFIG ${OPENCOLLADA_INST_LIBRARY}/cmake)
-+set(OPENCOLLADA_INST_INCLUDE ${CMAKE_INSTALL_FULL_INCLUDEDIR}/opencollada)
-+set(OPENCOLLADA_INST_LIBRARY ${CMAKE_INSTALL_FULL_LIBDIR}/opencollada)
-+set(OPENCOLLADA_INST_CMAKECONFIG ${CMAKE_INSTALL_FULL_LIBDIR}/cmake/OpenCOLLADA)
-
-
- #-----------------------------------------------------------------------------
---
-2.15.1
-
diff --git a/media-libs/opencollada/opencollada-1.6.63-r1.ebuild b/media-libs/opencollada/opencollada-1.6.63-r1.ebuild
deleted file mode 100644
index 1ed2b159eba1..000000000000
--- a/media-libs/opencollada/opencollada-1.6.63-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils eutils flag-o-matic
-
-DESCRIPTION="Stream based read/write library for COLLADA files"
-HOMEPAGE="http://www.opencollada.org/"
-SRC_URI="https://github.com/KhronosGroup/OpenCOLLADA/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE="static-libs"
-
-RDEPEND="dev-libs/libpcre
- dev-libs/libxml2
- dev-libs/zziplib
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/OpenCOLLADA-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.6.62-cmake-fixes.patch"
- "${FILESDIR}/${P}-pcre-fix.patch"
-)
-
-src_prepare() {
- edos2unix CMakeLists.txt
-
- cmake-utils_src_prepare
-
- # Remove bundled depends that have portage equivalents
- rm -rv Externals/{expat,lib3ds,LibXML,pcre,zziplib} || die
-
- # Remove unused build systems
- rm -v Makefile scripts/{unixbuild.sh,vcproj2cmake.rb} || die
- find "${S}" -name SConscript -delete || die
-}
-
-src_configure() {
- # bug 619670
- append-cxxflags -std=c++14
-
- local mycmakeargs=(
- -DUSE_SHARED=ON
- -DUSE_STATIC=$(usex static-libs)
- -DUSE_LIBXML=ON
- )
-
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
-
- echo "LDPATH=/usr/$(get_libdir)/opencollada" > "${T}"/99${PN} || die "echo failed"
- doenvd "${T}"/99${PN}
-
- dobin "${BUILD_DIR}/bin/DAEValidator"
- dobin "${BUILD_DIR}/bin/OpenCOLLADAValidator"
- # Need to be in same directory as above binaries
- docinto "/usr/bin"
- dodoc "${BUILD_DIR}/bin/COLLADAPhysX3Schema.xsd"
- dodoc "${BUILD_DIR}/bin/collada_schema_1_4_1.xsd"
- dodoc "${BUILD_DIR}/bin/collada_schema_1_5.xsd"
-}