summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-08-27 18:00:40 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2016-08-27 18:00:40 +0100
commitf870df2ea4d29117f5ad843fd0e67305127e95ca (patch)
treef6ca3baf50b1088bc7cce00ae15f8961d4fd09c9 /media-libs
parentapp-emulation/fuse: workaround underlinking against libm, bug #370265 (diff)
downloadgentoo-f870df2ea4d29117f5ad843fd0e67305127e95ca.tar.gz
gentoo-f870df2ea4d29117f5ad843fd0e67305127e95ca.tar.bz2
gentoo-f870df2ea4d29117f5ad843fd0e67305127e95ca.zip
media-libs/slv2: fix libdl and libraptor2 underlinking, bug #371747
Thanks ftrvxmtrx for the fix! Reported-by: Diego Elio Pettenò Bug: https://bugs.gentoo.org/371747 Package-Manager: portage-2.3.0
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/slv2/files/slv2-0.6.6-raptor2-link.patch23
-rw-r--r--media-libs/slv2/slv2-0.6.6-r1.ebuild3
-rw-r--r--media-libs/slv2/slv2-0.6.6.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/media-libs/slv2/files/slv2-0.6.6-raptor2-link.patch b/media-libs/slv2/files/slv2-0.6.6-raptor2-link.patch
new file mode 100644
index 000000000000..a6a113a7627c
--- /dev/null
+++ b/media-libs/slv2/files/slv2-0.6.6-raptor2-link.patch
@@ -0,0 +1,23 @@
+To reproduce it run:
+ $ LDFLAGS="-Wl,--no-undefined" emerge -1 slv2
+Fixes https://bugs.gentoo.org/371747 by ftrvxmtrx
+--- slv2-0.6.6.orig/wscript 2009-05-26 05:44:51.000000000 +0200
++++ slv2-0.6.6/wscript 2014-01-21 00:46:19.890443103 +0100
+@@ -51,6 +51,7 @@
+ autowaf.check_pkg(conf, 'lv2core', uselib_store='LV2CORE', atleast_version='1.0', mandatory=True)
+ autowaf.check_pkg(conf, 'redland', uselib_store='REDLAND', atleast_version='1.0.6', mandatory=True)
+ autowaf.check_pkg(conf, 'jack', uselib_store='JACK', atleast_version='0.107.0', mandatory=False)
++ autowaf.check_pkg(conf, 'raptor2', uselib_store='RAPTOR2', atleast_version='2.0.8', mandatory=True)
+ conf.env.append_value('CCFLAGS', '-std=c99')
+ conf.define('SLV2_VERSION', SLV2_VERSION)
+ conf.write_config_header('slv2-config.h')
+@@ -96,7 +97,8 @@
+ obj.target = 'slv2'
+ obj.vnum = SLV2_LIB_VERSION
+ obj.install_path = '${LIBDIR}'
+- autowaf.use_lib(bld, obj, 'REDLAND LV2CORE')
++ obj.lib = ['dl']
++ autowaf.use_lib(bld, obj, 'REDLAND LV2CORE RAPTOR2')
+
+ # Static library (for unit test code coverage)
+ if bld.env['BUILD_TESTS']:
diff --git a/media-libs/slv2/slv2-0.6.6-r1.ebuild b/media-libs/slv2/slv2-0.6.6-r1.ebuild
index 97cf5d40cd6c..183cc6653a1a 100644
--- a/media-libs/slv2/slv2-0.6.6-r1.ebuild
+++ b/media-libs/slv2/slv2-0.6.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -27,6 +27,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/ldconfig.patch
+ epatch "${FILESDIR}"/${P}-raptor2-link.patch
}
src_configure() {
diff --git a/media-libs/slv2/slv2-0.6.6.ebuild b/media-libs/slv2/slv2-0.6.6.ebuild
index afd57fec31cf..349e1e56ad3a 100644
--- a/media-libs/slv2/slv2-0.6.6.ebuild
+++ b/media-libs/slv2/slv2-0.6.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -29,6 +29,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/ldconfig.patch
+ epatch "${FILESDIR}"/${P}-raptor2-link.patch
}
src_configure() {