summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2020-09-21 23:22:51 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2020-09-21 23:29:54 +0200
commitf9f64633a057f7786333baeda436b0b37d81c055 (patch)
tree7b6a5c2599eca2ebc78bdebb0e5bd6a87b2d74f0 /media-libs
parentdev-python/cached-property: Bump to 1.5.2 (diff)
downloadgentoo-f9f64633a057f7786333baeda436b0b37d81c055.tar.gz
gentoo-f9f64633a057f7786333baeda436b0b37d81c055.tar.bz2
gentoo-f9f64633a057f7786333baeda436b0b37d81c055.zip
media-libs/SoXt: Version bump, remove old.
Closes: https://bugs.gentoo.org/738750 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/SoXt/Manifest2
-rw-r--r--media-libs/SoXt/SoXt-1.3.0-r1.ebuild47
-rw-r--r--media-libs/SoXt/SoXt-1.4.0.ebuild42
-rw-r--r--media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch12
-rw-r--r--media-libs/SoXt/metadata.xml2
5 files changed, 44 insertions, 61 deletions
diff --git a/media-libs/SoXt/Manifest b/media-libs/SoXt/Manifest
index ec83bff7d091..3071e910b50a 100644
--- a/media-libs/SoXt/Manifest
+++ b/media-libs/SoXt/Manifest
@@ -1 +1 @@
-DIST SoXt-1.3.0.tar.gz 1203903 BLAKE2B da64285656b57c7b90bb3dfba089dbea79ce6755aa36cee2fca1e64ad4945099e68474263a16ac97b34187207266b025734c352656c972fe66402717b94c9340 SHA512 1aae8c6d0b5e8de52734dac0326f9bcbae343a1819d18bb915f8f6fa223782e3512286819af62f494ce5238b8e1d981af5322186b2c07a94be20b7c9d32db208
+DIST SoXt-1.4.0-src.tar.gz 1369725 BLAKE2B 727c56644878e9d52441ca905558524ccd369de123e8018d7fef4d949aa4e96007fa3a1e9782490b4dc9d50a916686a118d37ec7094dc6a3522ede032b30b6ea SHA512 9c661396ec18c2cba8984be8c0875f51554c8845e1a85d9b202f9a0f4de8203566a46d9b276e20039861dbf7ff3a0ffa474d098866f8a7692b53a01e3f62977d
diff --git a/media-libs/SoXt/SoXt-1.3.0-r1.ebuild b/media-libs/SoXt/SoXt-1.3.0-r1.ebuild
deleted file mode 100644
index 9a19d7672949..000000000000
--- a/media-libs/SoXt/SoXt-1.3.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-HOMEPAGE="http://www.coin3d.org/"
-DESCRIPTION="GUI binding for using Coin/Open Inventor with Xt/Motif"
-SRC_URI="https://bitbucket.org/Coin3D/coin/downloads/${P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="debug doc static-libs"
-
-RDEPEND="
- <media-libs/coin-4
- x11-libs/motif:0
- virtual/opengl"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.3.0-pkgconfig-partial.patch"
-)
-
-DOCS=(AUTHORS ChangeLog HACKING NEWS README TODO BUGS.txt)
-
-src_configure() {
- local myeconfargs=(
- htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- --disable-compact
- --disable-html-help
- --includedir="$(coin-config --includedir)"
- --with-coin
- --with-motif
- $(use_enable debug)
- $(use_enable debug profile)
- $(use_enable doc html)
- $(use_enable doc man)
- )
- default
- # Remove SoXt from Libs.private (patch installs it in Libs)
- sed -i -e '/Libs.private/s/ -lSoXt//' SoXt.pc || die
- # Strip the default libdir
- sed -i -e "s,-L%{_libdir} ,," soxt-default.cfg || die
-}
diff --git a/media-libs/SoXt/SoXt-1.4.0.ebuild b/media-libs/SoXt/SoXt-1.4.0.ebuild
new file mode 100644
index 000000000000..0915565de4dd
--- /dev/null
+++ b/media-libs/SoXt/SoXt-1.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake flag-o-matic
+
+MY_P=${P/soxt/SoXt}
+
+HOMEPAGE="https://github.com/coin3d/coin/wiki"
+DESCRIPTION="GUI binding for using Coin/Open Inventor with Xt/Motif"
+SRC_URI="https://github.com/coin3d/soxt/releases/download/${MY_P}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="debug doc"
+
+RDEPEND="
+ media-libs/coin
+ x11-libs/motif:0
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+S="${WORKDIR}/soxt"
+
+DOCS=(AUTHORS ChangeLog HACKING NEWS README TODO BUGS.txt)
+
+src_configure() {
+ use debug && append-cppflags -DSOXT_DEBUG=1
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}/usr/share/doc/${PF}"
+ -DSOXT_BUILD_DOCUMENTATION=$(usex doc)
+ -DSOXT_BUILD_INTERNAL_DOCUMENTATION=OFF
+ -DSOXT_VERBOSE=$(usex debug)
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch b/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch
deleted file mode 100644
index d9f1ad25eeff..000000000000
--- a/media-libs/SoXt/files/SoXt-1.3.0-pkgconfig-partial.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/SoXt.pc.in 2013-06-17 11:26:59.998321839 -0700
-+++ b/SoXt.pc.in 2013-06-17 11:28:01.603654611 -0700
-@@ -10,7 +10,8 @@
- Version: @SOXT_VERSION@
- Requires: Coin
- Conflicts:
--Libs: -L${libdir} @SOGUI_EXTRA_LDFLAGS@ @SOGUI_EXTRA_LIBS@
-+Libs: -L${libdir} -lSoXt
-+Libs.private: -L${libdir} @SOGUI_EXTRA_LIBS@
- Cflags: -I${includedir} @SOGUI_EXTRA_CFLAGS@ @SOGUI_EXTRA_CPPFLAGS@
-
- soxt_host=@host@
diff --git a/media-libs/SoXt/metadata.xml b/media-libs/SoXt/metadata.xml
index 418672b1b7bb..a49ad79eefb2 100644
--- a/media-libs/SoXt/metadata.xml
+++ b/media-libs/SoXt/metadata.xml
@@ -12,6 +12,6 @@
from SGI or TGS.
</longdescription>
<upstream>
- <remote-id type="bitbucket">Coin3D/coin</remote-id>
+ <remote-id type="github">coin3d/soxt</remote-id>
</upstream>
</pkgmetadata>