summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/fil-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/fil-plugins')
-rw-r--r--media-plugins/fil-plugins/Manifest1
-rw-r--r--media-plugins/fil-plugins/fil-plugins-0.3.0.ebuild38
-rw-r--r--media-plugins/fil-plugins/files/fil-plugins-makefile.patch21
-rw-r--r--media-plugins/fil-plugins/metadata.xml5
4 files changed, 65 insertions, 0 deletions
diff --git a/media-plugins/fil-plugins/Manifest b/media-plugins/fil-plugins/Manifest
new file mode 100644
index 000000000000..8dd5f0faf3ae
--- /dev/null
+++ b/media-plugins/fil-plugins/Manifest
@@ -0,0 +1 @@
+DIST FIL-plugins-0.3.0.tar.bz2 16833 SHA256 1c0bf271211965f670a15a7783b4167307db77264ac1624a06e5667964da8ee9
diff --git a/media-plugins/fil-plugins/fil-plugins-0.3.0.ebuild b/media-plugins/fil-plugins/fil-plugins-0.3.0.ebuild
new file mode 100644
index 000000000000..9d76f82798e6
--- /dev/null
+++ b/media-plugins/fil-plugins/fil-plugins-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib toolchain-funcs eutils
+
+MY_P=${P/fil/FIL}
+
+DESCRIPTION="FIL-plugins ladspa plugin package. Filters by Fons Adriaensen"
+HOMEPAGE="http://www.kokkinizita.net/linuxaudio/"
+SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="media-libs/ladspa-sdk"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_compile() {
+ tc-export CXX
+ emake || die
+}
+
+src_install() {
+ dodoc AUTHORS README || die
+ insinto /usr/$(get_libdir)/ladspa
+ insopts -m0755
+ doins *.so || die
+}
diff --git a/media-plugins/fil-plugins/files/fil-plugins-makefile.patch b/media-plugins/fil-plugins/files/fil-plugins-makefile.patch
new file mode 100644
index 000000000000..625cab9d7325
--- /dev/null
+++ b/media-plugins/fil-plugins/files/fil-plugins-makefile.patch
@@ -0,0 +1,21 @@
+Index: FIL-plugins-0.3.0/Makefile
+===================================================================
+--- FIL-plugins-0.3.0.orig/Makefile
++++ FIL-plugins-0.3.0/Makefile
+@@ -15,14 +15,14 @@
+ # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+
+-CPPFLAGS += -I. -fPIC -D_REENTRANT -Wall -O3
++CPPFLAGS += -I. -fPIC -D_REENTRANT -Wall
+
+
+ all: filters.so
+
+
+ filters.so: filters.o filters_if.o exp2ap.o
+- g++ -shared filters.o filters_if.o exp2ap.o -o filters.so
++ $(CXX) $(LDFLAGS) -shared filters.o filters_if.o exp2ap.o -o filters.so
+
+ filters.o: ladspaplugin.h filters.h
+ filters_if.o: ladspaplugin.h filters.h
diff --git a/media-plugins/fil-plugins/metadata.xml b/media-plugins/fil-plugins/metadata.xml
new file mode 100644
index 000000000000..3a8ea7e02972
--- /dev/null
+++ b/media-plugins/fil-plugins/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+</pkgmetadata>