summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-18 00:28:20 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-18 00:47:48 +0300
commit01d8dbdd9c862c45de1864a37c1d9a82d1e9fe29 (patch)
tree131302c59f873988b0271414fe41a52f081d20b1 /media-plugins/gst-plugins-gtk
parentmedia-plugins/gst-plugins-dv: bump to 1.14.3, no code changes from 1.14.2 (diff)
downloadgentoo-01d8dbdd9c862c45de1864a37c1d9a82d1e9fe29.tar.gz
gentoo-01d8dbdd9c862c45de1864a37c1d9a82d1e9fe29.tar.bz2
gentoo-01d8dbdd9c862c45de1864a37c1d9a82d1e9fe29.zip
media-plugins/gst-plugins-gtk: bump to 1.14.3, no code changes from 1.14.2
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest1
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index 8d3c3ee96a06..ef7e2de8865c 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-good-1.14.1.tar.xz 3776168 BLAKE2B 5b17ac49d5bae423ee887f1516ba8bfb542acb17e3f304f489dddbaa728761ee51a08e67bd10a9981f53b5b8424d8013d1723fcbbf6e06d34a39548868d34f85 SHA512 b52d3214f2d32f263637cb9f0838284483e15b8d20bf36d64c349e99b481095734a4dd2c2421176540dfe5129ecc1acc101b89cc898b4773f0f736e8e962b070
DIST gst-plugins-good-1.14.2.tar.xz 3779912 BLAKE2B d49f82a6be7423d233ec15660470533d6bfc5da3d2ac5912ce7b3f97739b1540424c02593aff269aae3df7c6f15ca37b2d9d45fe85f3b36b910cdac4ba98f093 SHA512 26ff40d949ab95043ed717350fb344a616c72b049cd52c3e7debd9cc37f73eb9d4704b4f437ba257cecb9dba702ce451647279cb821e9405b36210b46ae9aa05
+DIST gst-plugins-good-1.14.3.tar.xz 3790052 BLAKE2B 14f4116ce3eeb20f1f2cc8e835e46a9444ef82291aad90b74e74d0e79c1974bb6f2373f79543a3a3235773c954bd9def67a9e6c64522035fa65e1541695d34e1 SHA512 1077d4ac7332a4bfd58fe5be53104e1404c3a688769520650c030488a184e64a43b301fc1f1d687de668143f849a23cb0ba2b417cf284d20710b9cf32d792e45
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.3.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.3.ebuild
new file mode 100644
index 000000000000..c4b5c5af5433
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.14.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-bad is build with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"