summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2021-02-13 19:37:56 +0200
committerMart Raudsepp <leio@gentoo.org>2021-02-13 19:37:56 +0200
commit5bada848957709e182b7cf6565669f796327a38d (patch)
tree87c7eb22becb0babafc781008a6645a3eff8beb8 /media-plugins/gst-plugins-gtk
parentmedia-plugins/gst-plugins-gdkpixbuf: bump to 1.16.3 (diff)
downloadgentoo-5bada848957709e182b7cf6565669f796327a38d.tar.gz
gentoo-5bada848957709e182b7cf6565669f796327a38d.tar.bz2
gentoo-5bada848957709e182b7cf6565669f796327a38d.zip
media-plugins/gst-plugins-gtk: bump to 1.16.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins/gst-plugins-gtk')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest1
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index 32073ca6e983..28ae66bf58cc 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1,2 +1,3 @@
DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
DIST gst-plugins-good-1.16.2.tar.xz 3897172 BLAKE2B b6341bb2f2456e2c558f71e9f18726eced88cbc703fa017067415297cc7ccdf70b4ceb18e9e3c7c64fc7c55806c7373d9a05eac582067ab764a02c1bafef4b33 SHA512 ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4
+DIST gst-plugins-good-1.16.3.tar.xz 3914676 BLAKE2B 52f18027f9d9a77e8b459a0a10fa7c1450dff2faf8a2a63134f833ad08b19985b7f0d3d2af4b766c9b8bf802d048fabd6f52ad5a7865eccd1fe0d26404b7b2de SHA512 3e0da4a4defc0ddea1c26dfc767fed732548654f4155452649777109a17d5b65b2fde895483a3e35dc1646de5a16e913cd2408f826251d46a99b7751b88dcb65
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild
new file mode 100644
index 000000000000..9fdf00d8fdce
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"