summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-06-18 10:05:27 +0300
committerMart Raudsepp <leio@gentoo.org>2017-06-18 11:30:01 +0300
commitd5af513e4b528479b367b25b2f705eaba8972b73 (patch)
tree6aadfc400f52bf8ac5e04b9d63d4e884feffa18c /media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild
parentmedia-plugins/gst-plugins-faad: bump to 1.10.5, no code changes compared to 1... (diff)
downloadgentoo-d5af513e4b528479b367b25b2f705eaba8972b73.tar.gz
gentoo-d5af513e4b528479b367b25b2f705eaba8972b73.tar.bz2
gentoo-d5af513e4b528479b367b25b2f705eaba8972b73.zip
media-plugins/gst-plugins-hls: bump to 1.10.5, no code changes compared to 1.10.4
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild')
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild
new file mode 100644
index 000000000000..31ab5b9fc15b
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.10.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ # FIXME: gsturidownloader does not have a .pc
+ # gstreamer_system_link \
+ # gst-libs/gst/uridownloader:gsturidownloader \
+ # gst-libs/gst/adaptativedemux:gstadaptivedemux
+
+ local directory libs
+ directory="gst-libs/gst/uridownloader"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/hls/Makefile.{am,in} || die
+
+ directory="gst-libs/gst/adaptivedemux"
+ libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0"
+ sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \
+ -i ext/hls/Makefile.{am,in} || die
+}
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ --with-hls-crypto=nettle
+}