summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-02-24 21:47:58 +0200
committerMart Raudsepp <leio@gentoo.org>2017-02-24 21:50:24 +0200
commit65b7bef7092403674734a34756b6c25bba86f63f (patch)
treec6be18fd61846554526ffbd235842661a0bd9ee7 /media-plugins/gst-plugins-libav
parentdev-python/pyelftools: drop old <0.24 versions (diff)
downloadgentoo-65b7bef7092403674734a34756b6c25bba86f63f.tar.gz
gentoo-65b7bef7092403674734a34756b6c25bba86f63f.tar.bz2
gentoo-65b7bef7092403674734a34756b6c25bba86f63f.zip
media-plugins/gst-plugins-libav: bump to 1.10.4 for bundled ffmpeg security fixes
Gentoo-bug: 610810 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'media-plugins/gst-plugins-libav')
-rw-r--r--media-plugins/gst-plugins-libav/Manifest1
-rw-r--r--media-plugins/gst-plugins-libav/gst-plugins-libav-1.10.4.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-libav/Manifest b/media-plugins/gst-plugins-libav/Manifest
index 35414002601f..0bc58e81effa 100644
--- a/media-plugins/gst-plugins-libav/Manifest
+++ b/media-plugins/gst-plugins-libav/Manifest
@@ -1,2 +1,3 @@
DIST gst-libav-1.10.3.tar.xz 8535624 SHA256 9a6bc165b1862b18b98d9f1755c43806e4839a80f69ec7ea9a2dab61b65752a9 SHA512 9f394fc5a23fa887e65c851836d338f9eb55be2a981429cfa7175e1112465696b1326386ef45d675bf1186cf8f1fec50dd0861273c763aa20ab97aaa257a1907 WHIRLPOOL 0833598516fd5f71a7cc105a4508f9301aee8c5db3569010ceabd270a8059679661508e8e2ae4e6e9147212f1454868e3244d631fbaff9bdde22ca865247331a
+DIST gst-libav-1.10.4.tar.xz 8535052 SHA256 6ca0feca75e3d48315e07f20ec37cf6260ed1e9dde58df355febd5016246268b SHA512 4037c4651c9f4c0e677f1f8136194c16319507dec3992270c1f98d461a69a55653d261ade45add833103872455e09c30695318181e81242ce78d1c2a2b95ca9c WHIRLPOOL 441ed31e9886a71bace9fadd9edcf8102db621cffa9185c087535e7fa4daedb14dd2cbf3a067868f821d36b58982b482c0c37d82907e079cbe0f3e48bb8a27f3
DIST gst-libav-1.8.3.tar.xz 7958532 SHA256 9006a05990089f7155ee0e848042f6bb24e52ab1d0a59ff8d1b5d7e33001a495 SHA512 49aa96197cd32ad31e280870495d64cdfe4bde67507e9cb166b80d0c394b510e734befa3ff13d6fe0711be0ffa24dd0a63a77fb62af91ab776d9844059cb839d WHIRLPOOL 0109f897ce7d42d21b467b42a661f02900896ea90c085f731b1c69de9c4913de36f3d48544db6fd44a5b828614947b6b9b1d851af2c5f739fbb537ac3022af88
diff --git a/media-plugins/gst-plugins-libav/gst-plugins-libav-1.10.4.ebuild b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.10.4.ebuild
new file mode 100644
index 000000000000..acbe5610a397
--- /dev/null
+++ b/media-plugins/gst-plugins-libav/gst-plugins-libav-1.10.4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils multilib-minimal
+
+MY_PN="gst-libav"
+DESCRIPTION="FFmpeg based gstreamer plugin"
+HOMEPAGE="https://gstreamer.freedesktop.org/modules/gst-libav.html"
+SRC_URI="https://gstreamer.freedesktop.org/src/${MY_PN}/${MY_PN}-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="1.0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="libav +orc"
+
+# XXX: bzip2/lzma are automagic
+# Move back to ${PV} deps of gstreamer/gst-plugins-base later; 1.10.4 had it reduced for lone security stabilization
+RDEPEND="
+ app-arch/bzip2
+ app-arch/xz-utils
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-1.10.3:1.0[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-1.10.3:1.0[${MULTILIB_USEDEP}]
+ !libav? ( >=media-video/ffmpeg-3.2.4:0=[${MULTILIB_USEDEP}] )
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RESTRICT="test" # FIXME: tests seem to get stuck at one point; investigate properly
+
+multilib_src_configure() {
+ GST_PLUGINS_BUILD=""
+ # Upstream dropped support for system libav and won't work
+ # for preserving its compat anymore, forcing us to rely on internal
+ # ffmpeg copy if we don't want to cause unresolvable blockers for
+ # libav setups.
+ # https://bugzilla.gnome.org/show_bug.cgi?id=758183
+ # Prefer system ffmpeg for -libav
+ local myconf
+
+ if use libav; then
+ ewarn "Using internal ffmpeg copy as upstream dropped"
+ ewarn "the support for compiling against system libav"
+ ewarn "http://bugzilla.gnome.org/show_bug.cgi?id=758183"
+ else
+ myconf="--with-system-libav"
+ fi
+
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-maintainer-mode \
+ --with-package-name="Gentoo GStreamer ebuild" \
+ --with-package-origin="https://www.gentoo.org" \
+ --disable-fatal-warnings \
+ $(use_enable orc) \
+ ${myconf}
+}
+
+multilib_src_compile() {
+ # Don't build with -Werror
+ emake ERROR_CFLAGS=
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --modules
+}