summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-04-02 00:07:42 -0400
committerMike Frysinger <vapier@gentoo.org>2016-04-02 00:11:37 -0400
commitf32e2332164a3b76e363763d4ecc73b5cd1fbb87 (patch)
tree5a1f3fa4ea5a79fc72d7e796a79b7cd708ea8af8 /media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild
parentx11-wm/enlightenment: mark 0.20.5 stable (diff)
downloadgentoo-f32e2332164a3b76e363763d4ecc73b5cd1fbb87.tar.gz
gentoo-f32e2332164a3b76e363763d4ecc73b5cd1fbb87.tar.bz2
gentoo-f32e2332164a3b76e363763d4ecc73b5cd1fbb87.zip
media-plugins/imlib2_loaders: version bump to 1.4.8
Diffstat (limited to 'media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild')
-rw-r--r--media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild
new file mode 100644
index 000000000000..8fb93aad1a2b
--- /dev/null
+++ b/media-plugins/imlib2_loaders/imlib2_loaders-1.4.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+else
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="image loader plugins for Imlib 2"
+HOMEPAGE="https://www.enlightenment.org/pages/imlib2.html"
+
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+ eet? ( dev-libs/efl )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable eet)
+ $(use_enable xcf)
+ )
+
+ enlightenment_src_configure
+}