summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2021-01-16 15:53:35 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2021-01-16 16:00:01 +0300
commite26d3281554a06cd8d22d181ed6942768de3a18a (patch)
tree0f55e87a4a88f0e270fb94394c393c0b354f6990 /media-plugins/imlib2_loaders
parentmedia-plugins/imlib2_loaders: pick an orphaned package (diff)
downloadgentoo-e26d3281554a06cd8d22d181ed6942768de3a18a.tar.gz
gentoo-e26d3281554a06cd8d22d181ed6942768de3a18a.tar.bz2
gentoo-e26d3281554a06cd8d22d181ed6942768de3a18a.zip
media-plugins/imlib2_loaders: version bump
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'media-plugins/imlib2_loaders')
-rw-r--r--media-plugins/imlib2_loaders/Manifest1
-rw-r--r--media-plugins/imlib2_loaders/files/imlib2_loaders-1.7.1-loader-api.patch36
-rw-r--r--media-plugins/imlib2_loaders/imlib2_loaders-1.7.1.ebuild38
3 files changed, 75 insertions, 0 deletions
diff --git a/media-plugins/imlib2_loaders/Manifest b/media-plugins/imlib2_loaders/Manifest
index 6498e5921dac..39671ffc8520 100644
--- a/media-plugins/imlib2_loaders/Manifest
+++ b/media-plugins/imlib2_loaders/Manifest
@@ -1 +1,2 @@
DIST imlib2_loaders-1.6.1.tar.gz 375642 BLAKE2B 20f4213e3d84c333faff82910f4f402524e50f567cddcce225678c0706d04c5a9520d8a54956f50be4d42fd231f317573ec091864f1d526336aacc8f7e0ae399 SHA512 1017b3587b2815d8347e9aef3f11649bdaadd48be10fe89d6e6eb8cb1d022723d414869cf12a2bff3eaa2f14c12ffd424767993e07990f8fa3ce5062ab0844fa
+DIST imlib2_loaders-1.7.1.tar.bz2 302348 BLAKE2B 8f73daa5b70d7122c136a001df920649a438edc60d4e7e94b691dfecc0864b66c321c676fb78a2f9e990b842d31fd5f95dcbacf232d6b9809382173449f86673 SHA512 5752768aa61c36e8f8ae5ff9219f950ba7b1561629bb21e4b4e16890d0fa904e93899e64152f05c6d7190553404336ec33b1d88b0cbec46c61a26598e27d449d
diff --git a/media-plugins/imlib2_loaders/files/imlib2_loaders-1.7.1-loader-api.patch b/media-plugins/imlib2_loaders/files/imlib2_loaders-1.7.1-loader-api.patch
new file mode 100644
index 000000000000..981b1ce1e9b1
--- /dev/null
+++ b/media-plugins/imlib2_loaders/files/imlib2_loaders-1.7.1-loader-api.patch
@@ -0,0 +1,36 @@
+diff '--color=auto' -Naurd imlib2_loaders-1.7.1.orig/src/modules/loaders/loader_common.h imlib2_loaders-1.7.1/src/modules/loaders/loader_common.h
+--- imlib2_loaders-1.7.1.orig/src/modules/loaders/loader_common.h 2020-05-21 06:49:09.000000000 +0300
++++ imlib2_loaders-1.7.1/src/modules/loaders/loader_common.h 2021-01-16 15:11:53.229675567 +0300
+@@ -4,6 +4,7 @@
+ #include "config.h"
+ #include "common.h"
+ #include "image.h"
++#include "loaders.h"
+
+ __EXPORT__ char load(ImlibImage * im, ImlibProgressFunction progress,
+ char progress_granularity, char load_data);
+diff '--color=auto' -Naurd imlib2_loaders-1.7.1.orig/src/modules/loaders/loaders.h imlib2_loaders-1.7.1/src/modules/loaders/loaders.h
+--- imlib2_loaders-1.7.1.orig/src/modules/loaders/loaders.h 1970-01-01 03:00:00.000000000 +0300
++++ imlib2_loaders-1.7.1/src/modules/loaders/loaders.h 2020-07-28 21:13:51.000000000 +0300
+@@ -0,0 +1,21 @@
++#ifndef __LOADERS
++#define __LOADERS 1
++
++#include "image.h"
++
++struct _imlibloader {
++ char *file;
++ int num_formats;
++ char **formats;
++ void *handle;
++ char (*load)(ImlibImage * im,
++ ImlibProgressFunction progress,
++ char progress_granularity, char load_data);
++ char (*save)(ImlibImage * im,
++ ImlibProgressFunction progress,
++ char progress_granularity);
++ ImlibLoader *next;
++ int (*load2)(ImlibImage * im, int load_data);
++};
++
++#endif /* __LOADERS */
diff --git a/media-plugins/imlib2_loaders/imlib2_loaders-1.7.1.ebuild b/media-plugins/imlib2_loaders/imlib2_loaders-1.7.1.ebuild
new file mode 100644
index 000000000000..06e19e93bd38
--- /dev/null
+++ b/media-plugins/imlib2_loaders/imlib2_loaders-1.7.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Additional image loaders for Imlib2"
+HOMEPAGE="https://www.enlightenment.org/
+ https://sourceforge.net/projects/enlightenment/files/imlib2-src/"
+SRC_URI="https://downloads.sourceforge.net/enlightenment/${P}.tar.bz2"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="eet xcf"
+
+RDEPEND=">=media-libs/imlib2-${PV}
+ eet? ( dev-libs/efl[eet] )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-loader-api.patch" )
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable eet)
+ $(use_enable xcf)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ V=1 emake install DESTDIR="${D}"
+ einstalldocs
+
+ find "${D}" -name '*.la' -delete || die
+}