summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-11-29 14:46:37 -0500
committerCraig Andrews <candrews@gentoo.org>2018-11-29 14:48:24 -0500
commitac5d00488cc79f262092a2ccc56bbd7d5282ade4 (patch)
treedd9e55f669b91698f07cde87c5b7cb9c783c8c3a /media-plugins/kodi-audiodecoder-vgmstream
parentmedia-plugins/kodi-audiodecoder-vgmstream: 1.1.0 is for Kodi 17 only (diff)
downloadgentoo-ac5d00488cc79f262092a2ccc56bbd7d5282ade4.tar.gz
gentoo-ac5d00488cc79f262092a2ccc56bbd7d5282ade4.tar.bz2
gentoo-ac5d00488cc79f262092a2ccc56bbd7d5282ade4.zip
media-plugins/kodi-audiodecoder-vgmstream: 1.1.3 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-audiodecoder-vgmstream')
-rw-r--r--media-plugins/kodi-audiodecoder-vgmstream/Manifest1
-rw-r--r--media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild36
-rw-r--r--media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-9999.ebuild11
3 files changed, 43 insertions, 5 deletions
diff --git a/media-plugins/kodi-audiodecoder-vgmstream/Manifest b/media-plugins/kodi-audiodecoder-vgmstream/Manifest
index 810a01d60cc5..45a85432dbdd 100644
--- a/media-plugins/kodi-audiodecoder-vgmstream/Manifest
+++ b/media-plugins/kodi-audiodecoder-vgmstream/Manifest
@@ -1 +1,2 @@
DIST kodi-audiodecoder-vgmstream-1.1.0.tar.gz 235215 BLAKE2B de8253b3a619e0a9a3ab954967fe73081d72aaef37318862745e1378d21001cb9950a2849c0ae6320e9c968d2d0f2c16ca394315e30d08c5fda94e8faf599f45 SHA512 a0549ad7ef94a68bf3e1d77d222790acc15be06f124e148e980aa2f96956da659d5967e0ac034db9ccbb34416cd3a607e7607ec91d00ec12e4bf287766b76d0d
+DIST kodi-audiodecoder-vgmstream-1.1.3.tar.gz 236276 BLAKE2B 4323a96ab7d899f40b0cc3243ed9047ca32b2669a845213e7a5703e79e3a4c10d1a37039b0d627d9b636dc1128b49da28e6ba798b44584411b9bb8bd84cc043a SHA512 7f855019e04156b5601a7be0f71a833b241c52bc2dd63f44f2c0c5f3a28b70e14ee9677e5e381ee283d332f167d1dc6e27f1f6cfc5212acb9854cfd93f2b4005
diff --git a/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild
new file mode 100644
index 000000000000..fc4e9c3f0adf
--- /dev/null
+++ b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-1.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="vgmstream decoder addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/audiodecoder.vgmstream"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/notspiff/audiodecoder.vgmstream"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/audiodecoder.vgmstream/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.vgmstream-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ "
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-9999.ebuild b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-9999.ebuild
index 21015b25f58e..dbd2e565982c 100644
--- a/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-9999.ebuild
+++ b/media-plugins/kodi-audiodecoder-vgmstream/kodi-audiodecoder-vgmstream-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,9 +16,10 @@ case ${PV} in
inherit git-r3
;;
*)
+ CODENAME="Leia"
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/notspiff/audiodecoder.vgmstream/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/audiodecoder.vgmstream-${PV}"
+ SRC_URI="https://github.com/notspiff/audiodecoder.vgmstream/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/audiodecoder.vgmstream-${PV}-${CODENAME}"
;;
esac
@@ -27,8 +28,8 @@ SLOT="0"
IUSE=""
DEPEND="
- media-tv/kodi
- media-libs/kodi-platform
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
"
RDEPEND="
${DEPEND}