summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-12-22 23:02:22 -0500
committerCraig Andrews <candrews@gentoo.org>2018-12-22 23:06:05 -0500
commitb12b8b6139a8ce4454289a3779e72e3bc1535bf9 (patch)
tree6b53c60d63603725f857115c1c2e60e623622ea7 /media-plugins/kodi-pvr-nextpvr
parentmedia-plugins/kodi-pvr-pctv: 2.4.5 version bump (diff)
downloadgentoo-b12b8b6139a8ce4454289a3779e72e3bc1535bf9.tar.gz
gentoo-b12b8b6139a8ce4454289a3779e72e3bc1535bf9.tar.bz2
gentoo-b12b8b6139a8ce4454289a3779e72e3bc1535bf9.zip
media-plugins/kodi-pvr-nextpvr: 3.3.8 version bump
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'media-plugins/kodi-pvr-nextpvr')
-rw-r--r--media-plugins/kodi-pvr-nextpvr/Manifest1
-rw-r--r--media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-3.3.8.ebuild38
-rw-r--r--media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-9999.ebuild8
3 files changed, 43 insertions, 4 deletions
diff --git a/media-plugins/kodi-pvr-nextpvr/Manifest b/media-plugins/kodi-pvr-nextpvr/Manifest
index 1d2f9ad008ab..32d81b962d47 100644
--- a/media-plugins/kodi-pvr-nextpvr/Manifest
+++ b/media-plugins/kodi-pvr-nextpvr/Manifest
@@ -1,2 +1,3 @@
DIST kodi-pvr-nextpvr-2.4.11.tar.gz 111677 BLAKE2B ce1279641f4ed1bd5e1a0731198775c2ca6358ac8de846bc57588988eb415bfbaf9fe069b84717368eafb9fa01b232b833888c8580bdd886d1331618c369faab SHA512 2c9e98cb6b99aca8c582d4751096c7ef445f97b09fb6d51c798767c7a7b54632bd4e5c7fb2d723b023eeb335daa73e53ba455156bd8e8ea863c3a98659e5e906
DIST kodi-pvr-nextpvr-2.4.13.tar.gz 111692 BLAKE2B 5199c9fb8b767eeaf116ed87abafe0d5f0e1e252fae945589413c002b313a222090c9cc12db02e927f168f6217c2fcff55f20adef984e54bceed92755e9922a5 SHA512 314217bca4ce7bf43900e8572fca158874c90bba50ca78b7541e804a3b00216bb39ef7624a270ceb4407f33d85b2711c7b58ea9b4ec1a0386d3d7697cac29c2a
+DIST kodi-pvr-nextpvr-3.3.8.tar.gz 118717 BLAKE2B ea72f205121b050355fcd194fc8c28a2bce62504187372128b7397841f03a411d9ae1419aa1cee36acf391e098fed04b58f3312a74cf3dadf48726cd72da59bb SHA512 3cf8de69091946c9678c73f0254be9d49b51ecffe8153f675e62198aa97fa952bc5c1b5a4ccabbf7de5c05e8ca9e0c01d1ee5fd5988504430acec37a5b2edf3e
diff --git a/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-3.3.8.ebuild b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-3.3.8.ebuild
new file mode 100644
index 000000000000..ddb345ee8d03
--- /dev/null
+++ b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-3.3.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="Kodi's NextPVR client addon"
+HOMEPAGE="https://github.com/kodi-pvr/pvr.nextpvr"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/kodi-pvr/pvr.nextpvr.git"
+ inherit git-r3
+ ;;
+*)
+ CODENAME="Leia"
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/kodi-pvr/pvr.nextpvr/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/pvr.nextpvr-${PV}-${CODENAME}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =media-tv/kodi-18*
+ =media-libs/kodi-platform-18*
+ dev-libs/tinyxml
+ "
+
+RDEPEND="
+ ${DEPEND}
+ "
diff --git a/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-9999.ebuild b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-9999.ebuild
index b254e4182857..8d192c0897ff 100644
--- a/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-9999.ebuild
+++ b/media-plugins/kodi-pvr-nextpvr/kodi-pvr-nextpvr-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ case ${PV} in
inherit git-r3
;;
*)
- CODENAME="Krypton"
+ CODENAME="Leia"
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/kodi-pvr/pvr.nextpvr/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/pvr.nextpvr-${PV}-${CODENAME}"
@@ -28,8 +28,8 @@ SLOT="0"
IUSE=""
DEPEND="
- =media-tv/kodi-9999
- =media-libs/kodi-platform-9999
+ ~media-tv/kodi-9999
+ ~media-libs/kodi-platform-9999
dev-libs/tinyxml
"