summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2018-06-20 09:50:41 -0400
committerCraig Andrews <candrews@gentoo.org>2018-06-20 09:50:41 -0400
commit8c00ffc3d65086931ee4823fddbe90942765b671 (patch)
treece2cc189d4af64c8d75a1ea970001e2e09bcf94f /media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
parentmedia-tv/kodi: remove sftp use flag on -9999 ebuild (diff)
downloadgentoo-8c00ffc3d65086931ee4823fddbe90942765b671.tar.gz
gentoo-8c00ffc3d65086931ee4823fddbe90942765b671.tar.bz2
gentoo-8c00ffc3d65086931ee4823fddbe90942765b671.zip
media-plugins/kodi-vfs-sftp: SFTP VFS addon for Kodi
Adds support for SFTP to Kodi. This functionality was originally part of Kodi itself, but was removed in Kodi 18. See https://github.com/xbmc/xbmc/pull/12005 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild')
-rw-r--r--media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
new file mode 100644
index 000000000000..b84c71c0291f
--- /dev/null
+++ b/media-plugins/kodi-vfs-sftp/kodi-vfs-sftp-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="SFTP VFS addon for Kodi"
+HOMEPAGE="https://github.com/notspiff/vfs.sftp"
+SRC_URI=""
+
+case ${PV} in
+9999)
+ SRC_URI=""
+ EGIT_REPO_URI="git://github.com/notspiff/vfs.sftp.git"
+ inherit git-r3
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/notspiff/vfs.sftp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/vfs.sftp-${PV}"
+ ;;
+esac
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ =dev-libs/libplatform-2*
+ net-libs/libssh[sftp]
+ =media-libs/kodi-platform-9999
+ =media-tv/kodi-9999
+ "