summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-13 21:06:50 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2021-05-13 21:07:17 +0200
commit63fb00b3235ba162859a170aed29626ecfe7ba4e (patch)
treef949692c3a480d1a3cd78ddc0759f7ffcc4880e6 /media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild
parentsys-kernel/gentoo-sources: Clean-up of old kernels (diff)
downloadgentoo-63fb00b3235ba162859a170aed29626ecfe7ba4e.tar.gz
gentoo-63fb00b3235ba162859a170aed29626ecfe7ba4e.tar.bz2
gentoo-63fb00b3235ba162859a170aed29626ecfe7ba4e.zip
media-plugins/vdr-dvd: clang compile fixed
also reverted bug fix from wrt bug 787488 as it is fixed in main vdr sources Closes: https://bugs.gentoo.org/740276 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild')
-rw-r--r--media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild b/media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild
new file mode 100644
index 000000000000..2412c3d519a3
--- /dev/null
+++ b/media-plugins/vdr-dvd/vdr-dvd-0.3.7_pre20090106-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+MY_P=${PN}-cvs-${PV#*_pre}
+S=${WORKDIR}/${MY_P#vdr-}
+
+DESCRIPTION="VDR Plugin: DVD-Player"
+HOMEPAGE="https://sourceforge.net/projects/dvdplugin"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-video/vdr-1.6.0
+ >=media-libs/libdvdnav-4.2.0
+ >=media-libs/a52dec-0.7.4"
+DEPEND="${RDEPEND}"
+
+# vdr-plugin-2.eclass fix
+KEEP_I18NOBJECT="yes"
+
+PATCHES=(
+ "${FILESDIR}/${P}-compile_warnings.diff"
+ "${FILESDIR}/${P}-fix-dvdnav-using-c++-keywords.patch"
+ "${FILESDIR}/${P}_clang.patch"
+ )
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-2.1.3"; then
+ sed -i player-dvd.c -e "s:DeviceTrickSpeed(sp):DeviceTrickSpeed(sp,true):"
+ fi
+
+ #bug 787485
+ sed -e "s:MAKEDEP = g++:MAKEDEP = \$(CXX):" -i Makefile
+}