summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild')
-rw-r--r--media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild b/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild
new file mode 100644
index 000000000000..7f1cc4eea3e2
--- /dev/null
+++ b/media-plugins/vdr-lcr/vdr-lcr-0.0.9.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: informe about Least Cost Routing (LCR)"
+HOMEPAGE="http://lcr.vdr-developer.org"
+SRC_URI="http://lcr.vdr-developer.org/downloads/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.5.7
+ >=dev-perl/libwww-perl-5.69-r2
+ >=dev-perl/HTML-Parser-3.34-r1
+ >=www-client/lynx-2.8.4"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dobin contrib/vdr-lcr-retrieve_data.pl
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ echo
+ elog "By default, this plugin only supports the German telephone network"
+ elog "Find more info in /usr/bin/vdr-lcr-retrieve-data.pl how to add your"
+ elog "own Provider-Parser, or contact the maintainer"
+}