summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-markad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-markad')
-rw-r--r--media-plugins/vdr-markad/Manifest1
-rw-r--r--media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch40
-rw-r--r--media-plugins/vdr-markad/files/vdr-markad-0.1.4_ffmpeg-2.patch13
-rw-r--r--media-plugins/vdr-markad/metadata.xml10
-rw-r--r--media-plugins/vdr-markad/vdr-markad-0.1.4-r1.ebuild67
-rw-r--r--media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild62
6 files changed, 193 insertions, 0 deletions
diff --git a/media-plugins/vdr-markad/Manifest b/media-plugins/vdr-markad/Manifest
new file mode 100644
index 000000000000..76b946f8a5f4
--- /dev/null
+++ b/media-plugins/vdr-markad/Manifest
@@ -0,0 +1 @@
+DIST vdr-markad-0.1.4.tgz 118728 SHA256 f940765c5dd4a5d66e1ff2650fa0a2b7bda7138953782431230a6c7539334a85 SHA512 10121e72803f489cdcabb46c989ecf4ae2ced1893bbdaccefbeef412ca34b124952ddf4639b3f78da3413e7b784ead4a60034a70cbab43a7c27e0e41f9653ae1 WHIRLPOOL 9e926e44798c5449346b078cfb906341a15715be49bff52bbad7594c299edff5f2454f1f2de9f5f3dc05a85968a860baa3d7796e220461da2663ca897db87414
diff --git a/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch b/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch
new file mode 100644
index 000000000000..f11fc6137000
--- /dev/null
+++ b/media-plugins/vdr-markad/files/vdr-markad-0.1.4-libav9.patch
@@ -0,0 +1,40 @@
+diff -urN markad-0.1.4.old/command/decoder.cpp markad-0.1.4/command/decoder.cpp
+--- markad-0.1.4.old/command/decoder.cpp 2013-06-17 21:52:44.333367552 +0200
++++ markad-0.1.4/command/decoder.cpp 2013-06-17 21:53:03.708366863 +0200
+@@ -11,6 +11,7 @@
+ #include <sys/types.h>
+ #include <string.h>
+ #include <cstdlib>
++#include <cstdio>
+
+ #include "decoder.h"
+
+@@ -172,7 +173,7 @@
+
+ if (video_codec)
+ {
+- video_context = avcodec_alloc_context();
++ video_context = avcodec_alloc_context3(NULL);
+ if (video_context)
+ {
+ if (video_codec->capabilities & CODEC_CAP_TRUNCATED)
+@@ -321,7 +322,7 @@
+ {
+ avcodec_flush_buffers(video_context);
+ AVCodecContext *dest;
+- dest=avcodec_alloc_context();
++ dest=avcodec_alloc_context3(NULL);
+ if (dest)
+ {
+ if (avcodec_copy_context(dest,video_context)!=0) ret=false;
+diff -urN markad-0.1.4.old/command/decoder.h markad-0.1.4/command/decoder.h
+--- markad-0.1.4.old/command/decoder.h 2013-06-17 21:52:44.333367552 +0200
++++ markad-0.1.4/command/decoder.h 2013-06-17 21:53:03.708366863 +0200
+@@ -18,6 +18,7 @@
+ #include <avcodec.h>
+ #else
+ #include <libavcodec/avcodec.h>
++#include <libavutil/mem.h>
+ #endif
+
+ #if LIBAVCODEC_VERSION_INT < ((52<<16)+(0<<8)+0)
diff --git a/media-plugins/vdr-markad/files/vdr-markad-0.1.4_ffmpeg-2.patch b/media-plugins/vdr-markad/files/vdr-markad-0.1.4_ffmpeg-2.patch
new file mode 100644
index 000000000000..c94d54ea7aef
--- /dev/null
+++ b/media-plugins/vdr-markad/files/vdr-markad-0.1.4_ffmpeg-2.patch
@@ -0,0 +1,13 @@
+diff -Naur markad-0.1.4.orig/command/decoder.cpp markad-0.1.4/command/decoder.cpp
+--- markad-0.1.4.orig/command/decoder.cpp 2014-01-29 20:16:23.000000000 +0100
++++ markad-0.1.4/command/decoder.cpp 2014-01-29 20:17:49.000000000 +0100
+@@ -152,7 +152,8 @@
+ }
+
+ video_codec=NULL;
+- CodecID video_codecid;
++// CodecID video_codecid;
++ AVCodecID video_codecid;
+
+ if (useH264)
+ {
diff --git a/media-plugins/vdr-markad/metadata.xml b/media-plugins/vdr-markad/metadata.xml
new file mode 100644
index 000000000000..5f9f14619db8
--- /dev/null
+++ b/media-plugins/vdr-markad/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-markad/vdr-markad-0.1.4-r1.ebuild b/media-plugins/vdr-markad/vdr-markad-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..ced44eb5e3e4
--- /dev/null
+++ b/media-plugins/vdr-markad/vdr-markad-0.1.4-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="1041" # every bump, new version
+
+DESCRIPTION="VDR Plugin: marks advertisements in VDR recordings"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-markad/"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6
+ virtual/ffmpeg[mp3,x264]
+ !media-video/noad"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${VDRPLUGIN}-${PV}/plugin"
+S2="${WORKDIR}/${VDRPLUGIN}-${PV}/command"
+
+# vdr-plugin-2.eclass changes
+PO_SUBDIR="../command"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ cd "${S2}"
+ epatch "${FILESDIR}/${PN}-0.1.4-libav9.patch"
+ sed -i Makefile \
+ -e "s:\$(CXXFLAGS) \$(OBJS):\$(CXXFLAGS) \$(LDFLAGS) \$(OBJS):" \
+ -e "s:\@\$(STRIP) \$(DESTDIR)/usr/bin/markad::"
+
+ if has_version ">=media-video/vdr-1.7.15"; then
+ sed -e "s:2001:6419:" -i markad-standalone.cpp
+ fi
+
+ epatch "${FILESDIR}/${P}_ffmpeg-2.patch"
+
+ # compile fix, tested libav11, ffmpeg-2.5.2
+ sed -e "s:CODEC_ID_:AV_CODEC_ID_:"\
+ -e "s:avcodec_alloc_frame:av_frame_alloc:"\
+ -i "${S2}"/decoder.cpp
+}
+
+src_compile() {
+ vdr-plugin-2_src_compile
+
+ cd "${S2}"
+ emake markad || die "Compiling command-line markad binary failed"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ cd "${S2}"
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ cd "${WORKDIR}/${VDRPLUGIN}-${PV}"
+ dodoc README HISTORY
+}
diff --git a/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild b/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild
new file mode 100644
index 000000000000..88523c5e8809
--- /dev/null
+++ b/media-plugins/vdr-markad/vdr-markad-0.1.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+VERSION="1041" # every bump, new version
+
+DESCRIPTION="VDR Plugin: marks advertisements in VDR recordings"
+HOMEPAGE="http://projects.vdr-developer.org/projects/plg-markad/"
+SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.6
+ virtual/ffmpeg[mp3,x264]
+ !media-video/noad"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${VDRPLUGIN}-${PV}/plugin"
+S2="${WORKDIR}/${VDRPLUGIN}-${PV}/command"
+
+# vdr-plugin-2.eclass changes
+PO_SUBDIR="../command"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ cd "${S2}"
+ epatch "${FILESDIR}/${PN}-0.1.4-libav9.patch"
+ sed -i Makefile \
+ -e "s:\$(CXXFLAGS) \$(OBJS):\$(CXXFLAGS) \$(LDFLAGS) \$(OBJS):" \
+ -e "s:\@\$(STRIP) \$(DESTDIR)/usr/bin/markad::"
+
+ if has_version ">=media-video/vdr-1.7.15"; then
+ sed -e "s:2001:6419:" -i markad-standalone.cpp
+ fi
+
+ epatch "${FILESDIR}/${P}_ffmpeg-2.patch"
+}
+
+src_compile() {
+ vdr-plugin-2_src_compile
+
+ cd "${S2}"
+ emake markad || die "Compiling command-line markad binary failed"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ cd "${S2}"
+ emake install DESTDIR="${D}" || die "emake install failed"
+
+ cd "${WORKDIR}/${VDRPLUGIN}-${PV}"
+ dodoc README HISTORY
+}