summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-mount
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-mount')
-rw-r--r--media-plugins/vdr-mount/Manifest1
-rw-r--r--media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff58
-rw-r--r--media-plugins/vdr-mount/metadata.xml12
-rw-r--r--media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild29
4 files changed, 100 insertions, 0 deletions
diff --git a/media-plugins/vdr-mount/Manifest b/media-plugins/vdr-mount/Manifest
new file mode 100644
index 000000000000..283153cdc74d
--- /dev/null
+++ b/media-plugins/vdr-mount/Manifest
@@ -0,0 +1 @@
+DIST vdr-mount-0.0.2.tgz 13127 SHA256 5aceb1b21af73a73a9da0d6fccd1f522c0126d04af6bcae161dd2b82627c45aa SHA512 1a16c192ef66fb1e4f41c304e4191b2fe759994e02b8965b314ef79cc5d8bb9dcf39d982902b5b651078e201c3dc77d5a2d7e28a38942d399da0692ff47cf116 WHIRLPOOL c6fd9a011a0520f4a4025aac6fbdb0855b48af2169c6d85f331143434d090446b512f4f685618b08780c1399f0bb0ae3e0224c9f3cd3d8ea2647c4933edacba2
diff --git a/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff b/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff
new file mode 100644
index 000000000000..ba2bcc437242
--- /dev/null
+++ b/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff
@@ -0,0 +1,58 @@
+Index: mount-0.0.2/Makefile
+===================================================================
+--- mount-0.0.2.orig/Makefile
++++ mount-0.0.2/Makefile
+@@ -59,12 +59,12 @@ OBJS = $(subst .C,.o, $(shell ls *.C 2>/
+
+ ### Targets:
+
+-all: medialist libvdr-$(PLUGIN).so
++all: libvdr-$(PLUGIN).so
+
+ medialist:
+- cd MediaList; make
++ $(MAKE) -C MediaList
+
+-libvdr-$(PLUGIN).so: $(OBJS)
++libvdr-$(PLUGIN).so: $(OBJS) medialist
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -L MediaList/src -l MediaList -o $@
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
+
+@@ -77,7 +77,7 @@ dist: clean
+ @echo Distribution package created as $(PACKAGE).tgz
+
+ clean:
+- cd MediaList; make clean
++ $(MAKE) -C MediaList clean
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ *.d
+
+ -include *.d
+Index: mount-0.0.2/MediaList/Makefile
+===================================================================
+--- mount-0.0.2.orig/MediaList/Makefile
++++ mount-0.0.2/MediaList/Makefile
+@@ -6,18 +6,18 @@ $(subst .cxx,, $(shell cd prog; ls *.cxx
+
+
+ all:
+- export MYLIBNAME=$(LIBNAME);cd src; make
+- export PROGS=$(PROGRAMMS);cd prog; make
+- export MYLIBNAME=$(LIBNAME);export PROGS=$(PROGRAMMS);cd bin; make
++ $(MAKE) -C src MYLIBNAME=$(LIBNAME)
++ $(MAKE) -C prog PROGS=$(PROGRAMMS)
++ $(MAKE) -C bin MYLIBNAME=$(LIBNAME) PROGS=$(PROGRAMMS)
+
+ depend:
+ @echo target depend is obsolete --- just make
+
+
+ clean:
+- cd src; make clean
+- cd prog; make clean
+- export PROGS=$(PROGRAMMS);cd bin; make clean
++ $(MAKE) -C src clean
++ $(MAKE) -C prog clean
++ $(MAKE) -C bin clean PROGS=$(PROGRAMMS)
+
+
+ install:
diff --git a/media-plugins/vdr-mount/metadata.xml b/media-plugins/vdr-mount/metadata.xml
new file mode 100644
index 000000000000..d1b88e6872a7
--- /dev/null
+++ b/media-plugins/vdr-mount/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<maintainer>
+<email>vdr@gentoo.org</email>
+<name>Gentoo VDR Project</name>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+
diff --git a/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
new file mode 100644
index 000000000000..a7bca1511b74
--- /dev/null
+++ b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: (Un)Mount removable media via osd"
+HOMEPAGE="http://www.vdr-wiki.de/wiki/index.php/Mount-plugin"
+SRC_URI="http://homepages.physik.uni-muenchen.de/~Felix.Rauscher/${P}.tgz"
+
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.6"
+
+PATCHES=("${FILESDIR}/${P}-makefile-fix.diff")
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version ">=media-video/vdr-2.1.2"; then
+ sed -e "s#VideoDirectory#cVideoDirectory::Name\(\)#" \
+ -i MediumItem.C
+ fi
+}