summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-prefermenu/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-prefermenu/files')
-rw-r--r--media-plugins/vdr-prefermenu/files/prefermenu.mk124
-rw-r--r--media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff73
2 files changed, 197 insertions, 0 deletions
diff --git a/media-plugins/vdr-prefermenu/files/prefermenu.mk b/media-plugins/vdr-prefermenu/files/prefermenu.mk
new file mode 100644
index 000000000000..8021b75536a0
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/files/prefermenu.mk
@@ -0,0 +1,124 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id$
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = prefermenu
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+#INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o preferosd.o prefersetup.o preferchannel.o
+
+### The main target:
+
+all: $(SOFILE)
+#i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib
+#install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+# @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff b/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff
new file mode 100644
index 000000000000..0c0239d2ac48
--- /dev/null
+++ b/media-plugins/vdr-prefermenu/files/vdr-prefermenu-0.6.6-no-static-getfont.diff
@@ -0,0 +1,73 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 90_prefermenu-0.6.6-1.5.3.dpatch by Thomas Günther <tom@toms-cafe.de>
+## http://toms-cafe.de/vdr/download/prefermenu-0.6.6-1.5.3.diff
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Changes for VDR >= 1.5.3.
+
+@DPATCH@
+--- prefermenu-0.6.6/prefermenu.c
++++ prefermenu-0.6.6/prefermenu.c
+@@ -75,6 +75,7 @@
+ }
+ // Clean up the file with current VDR channels.conf
+ PreferedChannelsList.Save();
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ config.height= (config.lines * (LINEHEIGHT+BORDERSIZE+2))+BORDERSIZE;
+ return new cPreferOsd;
+ }
+--- prefermenu-0.6.6/preferosd.c
++++ prefermenu-0.6.6/preferosd.c
+@@ -60,6 +60,7 @@
+ }
+ osd=cOsdProvider::NewOsd(config.originx, config.originy);
+ if (osd) {
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ tArea Area = { 0, 0, config.width+LINEHEIGHT, config.height-1, 4};
+ osd->SetAreas(&Area, 1);
+ DrawPreferMenu(0,0);
+@@ -168,6 +169,7 @@
+ {
+ if (current > 1) {
+ current -= 1;
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ DrawPreferMenu(-LINEHEIGHT,1);
+ DisplayPreferMenu();
+ //DrawPreferMneu(-10,1);
+@@ -181,6 +183,7 @@
+ {
+ if (current < number) {
+ current += 1;
++ const int LINEHEIGHT = cFont::GetFont(fontOsd)->Height();
+ DrawPreferMenu(+LINEHEIGHT,-1);
+ DisplayPreferMenu();
+ //DrawPreferMenu(+10,-1);
+@@ -315,6 +318,8 @@
+
+ void cPreferOsd::DrawPreferMenu(int delta, int highlight)
+ {
++ const cFont *font = cFont::GetFont(fontOsd);
++ const int LINEHEIGHT = font->Height();
+
+ int middle = int(config.height/2) + config.height%2;
+
+@@ -390,6 +395,8 @@
+
+ void cPreferOsd::DrawChannelsNames(int delta)
+ {
++ const cFont *font = cFont::GetFont(fontOsd);
++ const int LINEHEIGHT = font->Height();
+
+ // XXX The margin is hardcoded for now
+ // TODO: make it more flexible
+--- prefermenu-0.6.6/preferosd.h
++++ prefermenu-0.6.6/preferosd.h
+@@ -4,8 +4,6 @@
+ #include <vdr/plugin.h>
+
+ static const int BORDERSIZE = 2;
+-static const cFont *font = cFont::GetFont(fontOsd);
+-static const int LINEHEIGHT = font->Height();
+
+
+ class cPreferOsd : public cOsdObject {