summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2016-09-27 13:10:31 +0200
committerJoerg Bornkessel <hd_brummy@gentoo.org>2016-09-27 13:10:31 +0200
commitad6d1c2f37145ba24dce788b556827893ea7d4b5 (patch)
tree6f8bedfa38032826b98bb4611eccaf063dce6d80 /media-plugins/vdr-satip/files
parentsys-cluster/openmpi-1.10.3-r1: keyworded for ~alpha (diff)
downloadgentoo-ad6d1c2f37145ba24dce788b556827893ea7d4b5.tar.gz
gentoo-ad6d1c2f37145ba24dce788b556827893ea7d4b5.tar.bz2
gentoo-ad6d1c2f37145ba24dce788b556827893ea7d4b5.zip
media-plugins/vdr-satip: fixed gcc-6 compile; wrt bug 594170
Package-Manager: portage-2.3.0
Diffstat (limited to 'media-plugins/vdr-satip/files')
-rw-r--r--media-plugins/vdr-satip/files/vdr-satip-2.2.3_c++11.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-plugins/vdr-satip/files/vdr-satip-2.2.3_c++11.patch b/media-plugins/vdr-satip/files/vdr-satip-2.2.3_c++11.patch
new file mode 100644
index 000000000000..102e8e970b97
--- /dev/null
+++ b/media-plugins/vdr-satip/files/vdr-satip-2.2.3_c++11.patch
@@ -0,0 +1,28 @@
+common.h still use function typeof,
+this was never defined part of c++ and is
+not supported in c++11 anymore
+so we revert back to gnu++03 as it is not fixed by upstream
+Signed-of-by: Joerg Bornkessel <hd_brummy@gentoo.org> (2016/aug/01)
+diff -Naur satip-2.2.3.orig/Makefile satip-2.2.3/Makefile
+--- satip-2.2.3.orig/Makefile 2016-08-03 23:17:36.769080128 +0200
++++ satip-2.2.3/Makefile 2016-08-03 23:18:36.399080128 +0200
+@@ -32,6 +32,7 @@
+
+ export CFLAGS = $(call PKGCFG,cflags)
+ export CXXFLAGS = $(call PKGCFG,cxxflags)
++export CXXFLAGS += -std=gnu++03
+ STRIP = true
+
+ ### The version number of VDR's plugin API:
+diff -Naur satip-2.2.3.orig/common.h satip-2.2.3/common.h
+--- satip-2.2.3.orig/common.h 2016-08-07 02:54:27.290440336 +0200
++++ satip-2.2.3/common.h 2016-08-07 02:54:53.193773669 +0200
+@@ -52,7 +52,7 @@
+ do { \
+ if (exp) { \
+ char tmp[64]; \
+- esyslog("[%s,%d]: "errstr": %s", __FILE__, __LINE__, \
++ esyslog("[%s,%d]: " errstr ": %s", __FILE__, __LINE__, \
+ strerror_r(errno, tmp, sizeof(tmp))); \
+ func; \
+ ret; \