summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-25 19:32:55 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-25 19:53:23 +0100
commit1e00c132d8777c97b9d31e725f3ed4cdfe1bfe0b (patch)
tree38fc3807d055354049dc80a4bbf8b3432200bf15 /media-plugins/vdr-satip
parentvirtual/pypy3: Bump to 7.3.0 (diff)
downloadgentoo-1e00c132d8777c97b9d31e725f3ed4cdfe1bfe0b.tar.gz
gentoo-1e00c132d8777c97b9d31e725f3ed4cdfe1bfe0b.tar.bz2
gentoo-1e00c132d8777c97b9d31e725f3ed4cdfe1bfe0b.zip
media-plugins/vdr-satip: version bump
this version needs >=media-plugins/vdr-2.4 Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins/vdr-satip')
-rw-r--r--media-plugins/vdr-satip/Manifest1
-rw-r--r--media-plugins/vdr-satip/vdr-satip-2.4.1_p20191027.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-plugins/vdr-satip/Manifest b/media-plugins/vdr-satip/Manifest
index b00a76e8edc1..e4b6ece6b3e8 100644
--- a/media-plugins/vdr-satip/Manifest
+++ b/media-plugins/vdr-satip/Manifest
@@ -1,2 +1,3 @@
DIST vdr-satip-2.2.3.tgz 62722 BLAKE2B 408fe520b4210fa24667d4244560d5132260ce08067d482a50b12446c42c0c34fd922b3429d00c4e3550a7b1dc1d21bfac534cae9de478594751b9cf0f558d52 SHA512 451606b52831c009aaec894f0547c59a9447279d7f96a4b2291614eab09a3539849abcb6974b7c2c4b34e7b43a2f9c782ab1ea6bfd4e35f9747349065fb6a5e7
DIST vdr-satip-2.2.5.tgz 74669 BLAKE2B e586297f0f0c1ca776d4c9f83b46da7f7afe82b80ac7e79ec2da7107c793f5c8a5092590ad23030a435e2d034b084373b9b069bac6ef81822723d33ff6c7fab2 SHA512 3f8ab1d9e84843e71bc6fc8f712d178fa3d304d0959ec977de1b11829e27b575feb78735c6770b15d4dfb8f4fce933aed7df07a6d9ba0b20e937aacd3c643a21
+DIST vdr-satip-2.4.1_p20191027.tar.gz 74205 BLAKE2B 06d847bdec0aa996b5a12df8effcbed1f6cb508664aceda67f6ca415b84646e2f116e329068abd735403c145971146335a004d43e38ede133db03e37ba5b3117 SHA512 087b767583393608995141bf15f02793fb48ee448fe5c3becad34e2e84a4dc8391feb00c1b68fd37377837bd4468f766a8a389e720be375bd2cb6847277e887c
diff --git a/media-plugins/vdr-satip/vdr-satip-2.4.1_p20191027.ebuild b/media-plugins/vdr-satip/vdr-satip-2.4.1_p20191027.ebuild
new file mode 100644
index 000000000000..cd4da2275d45
--- /dev/null
+++ b/media-plugins/vdr-satip/vdr-satip-2.4.1_p20191027.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+GIT_COMMIT="19e3057f34d9c097c8c6bad30188b14d80b7a242"
+MY_P="vdr-plugin-satip-${GIT_COMMIT}"
+
+DESCRIPTION="VDR Plugin: integrates SAT>IP network devices seamlessly into VDR"
+HOMEPAGE="http://www.saunalahti.fi/~rahrenbe/vdr/satip/"
+SRC_URI="https://github.com/rofafor/vdr-plugin-satip/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND=">=media-video/vdr-2.4.0
+ >=net-misc/curl-7.36
+ || ( dev-libs/pugixml
+ dev-libs/tinyxml )"
+RDEPEND="${DEPEND}"
+
+QA_FLAGS_IGNORED="
+ usr/lib/vdr/plugins/libvdr-satip.*
+ usr/lib64/vdr/plugins/libvdr-satip.*"
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ if has_version "dev-libs/tinyxml" ; then
+ sed -e "s:#SATIP_USE_TINYXML:SATIP_USE_TINYXML:" -i Makefile || die "sed failed"
+ fi
+}