summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-vompserver
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-vompserver')
-rw-r--r--media-plugins/vdr-vompserver/Manifest3
-rw-r--r--media-plugins/vdr-vompserver/files/rrprocstart.patch43
-rw-r--r--media-plugins/vdr-vompserver/files/vdr-1.7.27.diff36
-rw-r--r--media-plugins/vdr-vompserver/files/vompserver.mk150
-rw-r--r--media-plugins/vdr-vompserver/metadata.xml17
-rw-r--r--media-plugins/vdr-vompserver/vdr-vompserver-0.3.1-r1.ebuild53
-rw-r--r--media-plugins/vdr-vompserver/vdr-vompserver-0.4.0.ebuild46
-rw-r--r--media-plugins/vdr-vompserver/vdr-vompserver-0.4.1.ebuild38
8 files changed, 386 insertions, 0 deletions
diff --git a/media-plugins/vdr-vompserver/Manifest b/media-plugins/vdr-vompserver/Manifest
new file mode 100644
index 000000000000..7b5125a9e68f
--- /dev/null
+++ b/media-plugins/vdr-vompserver/Manifest
@@ -0,0 +1,3 @@
+DIST vdr-vompserver-0.3.1.tgz 84183 SHA256 bb9838b1139926bc0bd35e87a750a5aaf937015d78b351361c8611a7610488bd
+DIST vdr-vompserver-0.4.0.tgz 87166 SHA256 21437dfaa0a5cec57e211ea5819a96d1b2b56a700bd3e76033a1fb1bd8702b06 SHA512 027b3b63fc8fa34da11cc1841602e89fb48a7345717c22cf796cb24134504991b3056354b459358deb983da93fd6a3e74ddd965e894afcd6ba2bf69c37d058fa WHIRLPOOL 780ee9dd51692456d6b5a8d67c4d273baf77a9c549650416dc7307c0a4386fbf83b2e4df00856008b445875cc21ee665fe06349bf2cf691bae2e7ed91cbbbff2
+DIST vdr-vompserver-0.4.1.tgz 87056 SHA256 c5d2ba4d48c230de1223dcee6edff3a8cdc574a47779569136b39f4f810fdbd9 SHA512 79fbc311b48a752206842f21ec8d864df67aa7614f092b4e6a6623d732d4e053c2e35af7981aaed7d392f6510ebaac59f60640acae540e13c4f38cce04ddd1bd WHIRLPOOL 89ff2f8472a3dae695685417e85b6eef07a993c52ce81b4fee3ed4461b6f9394bf3ee04e41d74bfbc65da2ccb2cf8fff7e66010e083fff9320195a098817372f
diff --git a/media-plugins/vdr-vompserver/files/rrprocstart.patch b/media-plugins/vdr-vompserver/files/rrprocstart.patch
new file mode 100644
index 000000000000..bccdc9d5700d
--- /dev/null
+++ b/media-plugins/vdr-vompserver/files/rrprocstart.patch
@@ -0,0 +1,43 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 10-rrprocstart.dpatch by <marten.richter@freenet.de>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: Backport of a bug in rrproc
+
+fix a message overrun when MediaMVP boots
+The topic is documented in http://forum.loggytronic.com/index.php?topic=528.0
+
+@DPATCH@
+diff -u vdr-plugin-vompserver-new/vompclientrrproc.c vdr-plugin-vompserver-0.3.1/vompclientrrproc.c
+--- vdr-plugin-vompserver-new/vompclientrrproc.c 2010-07-05 19:20:11.000000000 +0200
++++ vdr-plugin-vompserver-0.3.1/vompclientrrproc.c 2010-07-05 19:24:05.000000000 +0200
+@@ -87,9 +87,25 @@
+
+ if (req_queue.size() != 0)
+ {
+- log->log("RRProc", Log::ERR, "threadMethod err 1");
+- threadUnlock();
+- return;
++ log->log("RRProc", Log::ERR, "threadMethod startup with already queued packets");
++ while (req_queue.size())
++ {
++ //log->log("RRProc", Log::DEBUG, "thread while");
++ req = req_queue.front();
++ req_queue.pop();
++
++ threadUnlock(); // allow recvRequest to be queuing packets while we are working on this one
++
++ if (!processPacket())
++ {
++ log->log("RRProc", Log::ERR, "processPacket exited with fail");
++ return;
++ }
++
++ threadLock();
++ }
++ log->log("RRProc", Log::ERR, "threadMethod startup with already queued packets done.");
++
+ }
+
+ while(1)
+
diff --git a/media-plugins/vdr-vompserver/files/vdr-1.7.27.diff b/media-plugins/vdr-vompserver/files/vdr-1.7.27.diff
new file mode 100644
index 000000000000..f98b75c124f4
--- /dev/null
+++ b/media-plugins/vdr-vompserver/files/vdr-1.7.27.diff
@@ -0,0 +1,36 @@
+diff -Naur vompserver-0.3.1.orig/mvpreceiver.c vompserver-0.3.1/mvpreceiver.c
+--- vompserver-0.3.1.orig/mvpreceiver.c 2012-05-01 14:35:39.000000000 +0200
++++ vompserver-0.3.1/mvpreceiver.c 2012-05-01 14:49:08.000000000 +0200
+@@ -40,7 +40,7 @@
+ #elif VDRVERSNUM < 10500
+ : cReceiver(channel->Ca(), 0, channel->Vpid(), channel->Apids(), channel->Dpids(), mergeSpidsTpid(channel->Spids(),channel->Tpid()))
+ #else
+-: cReceiver(channel->GetChannelID(), 0, channel->Vpid(), channel->Apids(), channel->Dpids(), mergeSpidsTpid(channel->Spids(),channel->Tpid()))
++: cReceiver(channel, 0)
+ #endif
+ {
+ logger = Log::getInstance();
+diff -Naur vompserver-0.3.1.orig/vompclientrrproc.c vompserver-0.3.1/vompclientrrproc.c
+--- vompserver-0.3.1.orig/vompclientrrproc.c 2012-05-01 14:35:39.000000000 +0200
++++ vompserver-0.3.1/vompclientrrproc.c 2012-05-01 14:46:41.000000000 +0200
+@@ -615,7 +615,7 @@
+
+ for (cRecording *recording = Recordings.First(); recording; recording = Recordings.Next(recording))
+ {
+- resp->addULONG(recording->start);
++ resp->addULONG(recording->Start());
+ resp->addString(recording->Name());
+ resp->addString(recording->FileName());
+ }
+@@ -1770,9 +1770,9 @@
+ {
+ for (const cMark *m = Marks.First(); m; m = Marks.Next(m))
+ {
+- log->log("RRProc", Log::DEBUG, "found Mark %i", m->position);
++ log->log("RRProc", Log::DEBUG, "found Mark %i", m->Position());
+
+- resp->addULONG(m->position);
++ resp->addULONG(m->Position());
+ }
+ }
+ else
diff --git a/media-plugins/vdr-vompserver/files/vompserver.mk b/media-plugins/vdr-vompserver/files/vompserver.mk
new file mode 100644
index 000000000000..1ea9ac3871ba
--- /dev/null
+++ b/media-plugins/vdr-vompserver/files/vompserver.mk
@@ -0,0 +1,150 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id$
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+# add the name of the plugin, next edit the OBJS line,
+PLUGIN = vompserver
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+INCLUDES +=
+
+DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+DEFINES += -DVOMPSERVER
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o
+
+OBJS += dsock.o mvpserver.o udpreplier.o bootpd.o tftpd.o i18n.o vompclient.o tcp.o \
+ ringbuffer.o mvprelay.o vompclientrrproc.o \
+ config.o log.o thread.o tftpclient.o \
+ media.o responsepacket.o \
+ mediafile.o mediaplayer.o servermediafile.o serialize.o medialauncher.o
+
+OBJS2 = recplayer.o mvpreceiver.o
+
+### The main target:
+
+all: allbase $(SOFILE)
+#i18n
+standalone: standalonebase vompserver-standalone
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+objectsstandalone: $(OBJS)
+objects: $(OBJS) $(OBJS2)
+
+allbase:
+ ( if [ -f .standalone ] ; then ( rm -f .standalone; make clean ; make objects ) ; else exit 0 ;fi )
+standalonebase:
+ ( if [ ! -f .standalone ] ; then ( make clean; echo "DEFINES+=-DVOMPSTANDALONE" > .standalone; echo "DEFINES+=-D_FILE_OFFSET_BITS=64" >> .standalone; make objectsstandalone ) ; else exit 0 ;fi )
+
+$(SOFILE): objects
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) $(OBJS2) -o $@
+ @if [ -n "$(DOOLDINSTALL)" ]; then \
+cp $@ $(LIBDIR)/$@.$(APIVERSION) ; \
+echo "done manual copy"; \
+fi
+
+vompserver-standalone: objectsstandalone
+ $(CXX) $(CXXFLAGS) $(OBJS) -lpthread -o $@
+ chmod u+x $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-vompserver/metadata.xml b/media-plugins/vdr-vompserver/metadata.xml
new file mode 100644
index 000000000000..9942f60ccf48
--- /dev/null
+++ b/media-plugins/vdr-vompserver/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>media-tv</herd>
+<herd>proxy-maintainers</herd>
+
+<maintainer>
+ <email>pfrank@gmx.de</email>
+ <name>Petric Frank</name>
+ <description>Proxied maintainer</description>
+</maintainer>
+
+<maintainer>
+ <email>vdr@gentoo.org</email>
+ <name>Gentoo VDR Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-plugins/vdr-vompserver/vdr-vompserver-0.3.1-r1.ebuild b/media-plugins/vdr-vompserver/vdr-vompserver-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..8f135d968e50
--- /dev/null
+++ b/media-plugins/vdr-vompserver/vdr-vompserver-0.3.1-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: server part for MediaMVP device"
+HOMEPAGE="http://www.loggytronic.com/vomp.php"
+SRC_URI="http://www.loggytronic.com/dl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.2.6"
+RDEPEND="${DEPEND}"
+
+PATCHES=("${FILESDIR}/rrprocstart.patch")
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -i "s:vompserver:vomp:" vompserver.c
+ sed -i "s:char b:// char b:" mediafile.c
+
+ if has_version ">=media-video/vdr-1.7.27"; then
+ epatch "${FILESDIR}/vdr-1.7.27.diff"
+ fi
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dodoc README
+
+ insinto /etc/vdr/plugins/vomp
+ newins vomp.conf.sample vomp.conf
+ newins vomp-00-00-00-00-00-00.conf.sample vomp-00-00-00-00-00-00.conf
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ echo
+ elog "Have a look to the VOMP sample files in /etc/vdr/plugins."
+ echo
+ elog "You have to download the dongle file (i.e. firmware) and adapt"
+ elog "the vomp configuration files accordingly."
+ echo
+}
diff --git a/media-plugins/vdr-vompserver/vdr-vompserver-0.4.0.ebuild b/media-plugins/vdr-vompserver/vdr-vompserver-0.4.0.ebuild
new file mode 100644
index 000000000000..7de4173faea6
--- /dev/null
+++ b/media-plugins/vdr-vompserver/vdr-vompserver-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: server part for MediaMVP device"
+HOMEPAGE="http://www.loggytronic.com/vomp.php"
+SRC_URI="http://www.loggytronic.com/dl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.36-r1"
+RDEPEND="${DEPEND}"
+
+KEEP_I18NOBJECT="yes"
+
+src_prepare() {
+ cp "${FILESDIR}/${VDRPLUGIN}.mk" "${S}/Makefile"
+
+ vdr-plugin-2_src_prepare
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ dodoc README
+
+ insinto /etc/vdr/plugins/vompserver
+ newins vomp.conf.sample vomp.conf
+ newins vomp-00-00-00-00-00-00.conf.sample vomp-00-00-00-00-00-00.conf
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "\nHave a look to the VOMP sample files in /etc/vdr/plugins.\n"
+
+ elog "You have to download the dongle file (i.e. firmware) and adapt"
+ elog "the vomp configuration files accordingly."
+}
diff --git a/media-plugins/vdr-vompserver/vdr-vompserver-0.4.1.ebuild b/media-plugins/vdr-vompserver/vdr-vompserver-0.4.1.ebuild
new file mode 100644
index 000000000000..8cce67252ca2
--- /dev/null
+++ b/media-plugins/vdr-vompserver/vdr-vompserver-0.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Plugin: server part for MediaMVP device"
+HOMEPAGE="http://www.loggytronic.com/vomp.php"
+SRC_URI="http://www.loggytronic.com/dl/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=">=media-video/vdr-1.7.36-r1"
+RDEPEND="${DEPEND}"
+
+KEEP_I18NOBJECT="yes"
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/vompserver
+ newins vomp.conf.sample vomp.conf
+ newins vomp-00-00-00-00-00-00.conf.sample vomp-00-00-00-00-00-00.conf
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ elog "\nHave a look to the VOMP sample files in /etc/vdr/plugins.\n"
+
+ elog "You have to download the dongle file (i.e. firmware) and adapt"
+ elog "the vomp configuration files accordingly."
+}