summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild')
-rw-r--r--media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild b/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
new file mode 100644
index 000000000000..67726def6d01
--- /dev/null
+++ b/media-plugins/vdr-weatherng/vdr-weatherng-0.0.8_pre3-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vdr-plugin-2
+
+MY_PV="${PV/_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="VDR plugin: show weather for specified place"
+HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
+SRC_URI="mirror://vdrfiles/${PN}/${MY_P}.tgz"
+
+LICENSE="GPL-2 stardock-images"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dxr3"
+
+DEPEND="media-libs/imlib2[jpeg,gif]
+ >=media-video/vdr-1.3.34"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/weatherng-${MY_PV}"
+
+VDR_CONFD_FILE="${FILESDIR}/confd-0.0.8"
+VDR_RCADDON_FILE="${FILESDIR}/rc-addon-0.0.8.sh"
+
+PATCHES=("${FILESDIR}/${P}-i18n-fix.diff")
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ epatch "${FILESDIR}/${P}-timeout.diff"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+
+ use dxr3 && epatch "${FILESDIR}/${P}-dxr3.diff"
+
+ # /bin/sh is not necessaryly bash, so explicitly use /bin/bash
+ sed -e 's#/bin/sh#/bin/bash#' -i examples/weatherng.sh
+
+ sed -i weatherng.c -e "s:RegisterI18n://RegisterI18n:"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /usr/share/vdr/weatherng/images
+ doins "${S}"/images/*.png
+
+ diropts -m0755 -ovdr -gvdr
+ dodir /var/vdr/${VDRPLUGIN}
+
+ insinto /var/vdr/${VDRPLUGIN}
+ insopts -m755 -ovdr -gvdr
+ doins "${S}"/examples/weatherng.sh
+}
+
+pkg_postinst() {
+ vdr-plugin-2_pkg_postinst
+
+ echo
+ elog "To display the weather for your location"
+ elog "you have to find out its ID on weather.com"
+ elog
+ elog "Go to http://uk.weather.com/search/drilldown/ and search for your city (i.e. Herne)"
+ elog "in the list of results click on the right one and then look at its URL"
+ elog
+ elog "It contains a code for your city"
+ elog "For Herne this is GMXX0056"
+ elog
+ elog "Now you have to enter this code in /etc/conf.d/vdr.weatherng WEATHERNG_STATIONID(x)"
+ echo
+}