summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2017-07-03 21:26:31 +0200
committerMatthias Schwarzott <zzam@gentoo.org>2017-07-03 21:32:56 +0200
commitb97cd6bf29233c0d0b8cb63e61d8e4a564e5c1e8 (patch)
treefd9c6d87cd578c3553430268b47d6fb1945dfca4 /media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild
parentmedia-gfx/darktable: version bump (diff)
downloadgentoo-b97cd6bf29233c0d0b8cb63e61d8e4a564e5c1e8.tar.gz
gentoo-b97cd6bf29233c0d0b8cb63e61d8e4a564e5c1e8.tar.bz2
gentoo-b97cd6bf29233c0d0b8cb63e61d8e4a564e5c1e8.zip
media-plugins/vdr-xineliboutput: Fix wrong versions for snapshot versions
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild')
-rw-r--r--media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild146
1 files changed, 0 insertions, 146 deletions
diff --git a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild b/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild
deleted file mode 100644
index 537dd92935a7..000000000000
--- a/media-plugins/vdr-xineliboutput/vdr-xineliboutput-2.0.0_p20150220.ebuild
+++ /dev/null
@@ -1,146 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit vdr-plugin-2
-
-GENTOO_VDR_CONDITIONAL=yes
-
-DESCRIPTION="VDR Plugin: Xinelib PlugIn"
-HOMEPAGE="https://sourceforge.net/projects/xineliboutput/"
-SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tar.xz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="bluray caps dbus fbcon jpeg libextractor nls opengl +vdr vdpau +X +xine xinerama"
-
-COMMON_DEPEND="
- vdr? (
- >=media-video/vdr-1.6.0
- libextractor? ( >=media-libs/libextractor-0.5.20 )
- caps? ( sys-libs/libcap )
- )
-
- xine? (
- ( >=media-libs/xine-lib-1.2
- virtual/ffmpeg )
- fbcon? ( jpeg? ( virtual/jpeg:* ) )
- X? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrender
- xinerama? ( x11-libs/libXinerama )
- dbus? ( dev-libs/dbus-glib dev-libs/glib:2 )
- vdpau? ( x11-libs/libvdpau >=media-libs/xine-lib-1.2 )
- jpeg? ( virtual/jpeg:* )
- bluray? ( media-libs/libbluray )
- opengl? ( virtual/opengl )
- )
- )"
-
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- sys-kernel/linux-headers
- nls? ( sys-devel/gettext )
- xine? (
- X? (
- x11-proto/xproto
- x11-libs/libXxf86vm
- )
- )"
-RDEPEND="${COMMON_DEPEND}"
-
-REQUIRED_USE=" || ( vdr xine )"
-
-VDR_CONFD_FILE="${FILESDIR}/confd-2.0.0"
-
-pkg_setup() {
- vdr-plugin-2_pkg_setup
-
- if use xine; then
- XINE_PLUGIN_DIR=$(pkg-config --variable=plugindir libxine)
- [ -z "${XINE_PLUGIN_DIR}" ] && die "Could not find xine plugin dir"
- fi
-}
-
-src_configure() {
- local myconf
-
- if has_version ">=media-libs/xine-lib-1.2"; then
- myconf="${myconf} --enable-libavutil"
- else
- myconf="${myconf} --disable-libavutil"
- fi
-
- # No autotools based configure script
- ./configure \
- --cc=$(tc-getCC) \
- --cxx=$(tc-getCXX) \
- $(use_enable X x11) \
- $(use_enable X xshm) \
- $(use_enable X xdpms) \
- $(use_enable X xshape) \
- $(use_enable X xrender) \
- $(use_enable fbcon fb) \
- $(use_enable vdr) \
- $(use_enable xine libxine) \
- $(use_enable libextractor) \
- $(use_enable caps libcap) \
- $(use_enable jpeg libjpeg) \
- $(use_enable xinerama) \
- $(use_enable vdpau) \
- $(use_enable dbus dbus-glib-1) \
- $(use_enable nls i18n) \
- $(use_enable bluray libbluray) \
- $(use_enable opengl) \
- ${myconf} \
- || die
-
- # UINT64_C is needed by ffmpeg headers
- append-cxxflags -D__STDC_CONSTANT_MACROS
-}
-
-src_install() {
- if use vdr; then
- vdr-plugin-2_src_install
-
- # bug 346989
- insinto /etc/vdr/plugins/xineliboutput/
- doins examples/allowed_hosts.conf
- fowners -R vdr:vdr /etc/vdr/
-
- if use nls; then
- emake DESTDIR="${D}" i18n
- fi
-
- if use xine; then
- doinitd "${FILESDIR}"/vdr-frontend
-
- insinto $XINE_PLUGIN_DIR
- doins xineplug_inp_xvdr.so
-
- insinto $XINE_PLUGIN_DIR/post
- doins xineplug_post_*.so
-
- if use fbcon; then
- dobin vdr-fbfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-fbfe.so.*
- fi
-
- if use X; then
- dobin vdr-sxfe
-
- insinto $VDR_PLUGIN_DIR
- doins libxineliboutput-sxfe.so.*
- fi
- fi
- else
- emake DESTDIR="${D}" install
-
- dodoc HISTORY README
- fi
-}