summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-05-03 20:40:27 +0300
committerMart Raudsepp <leio@gentoo.org>2020-05-03 22:12:05 +0300
commit3293300c2b17e60209213dc9fef2eec3569635ed (patch)
tree95ac29f060e09b5b36a6e3e0ae85767f53601db8 /media-plugins
parentmedia-plugins/gst-plugins-gdkpixbuf: bump to 1.16.2 (diff)
downloadgentoo-3293300c2b17e60209213dc9fef2eec3569635ed.tar.gz
gentoo-3293300c2b17e60209213dc9fef2eec3569635ed.tar.bz2
gentoo-3293300c2b17e60209213dc9fef2eec3569635ed.zip
media-plugins/gst-plugins-gtk: bump to 1.16.2
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/gst-plugins-gtk/Manifest1
-rw-r--r--media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-gtk/Manifest b/media-plugins/gst-plugins-gtk/Manifest
index ff83b44437dd..32073ca6e983 100644
--- a/media-plugins/gst-plugins-gtk/Manifest
+++ b/media-plugins/gst-plugins-gtk/Manifest
@@ -1 +1,2 @@
DIST gst-plugins-good-1.14.5.tar.xz 3800104 BLAKE2B acb8ba559c8f4d96cb548fa05e88a556dbfd3aed8572d91cee4fc7b652ab1e814a615713f1372a0acdaa723ddf2d9af9c84c599bc4128b8f61d03bfbc096dcce SHA512 11bfadaf39b28a0a6a6c87c4ade8513496e8f13873cb0c2ddc8b8241029b8775d4839f2de441bda664bc67c66c4ca1d6839dd7570f7d79c1f485d5a25cc9d236
+DIST gst-plugins-good-1.16.2.tar.xz 3897172 BLAKE2B b6341bb2f2456e2c558f71e9f18726eced88cbc703fa017067415297cc7ccdf70b4ceb18e9e3c7c64fc7c55806c7373d9a05eac582067ab764a02c1bafef4b33 SHA512 ab0dfd51af3ea345db466618547c35c78b5f08e725096b66074a5a7e0a83ca25ac51d2d915b7a8c07b70f8e4c9fc65d51c1851f147a5a5a71fbca58e1eb5ffd4
diff --git a/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
new file mode 100644
index 000000000000..1b37803b64ac
--- /dev/null
+++ b/media-plugins/gst-plugins-gtk/gst-plugins-gtk-1.16.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE=gst-plugins-good
+
+inherit gstreamer
+
+DESCRIPTION="Video sink plugin for GStreamer that renders to a GtkWidget"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+egl gles2 +opengl wayland +X" # Keep default IUSE mirrored with gst-plugins-base
+# egl, wayland and X only matters if gst-plugins-base is built with USE=opengl and/or USE=gles2
+# We mirror egl/gles2/opengl/wayland/X due to automagic detection from gstreamer-gl.pc variables;
+# we don't care about matching egl/wayland/X if both opengl and gles2 are disabled here and on
+# gst-plugins-base, but no way to express that.
+
+# We only need gtk+ matching backend flags when GL is enabled
+GL_DEPS="
+ >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},egl=,gles2=,opengl=,wayland=,X=]
+ >=x11-libs/gtk+-3.15:3[${MULTILIB_USEDEP}]
+ gles2? ( ${GL_DEPS} )
+ opengl? ( ${GL_DEPS} )
+
+ !<media-libs/gst-plugins-bad-1.13.1:1.0
+"
+DEPEND="${RDEPEND}"
+
+GST_PLUGINS_BUILD="gtk3"