summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-05 16:41:17 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2020-01-05 16:41:55 +0100
commit84014afdc8783146d314c74c7039978548e9908e (patch)
treedfccbad9831cfdc690f9229f92d341d81f66f2f6 /media-plugins
parentdev-libs/libdnsres: Clean up patch (diff)
downloadgentoo-84014afdc8783146d314c74c7039978548e9908e.tar.gz
gentoo-84014afdc8783146d314c74c7039978548e9908e.tar.bz2
gentoo-84014afdc8783146d314c74c7039978548e9908e.zip
media-plugins/vdr-skinelchi: compile fix for not declared min/max
Closes: https://bugs.gentoo.org/703994 Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/vdr-skinelchi/files/vdr-skinelchi-0.3.0_min_max_from_stl.patch18
-rw-r--r--media-plugins/vdr-skinelchi/vdr-skinelchi-0.3.0-r2.ebuild41
2 files changed, 59 insertions, 0 deletions
diff --git a/media-plugins/vdr-skinelchi/files/vdr-skinelchi-0.3.0_min_max_from_stl.patch b/media-plugins/vdr-skinelchi/files/vdr-skinelchi-0.3.0_min_max_from_stl.patch
new file mode 100644
index 000000000000..123d0e4d5575
--- /dev/null
+++ b/media-plugins/vdr-skinelchi/files/vdr-skinelchi-0.3.0_min_max_from_stl.patch
@@ -0,0 +1,18 @@
+taken from debian vdr repo
+this will fix
+https://bugs.gentoo.org/703994
+
+Reviewed-by: Joerg Bornkessel <hd_brummy@gentoo.org> ( 2020 Jan 05 )
+Index: b/DisplayChannel.c
+===================================================================
+--- a/DisplayChannel.c
++++ b/DisplayChannel.c
+@@ -724,7 +724,7 @@
+ }
+ else {
+ time_t t = time(NULL);
+- int seen = max(0, min(y9 - y6a - 1, int((y9 - y6a) * double(t - Present->StartTime()) / Present->Duration())));
++ int seen = std::max(0, std::min(y9 - y6a - 1, int((y9 - y6a) * double(t - Present->StartTime()) / Present->Duration())));
+ osd->DrawRectangle(x4 + Gap, y6a + seen, x4 + Gap + ScrollWidth - 1, y9 - 1, Theme.Color(clrChannelTimebarRest));
+ osd->DrawRectangle(x4 + Gap, y6a, x4 + Gap + ScrollWidth - 1, y6a + seen - 1, Theme.Color(clrChannelTimebarSeen));
+ changed = true;
diff --git a/media-plugins/vdr-skinelchi/vdr-skinelchi-0.3.0-r2.ebuild b/media-plugins/vdr-skinelchi/vdr-skinelchi-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..0f5afd259943
--- /dev/null
+++ b/media-plugins/vdr-skinelchi/vdr-skinelchi-0.3.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR Skin Plugin: skinelchi"
+HOMEPAGE="http://firefly.vdr-developer.org/skinelchi"
+SRC_URI="http://firefly.vdr-developer.org/skinelchi/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="media-video/vdr"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ #bug #599148
+ append-cxxflags -std=gnu++11
+
+ # disable imagemagick support, broken ...
+ sed -i "${S}"/Makefile -e \
+ "s:SKINELCHI_HAVE_IMAGEMAGICK = 1:SKINELCHI_HAVE_IMAGEMAGICK = 0:"
+
+ sed -i "${S}"/DisplayChannel.c \
+ -e "s:/hqlogos::" \
+ -e "s:/logos::"
+
+ # wrong sed in vdr-plugin-2.eclass?
+ sed -e "s:INCLUDES += -I\$(VDRINCDIR):INCLUDES += -I\$(VDRINCDIR)/include:" \
+ -i Makefile
+
+ # gcc-6 warnings
+ sed -e "s:auto_ptr:unique_ptr:" -i services/epgsearch_services.h
+
+ # wrt bug 703994
+ eapply "${FILESDIR}/${P}_min_max_from_stl.patch"
+}