summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/svxlink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/svxlink')
-rw-r--r--media-radio/svxlink/Manifest3
-rw-r--r--media-radio/svxlink/files/remotetrx.init43
-rw-r--r--media-radio/svxlink/files/remotetrx.rc21
-rw-r--r--media-radio/svxlink/files/svxlink-11.11.1-gcc-47.patch10
-rw-r--r--media-radio/svxlink/files/svxlink.init43
-rw-r--r--media-radio/svxlink/files/svxlink.rc21
-rw-r--r--media-radio/svxlink/metadata.xml17
-rw-r--r--media-radio/svxlink/svxlink-13.03.ebuild55
-rw-r--r--media-radio/svxlink/svxlink-13.07.ebuild55
-rw-r--r--media-radio/svxlink/svxlink-13.12.ebuild56
10 files changed, 324 insertions, 0 deletions
diff --git a/media-radio/svxlink/Manifest b/media-radio/svxlink/Manifest
new file mode 100644
index 000000000000..43d371875469
--- /dev/null
+++ b/media-radio/svxlink/Manifest
@@ -0,0 +1,3 @@
+DIST svxlink-13.03.tar.gz 1071980 SHA256 638d239d94d120a8efd1b4f1f5456f8e1a2f2e24893dbd40db89a750634e58ea SHA512 148aca62d903625b7e84c56178bc9d396593e377d731dfe0f6aea3eaffd5e820ac7825c5a1e2ede30ceb9aedd4da135a8e56a8fad804eb74f3cce67eb1500dfc WHIRLPOOL 244bdb883344d9f343e9cddff7466b350ee26409904545eb8261c8fa9b7af2e7f815e2e0d75b64be42862898cc3f7031eb6a58813aee6ef535dade752da56b54
+DIST svxlink-13.07.tar.gz 1123208 SHA256 b8d4c25009a7d6294ebf4fffe8daca866778c9f8c8df35a739cb71947c9a3c1a SHA512 2d65bcae375935242105390b5b43d22dd68f3541207a688a277b86179cca3c90c1cebb5eec76e687e31b09aea7829bf68ec2fc99f183d2681fc14f0c51b60667 WHIRLPOOL 9556ee8ec934b8f18cabb61350539471c3a9fb2241d7165f141f17dcfa3d122934531fd4d14b3f626580b2f41eb61663bb4e235db0c7f9bf58577c4193202d9d
+DIST svxlink-13.12.tar.gz 1168697 SHA256 c2a991a35f3386027e33f35c53c9d383231bc8e3184c8e2fef871e4f68622245 SHA512 442320c7f29e090ab3596c607c640d310cd534093203264a9cb57f3e768b83604bffa478a2e743b37a2a82fd093b83050a1c300c623f01191048119091b4bf74 WHIRLPOOL 0c9ba108b076dca6ad5fa6ccf02141a83159a2bb28cf4653d614502cf6255583ada9281490fadd212837b97a5f7a7d75eb292fd35a912569d8122a005c409ebb
diff --git a/media-radio/svxlink/files/remotetrx.init b/media-radio/svxlink/files/remotetrx.init
new file mode 100644
index 000000000000..cfadbc7fe8d1
--- /dev/null
+++ b/media-radio/svxlink/files/remotetrx.init
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PNAME=remotetrx
+NAME="RemoteTrx Server"
+DAEMON=/usr/bin/$PNAME
+
+POPTS="--daemon \
+ ${RUNASUSER:+--runasuser=$RUNASUSER} \
+ ${PIDFILE:+--pidfile=$PIDFILE} \
+ ${LOGFILE:+--logfile=$LOGFILE} \
+ ${CFGFILE:+--config=$CFGFILE}"
+
+create_logfile()
+{
+ touch $LOGFILE
+ if [ -n "$RUNASUSER" ]; then
+ chown $RUNASUSER.$RUNASUSER $LOGFILE
+ fi
+}
+
+
+depend() {
+ need localmount
+ use net
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting $NAME"
+ create_logfile
+ export $ENV
+ start-stop-daemon --start --pidfile $PIDFILE --exec $DAEMON -- $POPTS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --pidfile $PIDFILE --exec $DAEMON
+ eend $?
+}
diff --git a/media-radio/svxlink/files/remotetrx.rc b/media-radio/svxlink/files/remotetrx.rc
new file mode 100644
index 000000000000..940cc389bf4c
--- /dev/null
+++ b/media-radio/svxlink/files/remotetrx.rc
@@ -0,0 +1,21 @@
+#############################################################################
+#
+# Configuration file for the RemoteTrx startup script /etc/init.d/remotetrx
+#
+#############################################################################
+
+# The log file to use
+LOGFILE=/var/log/remotetrx
+
+# The PID file to use
+PIDFILE=/var/run/remotetrx.pid
+
+# The user to run the SvxLink server as
+RUNASUSER=svxlink
+
+# Specify which configuration file to use
+CFGFILE=/etc/svxlink/remotetrx.conf
+
+# Environment variables to set up. Separate variables with a space.
+ENV="ASYNC_AUDIO_NOTRIGGER=1"
+
diff --git a/media-radio/svxlink/files/svxlink-11.11.1-gcc-47.patch b/media-radio/svxlink/files/svxlink-11.11.1-gcc-47.patch
new file mode 100644
index 000000000000..b13985ace9c7
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink-11.11.1-gcc-47.patch
@@ -0,0 +1,10 @@
+--- async/cpp/AsyncCppDnsLookupWorker.cpp.old 2012-07-31 17:45:31.000000000 +0000
++++ async/cpp/AsyncCppDnsLookupWorker.cpp 2012-07-31 17:45:24.000000000 +0000
+@@ -38,6 +38,7 @@
+ *
+ ****************************************************************************/
+
++#include <unistd.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/media-radio/svxlink/files/svxlink.init b/media-radio/svxlink/files/svxlink.init
new file mode 100644
index 000000000000..ceded48f41b7
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink.init
@@ -0,0 +1,43 @@
+#!/sbin/runscript
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+PNAME=svxlink
+NAME="SvxLink Server"
+DAEMON=/usr/bin/$PNAME
+
+POPTS="--daemon \
+ ${RUNASUSER:+--runasuser=$RUNASUSER} \
+ ${PIDFILE:+--pidfile=$PIDFILE} \
+ ${LOGFILE:+--logfile=$LOGFILE} \
+ ${CFGFILE:+--config=$CFGFILE}"
+
+create_logfile()
+{
+ touch $LOGFILE
+ if [ -n "$RUNASUSER" ]; then
+ chown $RUNASUSER.$RUNASUSER $LOGFILE
+ fi
+}
+
+
+depend() {
+ need localmount
+ use net
+ after bootmisc
+}
+
+start() {
+ ebegin "Starting $NAME"
+ create_logfile
+ export $ENV
+ start-stop-daemon --start --pidfile $PIDFILE --exec $DAEMON -- $POPTS
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $NAME"
+ start-stop-daemon --stop --pidfile $PIDFILE --exec $DAEMON
+ eend $?
+}
diff --git a/media-radio/svxlink/files/svxlink.rc b/media-radio/svxlink/files/svxlink.rc
new file mode 100644
index 000000000000..5f19f576e824
--- /dev/null
+++ b/media-radio/svxlink/files/svxlink.rc
@@ -0,0 +1,21 @@
+#############################################################################
+#
+# Configuration file for the SvxLink startup script /etc/init.d/svxlink
+#
+#############################################################################
+
+# The log file to use
+LOGFILE=/var/log/svxlink
+
+# The PID file to use
+PIDFILE=/var/run/svxlink.pid
+
+# The user to run the SvxLink server as
+RUNASUSER=svxlink
+
+# Specify which configuration file to use
+CFGFILE=/etc/svxlink/svxlink.conf
+
+# Environment variables to set up. Separate variables with a space.
+ENV="ASYNC_AUDIO_NOTRIGGER=1"
+
diff --git a/media-radio/svxlink/metadata.xml b/media-radio/svxlink/metadata.xml
new file mode 100644
index 000000000000..3d86de25052d
--- /dev/null
+++ b/media-radio/svxlink/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>tomjbe@gentoo.org</email>
+ <name>Thomas Beierlein</name>
+ </maintainer>
+ <longdescription lang="en">
+ The SvxLink project aim to develop a flexible, general purpose voice
+ services system for ham radio use. The svxlink server consists of a core
+ that handles the connection to the tranceiver. The project also
+ includes an EchoLink client GUI application (Qtel).
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">svxlink</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-radio/svxlink/svxlink-13.03.ebuild b/media-radio/svxlink/svxlink-13.03.ebuild
new file mode 100644
index 000000000000..2300f8e93ff6
--- /dev/null
+++ b/media-radio/svxlink/svxlink-13.03.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib qt4-r2 user
+
+DESCRIPTION="Multi Purpose Voice Services System, including Qtel for EchoLink"
+HOMEPAGE="http://svxlink.sourceforge.net/"
+SRC_URI="mirror://sourceforge/svxlink/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl:0
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/alsa-lib
+ media-sound/gsm
+ dev-libs/libgcrypt:0
+ media-libs/speex
+ dev-libs/libsigc++:2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ enewgroup svxlink
+ enewuser svxlink -1 -1 -1 svxlink
+}
+
+src_prepare() {
+ sed -i -e "s:/lib:/$(get_libdir):g" makefile.cfg || die
+ sed -i -e "s:/etc/udev:/lib/udev:" svxlink/scripts/Makefile.default || die
+ # fix underlinking
+ sed -i -e "s:lgsm:lgsm -lspeex:" qtel/Makefile.default || die
+ # drop deprecated desktop category (bug #475730)
+ sed -i -e "s:Categories=Application;:Categories=:g" qtel/qtel.desktop || die
+}
+
+src_install() {
+ default
+
+ fowners -R svxlink.svxlink /var/spool/svxlink
+ # adapt to gentoo init system
+ rm -R "${D}"/etc/sysconfig || die
+ newinitd "${FILESDIR}"/remotetrx.init remotetrx
+ newinitd "${FILESDIR}"/svxlink.init svxlink
+ newconfd "${FILESDIR}"/remotetrx.rc remotetrx
+ newconfd "${FILESDIR}"/svxlink.rc svxlink
+}
diff --git a/media-radio/svxlink/svxlink-13.07.ebuild b/media-radio/svxlink/svxlink-13.07.ebuild
new file mode 100644
index 000000000000..2300f8e93ff6
--- /dev/null
+++ b/media-radio/svxlink/svxlink-13.07.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib qt4-r2 user
+
+DESCRIPTION="Multi Purpose Voice Services System, including Qtel for EchoLink"
+HOMEPAGE="http://svxlink.sourceforge.net/"
+SRC_URI="mirror://sourceforge/svxlink/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl:0
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/alsa-lib
+ media-sound/gsm
+ dev-libs/libgcrypt:0
+ media-libs/speex
+ dev-libs/libsigc++:2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ enewgroup svxlink
+ enewuser svxlink -1 -1 -1 svxlink
+}
+
+src_prepare() {
+ sed -i -e "s:/lib:/$(get_libdir):g" makefile.cfg || die
+ sed -i -e "s:/etc/udev:/lib/udev:" svxlink/scripts/Makefile.default || die
+ # fix underlinking
+ sed -i -e "s:lgsm:lgsm -lspeex:" qtel/Makefile.default || die
+ # drop deprecated desktop category (bug #475730)
+ sed -i -e "s:Categories=Application;:Categories=:g" qtel/qtel.desktop || die
+}
+
+src_install() {
+ default
+
+ fowners -R svxlink.svxlink /var/spool/svxlink
+ # adapt to gentoo init system
+ rm -R "${D}"/etc/sysconfig || die
+ newinitd "${FILESDIR}"/remotetrx.init remotetrx
+ newinitd "${FILESDIR}"/svxlink.init svxlink
+ newconfd "${FILESDIR}"/remotetrx.rc remotetrx
+ newconfd "${FILESDIR}"/svxlink.rc svxlink
+}
diff --git a/media-radio/svxlink/svxlink-13.12.ebuild b/media-radio/svxlink/svxlink-13.12.ebuild
new file mode 100644
index 000000000000..a6b9bdac436e
--- /dev/null
+++ b/media-radio/svxlink/svxlink-13.12.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib qt4-r2 user
+
+DESCRIPTION="Multi Purpose Voice Services System, including Qtel for EchoLink"
+HOMEPAGE="http://svxlink.sourceforge.net/"
+SRC_URI="mirror://sourceforge/svxlink/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-lang/tcl:0
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/alsa-lib
+ media-sound/gsm
+ dev-libs/libgcrypt:0
+ media-libs/speex
+ media-libs/opus
+ dev-libs/libsigc++:2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_setup() {
+ enewgroup svxlink
+ enewuser svxlink -1 -1 -1 svxlink
+}
+
+src_prepare() {
+ sed -i -e "s:/lib:/$(get_libdir):g" makefile.cfg || die
+ sed -i -e "s:/etc/udev:/lib/udev:" svxlink/scripts/Makefile.default || die
+ # fix underlinking
+ sed -i -e "s:lgsm:lgsm -lspeex:" qtel/Makefile.default || die
+ # drop deprecated desktop category (bug #475730)
+ sed -i -e "s:Categories=Application;:Categories=:g" qtel/qtel.desktop || die
+}
+
+src_install() {
+ default
+
+ fowners -R svxlink.svxlink /var/spool/svxlink
+ # adapt to gentoo init system
+ rm -R "${D}"/etc/sysconfig || die
+ newinitd "${FILESDIR}"/remotetrx.init remotetrx
+ newinitd "${FILESDIR}"/svxlink.init svxlink
+ newconfd "${FILESDIR}"/remotetrx.rc remotetrx
+ newconfd "${FILESDIR}"/svxlink.rc svxlink
+}