summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2023-03-07 13:30:56 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2023-03-07 13:34:57 +0100
commita18c33a93e04ac6fd08a9e1956f3d71a0ddc24b6 (patch)
tree00c6a97e852d20e3b22c79cbf0588edf76916143 /media-radio
parentgnome-extra/gnome-shell-extension-appindicator: add 50 (diff)
downloadgentoo-a18c33a93e04ac6fd08a9e1956f3d71a0ddc24b6.tar.gz
gentoo-a18c33a93e04ac6fd08a9e1956f3d71a0ddc24b6.tar.bz2
gentoo-a18c33a93e04ac6fd08a9e1956f3d71a0ddc24b6.zip
media-radio/tucnak: Fix implicit function declaration in configure.ac
Closes: https://bugs.gentoo.org/899844 Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/tucnak/files/tucnak-4.40-configure.patch22
-rw-r--r--media-radio/tucnak/tucnak-4.40-r1.ebuild71
2 files changed, 93 insertions, 0 deletions
diff --git a/media-radio/tucnak/files/tucnak-4.40-configure.patch b/media-radio/tucnak/files/tucnak-4.40-configure.patch
new file mode 100644
index 000000000000..c7a83a892ce9
--- /dev/null
+++ b/media-radio/tucnak/files/tucnak-4.40-configure.patch
@@ -0,0 +1,22 @@
+# fix implicit function declaration in configure.ac
+# Bug 899844
+diff --git a/configure.ac b/configure.ac
+index c3ebffb..29abf94 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -664,6 +664,7 @@ AC_TRY_RUN([
+ #define AUTOCONF_TEST 1
+ #include <sys/ioctl.h>
+ #include "confdefs.h"
++#include <stdlib.h>
+ int cmp(const struct dirent **a, const struct dirent **b){return 0;}
+ int main(){
+ char c[2];
+@@ -684,6 +685,7 @@ AC_TRY_RUN([
+ #define AUTOCONF_TEST 1
+ #include <sys/socket.h>
+ #include "confdefs.h"
++#include <stdlib.h>
+ int main(){
+ socklen_t tmp;
+ exit(0);
diff --git a/media-radio/tucnak/tucnak-4.40-r1.ebuild b/media-radio/tucnak/tucnak-4.40-r1.ebuild
new file mode 100644
index 000000000000..2c8e4466e90b
--- /dev/null
+++ b/media-radio/tucnak/tucnak-4.40-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools flag-o-matic
+
+DESCRIPTION="Amateur Radio VHF Contest Logbook"
+HOMEPAGE="http://tucnak.nagano.cz"
+SRC_URI="http://tucnak.nagano.cz/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa fftw gpm hamlib suid"
+
+RDEPEND="dev-libs/glib:2
+ ~dev-libs/libzia-4.40
+ media-libs/libsndfile
+ media-libs/libsdl2
+ alsa? ( media-libs/alsa-lib )
+ fftw? ( sci-libs/fftw:3.0 )
+ gpm? ( sys-libs/gpm )
+ hamlib? ( media-libs/hamlib:= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-${PV}-configure.patch )
+
+src_prepare() {
+ eapply_user
+ eapply ${PATCHES[@]}
+ # fix destop file
+ sed -i -e "s/HamRadio/HamRadio;/" share/applications/tucnak.desktop || die
+ # fix doc install path
+ sed -i -e "s/docsdir/# docsdir/" \
+ -e "s/docs_DATA =/# docs_DATA/" \
+ -e "s/EXTRA_DIST =/# EXTRA_DIST =/" Makefile.am doc/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf $(use_with alsa) \
+ $(use_with gpm) $(use_with hamlib) \
+ $(use_with fftw fftw3)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog doc/NAVOD.pdf
+ if use suid ; then
+ fperms 4711 /usr/bin/soundwrapper
+ fi
+}
+
+pkg_postinst() {
+ elog "In order to use sound with tucnak add yourself to the 'audio' group"
+ elog "and to key your rig via the parport add yourself to the 'lp' group"
+ elog ""
+ elog "tucnak can be used with the following additional packages:"
+ elog " media-radio/cwdaemon : Morse output via code cwdaemon"
+ elog " (No need to recompile)"
+ if use suid ; then
+ ewarn "You have choosen to install the little helper program 'soundwrapper'"
+ ewarn "setuid by setting USE=suid. That helper is only needed if you"
+ ewarn "want to use morse sidetone output via the PC speaker."
+ ewarn ""
+ ewarn "While the helper should be safe by design be aware that setting"
+ ewarn "any program setuid is a security risk."
+ fi
+}