summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/a2jmidid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/a2jmidid')
-rw-r--r--media-sound/a2jmidid/Manifest1
-rw-r--r--media-sound/a2jmidid/a2jmidid-8-r1.ebuild46
-rw-r--r--media-sound/a2jmidid/a2jmidid-8.ebuild44
-rw-r--r--media-sound/a2jmidid/files/a2jmidid-link.patch33
-rw-r--r--media-sound/a2jmidid/metadata.xml15
5 files changed, 139 insertions, 0 deletions
diff --git a/media-sound/a2jmidid/Manifest b/media-sound/a2jmidid/Manifest
new file mode 100644
index 000000000000..b54d4ba374e0
--- /dev/null
+++ b/media-sound/a2jmidid/Manifest
@@ -0,0 +1 @@
+DIST a2jmidid-8.tar.bz2 162764 SHA256 2a9635f62aabc59edb54ada07048dd47e896b90caff94bcee710d3582606f55f SHA512 6182a295462ae587461ca395d85c956523bfecd113d031d0ae8a9f304fc3d41f6a5097b3a1a9fc06bd0eef7fe08a4b3c116a3361ff9e63468c3e40b736215592 WHIRLPOOL 04408b6eb3460a522da6009e142fa113fd95c20efbce6c1fcca30a2966478950fc3d5c061694bb533fd5f3261f2d26f22b507bff5fb73050f2fb57a23c6c8936
diff --git a/media-sound/a2jmidid/a2jmidid-8-r1.ebuild b/media-sound/a2jmidid/a2jmidid-8-r1.ebuild
new file mode 100644
index 000000000000..418ee3427075
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-8-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE='threads(+)'
+NO_WAF_LIBDIR=1
+
+inherit python-single-r1 toolchain-funcs waf-utils eutils
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="http://home.gna.org/a2jmidid/"
+SRC_URI="http://download.gna.org/a2jmidid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dbus? ( sys-apps/dbus )
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS README NEWS internals.txt)
+
+src_prepare() {
+ # Bug 518382
+ epatch "${FILESDIR}"/${PN}-link.patch
+}
+
+src_configure() {
+ if use dbus ; then
+ waf-utils_src_configure
+ else
+ waf-utils_src_configure --disable-dbus
+ fi
+}
+
+src_install() {
+ waf-utils_src_install
+ python_fix_shebang "${ED}"
+}
diff --git a/media-sound/a2jmidid/a2jmidid-8.ebuild b/media-sound/a2jmidid/a2jmidid-8.ebuild
new file mode 100644
index 000000000000..61d53c3081d5
--- /dev/null
+++ b/media-sound/a2jmidid/a2jmidid-8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+PYTHON_DEPEND="2"
+NO_WAF_LIBDIR=1
+
+inherit python toolchain-funcs waf-utils
+
+DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
+HOMEPAGE="http://home.gna.org/a2jmidid/"
+SRC_URI="http://download.gna.org/a2jmidid/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="dbus"
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=(AUTHORS README NEWS internals.txt)
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ if use dbus ; then
+ waf-utils_src_configure
+ else
+ waf-utils_src_configure --disable-dbus
+ fi
+}
+
+src_install() {
+ waf-utils_src_install
+ python_convert_shebangs -r 2 "${ED}"
+}
diff --git a/media-sound/a2jmidid/files/a2jmidid-link.patch b/media-sound/a2jmidid/files/a2jmidid-link.patch
new file mode 100644
index 000000000000..8b41f6ec1a41
--- /dev/null
+++ b/media-sound/a2jmidid/files/a2jmidid-link.patch
@@ -0,0 +1,33 @@
+From 7f82da7eb2f540a94db23331be98d42a58ddc269 Mon Sep 17 00:00:00 2001
+From: Nedko Arnaudov <nedko@arnaudov.name>
+Date: Tue, 10 Jul 2012 07:25:12 +0300
+Subject: [PATCH] properly fix pthread linking. Patch by Orcan. sr#2934
+
+---
+ wscript | 5 +++--
+ 1 file changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/wscript b/wscript
+index 36710e2..66a532a 100644
+--- a/wscript
++++ b/wscript
+@@ -66,7 +66,8 @@ def configure(conf):
+ else:
+ conf.env['DBUS_ENABLED'] = False
+
+ conf.env['LIB_DL'] = ['dl']
++ conf.env['LIB_PTHREAD'] = ['pthread']
+
+ #conf.check_header('expat.h', mandatory=True)
+ #conf.env['LIB_EXPAT'] = ['expat']
+@@ -152,7 +153,7 @@ def build(bld):
+
+ prog.includes = '.' # make waf dependency tracking work
+ prog.target = 'a2jmidid'
+- prog.uselib = 'ALSA JACK DL'
++ prog.uselib = 'ALSA JACK DL PTHREAD'
+ if bld.env()['DBUS_ENABLED']:
+ prog.uselib += " DBUS-1"
+ prog = bld.create_obj('cc', 'program')
+--
+2.3.3.GIT
diff --git a/media-sound/a2jmidid/metadata.xml b/media-sound/a2jmidid/metadata.xml
new file mode 100644
index 000000000000..b6dce26b0a20
--- /dev/null
+++ b/media-sound/a2jmidid/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <maintainer>
+ <email>l33tmmx@gmail.com</email>
+ <name>Jouni Rinne</name>
+ </maintainer>
+</pkgmetadata>
+