summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-03 20:42:32 -0400
committerTim Harder <radhermit@gentoo.org>2016-11-03 20:42:32 -0400
commit0e354e0742b020ba31b9c4f2dad2f296c44bcf79 (patch)
treee20a4de9af8d49ea21cb8352520a59e7e28891a3 /media-sound/abcm2ps/abcm2ps-8.12.9.ebuild
parentapp-vim/session: remove old (diff)
downloadgentoo-0e354e0742b020ba31b9c4f2dad2f296c44bcf79.tar.gz
gentoo-0e354e0742b020ba31b9c4f2dad2f296c44bcf79.tar.bz2
gentoo-0e354e0742b020ba31b9c4f2dad2f296c44bcf79.zip
media-sound/abcm2ps: version bump to 8.12.9
Diffstat (limited to 'media-sound/abcm2ps/abcm2ps-8.12.9.ebuild')
-rw-r--r--media-sound/abcm2ps/abcm2ps-8.12.9.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/media-sound/abcm2ps/abcm2ps-8.12.9.ebuild b/media-sound/abcm2ps/abcm2ps-8.12.9.ebuild
new file mode 100644
index 000000000000..ab13763bc47c
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-8.12.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+RDEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}