summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-03-11 21:17:37 +0100
committerDavid Seifert <soap@gentoo.org>2017-03-11 21:46:47 +0100
commitf093b9e257fec7af4e801c589c4f1617f1a7571c (patch)
tree1b8e4add675a8d59170ba0c2080acacc4b61ddad /media-sound/alac_decoder
parentmedia-sound/SmarTagger: Modernise to EAPI 6 (diff)
downloadgentoo-f093b9e257fec7af4e801c589c4f1617f1a7571c.tar.gz
gentoo-f093b9e257fec7af4e801c589c4f1617f1a7571c.tar.bz2
gentoo-f093b9e257fec7af4e801c589c4f1617f1a7571c.zip
media-sound/alac_decoder: Modernise to EAPI 6
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'media-sound/alac_decoder')
-rw-r--r--media-sound/alac_decoder/alac_decoder-0.2.0-r1.ebuild28
-rw-r--r--media-sound/alac_decoder/files/alac_decoder-0.2.0-fix-build-system.patch24
2 files changed, 52 insertions, 0 deletions
diff --git a/media-sound/alac_decoder/alac_decoder-0.2.0-r1.ebuild b/media-sound/alac_decoder/alac_decoder-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..db49dc6deca4
--- /dev/null
+++ b/media-sound/alac_decoder/alac_decoder-0.2.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Basic decoder for Apple Lossless Audio Codec files (ALAC)"
+HOMEPAGE="http://craz.net/programs/itunes/alac.html"
+SRC_URI="http://craz.net/programs/itunes/files/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+PATCHES=( "${FILESDIR}"/${PN}-0.2.0-fix-build-system.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin alac
+ einstalldocs
+}
diff --git a/media-sound/alac_decoder/files/alac_decoder-0.2.0-fix-build-system.patch b/media-sound/alac_decoder/files/alac_decoder-0.2.0-fix-build-system.patch
new file mode 100644
index 000000000000..eac113e1d3d9
--- /dev/null
+++ b/media-sound/alac_decoder/files/alac_decoder-0.2.0-fix-build-system.patch
@@ -0,0 +1,24 @@
+Make build system respect user flags
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,4 @@
+-CC=gcc
+ RM=rm -f
+-CFLAGS=-ggdb -O3 -W -Wall
+
+ C_SOURCES=alac.c \
+ demux.c \
+@@ -11,10 +9,10 @@
+ OBJECTS=$(C_SOURCES:.c=.o)
+
+ alac: $(OBJECTS)
+- $(CC) -o alac $(OBJECTS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o alac $(OBJECTS)
+
+ %.o: %.c
+- $(CC) -c $(CFLAGS) $< -o $@
++ $(CC) $(CFLAGS) $(CPPFLAGS) -c $< -o $@
+
+ clean:
+ rm -f $(OBJECTS) *.*~ alac