summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-27 19:49:51 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-27 19:50:03 +0200
commit97782e5e71bcbba3bd8d0be9566c569613046bfc (patch)
treeadc396214c71c35eaab6370217747ab5a9caffc8 /media-sound/amarok
parentgames-fps/warsow-community-map-pack: Initial commit with ebuild and update by... (diff)
downloadgentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.tar.gz
gentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.tar.bz2
gentoo-97782e5e71bcbba3bd8d0be9566c569613046bfc.zip
media-sound/amarok: Version bump 2.8.90 (2.9 beta)
Package-Manager: portage-2.2.28
Diffstat (limited to 'media-sound/amarok')
-rw-r--r--media-sound/amarok/Manifest1
-rw-r--r--media-sound/amarok/amarok-2.8.90.ebuild128
-rw-r--r--media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch34
3 files changed, 163 insertions, 0 deletions
diff --git a/media-sound/amarok/Manifest b/media-sound/amarok/Manifest
index 5ab676dd7751..164d0d3c5cba 100644
--- a/media-sound/amarok/Manifest
+++ b/media-sound/amarok/Manifest
@@ -1 +1,2 @@
DIST amarok-2.8.0.tar.bz2 39950028 SHA256 f4b89b28f217a6d947e55fb0890de22fad8c404794c6beeb2dcaf2711b4f8ec6 SHA512 09f7f675f1223d36fb9df2f8c88923c6616524e022ad83b12bcb770dfbf60cb6b191e4035633f2ea2eee5fb7b38e6d5092cf69fe222ef9c3f3c46ba8f157a62d WHIRLPOOL 108cfd95d65e74f28f85a846f605bc349e5b2962b7f9a357415225f3e48ff87148d7f50a642665cc3c809bb2cb4c22f339ad049cdeb4659bb7c0a48e798833ad
+DIST amarok-2.8.90.tar.xz 48890580 SHA256 b057369ab70d192b669ee6c2c11e9e7d4140663f6a60d6175ef0bb56b4bef9a7 SHA512 1ff5f43100dbe027c8676946a4e82e914927b03ac0bb9e95bfc7e9e03fcc1cad81d9ea2a343bc4f644a025242e224ea9ae3cae7423d68b0b3c68f346922537fc WHIRLPOOL 22da35ea61dcda04d882f4c0da7327cab10edf50140b3ae891738d10e1b9e5062eb541e35e817fd04a7f0284eb085b5ccf3edfa20438b764a9ce3615de35ca8c
diff --git a/media-sound/amarok/amarok-2.8.90.ebuild b/media-sound/amarok/amarok-2.8.90.ebuild
new file mode 100644
index 000000000000..4db4e9724a99
--- /dev/null
+++ b/media-sound/amarok/amarok-2.8.90.ebuild
@@ -0,0 +1,128 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_LINGUAS="bs ca ca@valencia cs da de el en_GB es et eu fi fr ga gl hu it ja
+lt lv nb nl pa pl pt pt_BR ro ru sl sr sr@ijekavian sr@ijekavianlatin sr@latin
+sv tr uk zh_CN zh_TW"
+KDE_REQUIRED="never"
+KDE_HANDBOOK="optional"
+VIRTUALX_REQUIRED="test"
+VIRTUALDBUS_TEST="true"
+inherit flag-o-matic kde4-base pax-utils
+
+DESCRIPTION="Advanced audio player based on KDE framework"
+HOMEPAGE="http://amarok.kde.org/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="cdda debug +embedded ipod lastfm mp3tunes mtp ofa opengl test +utils"
+
+if [[ ${KDE_BUILD_TYPE} == live ]]; then
+ RESTRICT="test"
+fi
+
+# ipod requires gdk enabled and also gtk compiled in libgpod
+COMMONDEPEND="
+ app-crypt/qca:2[qt4(+)]
+ $(add_kdebase_dep kdelibs 'opengl?' 4.8.4)
+ $(add_kdeapps_dep kdebase-kioslaves)
+ >=media-libs/taglib-1.7[asf,mp4]
+ >=media-libs/taglib-extras-1.0.1
+ sys-libs/zlib
+ >=virtual/mysql-5.1[embedded?]
+ >=dev-qt/qtcore-4.8:4
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtscript-4.8:4
+ >=x11-libs/qtscriptgenerator-0.1.0
+ cdda? (
+ $(add_kdeapps_dep libkcddb)
+ $(add_kdeapps_dep libkcompactdisc)
+ $(add_kdeapps_dep audiocd-kio)
+ )
+ ipod? ( >=media-libs/libgpod-0.7.0[gtk] )
+ lastfm? ( >=media-libs/liblastfm-1.0.3[qt4(+)] )
+ mp3tunes? (
+ dev-libs/glib:2
+ dev-libs/libxml2
+ dev-libs/openssl:0
+ net-libs/loudmouth
+ net-misc/curl
+ >=dev-qt/qtcore-4.8.4:4[glib]
+ )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ ofa? ( >=media-libs/libofa-0.9.0 )
+ opengl? ( virtual/opengl )
+"
+DEPEND="${COMMONDEPEND}
+ dev-util/automoc
+ virtual/pkgconfig
+ test? ( dev-cpp/gmock )
+"
+RDEPEND="${COMMONDEPEND}
+ !media-sound/amarok-utils
+ $(add_kdeapps_dep phonon-kde)
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.8.0-taglib110.patch"
+ "${FILESDIR}/${P}-mysql-embedded.patch"
+)
+
+src_configure() {
+ # Append minimal-toc cflag for ppc64, see bug 280552 and 292707
+ use ppc64 && append-flags -mminimal-toc
+
+ local mycmakeargs=(
+ -DWITH_PLAYER=ON
+ -DWITH_Libgcrypt=OFF
+ -DWITH_SPECTRUM_ANALYZER=OFF
+ -DWITH_NepomukCore=OFF
+ -DWITH_Soprano=OFF
+ -DWITH_MYSQL_EMBEDDED=$(usex embedded)
+ -DWITH_IPOD=$(usex ipod)
+ -DWITH_GDKPixBuf=$(usex ipod)
+ -DWITH_LibLastFm=$(usex lastfm)
+ -DWITH_MP3Tunes=$(usex mp3tunes)
+ -DWITH_Mtp=$(usex mtp)
+ -DWITH_LibOFA=$(usex ofa)
+ -DWITH_UTILITIES=$(usex utils)
+ )
+
+ kde4-base_src_configure
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 481592
+ pax-mark m "${ED}"/usr/bin/amarok
+}
+
+pkg_postinst() {
+ kde4-base_pkg_postinst
+
+ if ! use embedded; then
+ echo
+ elog "You've disabled the amarok support for embedded mysql DBs."
+ elog "You'll have to configure amarok to use an external db server."
+ echo
+ elog "Please read http://amarok.kde.org/wiki/MySQL_Server for details on how"
+ elog "to configure the external db and migrate your data from the embedded database."
+ echo
+
+ if has_version "virtual/mysql[minimal]"; then
+ elog "You built mysql with the minimal use flag, so it doesn't include the server."
+ elog "You won't be able to use the local mysql installation to store your amarok collection."
+ echo
+ fi
+ fi
+}
diff --git a/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
new file mode 100644
index 000000000000..b03aa1897cc4
--- /dev/null
+++ b/media-sound/amarok/files/amarok-2.8.90-mysql-embedded.patch
@@ -0,0 +1,34 @@
+From 048ca3d57228759f05af7b9553200fd362aeaa8b Mon Sep 17 00:00:00 2001
+From: Matt Whitlock <kde@mattwhitlock.name>
+Date: Tue, 29 Mar 2016 12:22:41 -0400
+Subject: [PATCH] Only link with MYSQL_EMBEDDED_LIBRARIES if
+ WITH_MYSQL_EMBEDDED
+
+REVIEW: 127523
+---
+ src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+index 244cde1..4c618fc 100644
+--- a/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
++++ b/src/core-impl/collections/db/sql/mysqlcollection/CMakeLists.txt
+@@ -21,11 +21,14 @@ target_link_libraries(amarok_collection-mysqlcollection
+ ${KDE4_KDECORE_LIBS}
+ ${QT_QTCORE_LIBRARY}
+ ${QT_QTGUI_LIBRARY}
+- ${MYSQL_EMBEDDED_LIBRARIES}
+ ${CMAKE_DL_LIBS}
+ ${ZLIB_LIBRARIES}
+ )
+
++if(WITH_MYSQL_EMBEDDED)
++ target_link_libraries( amarok_collection-mysqlcollection ${MYSQL_EMBEDDED_LIBRARIES} )
++endif(WITH_MYSQL_EMBEDDED)
++
+ if(NOT WIN32 AND NOT APPLE)
+ target_link_libraries( amarok_collection-mysqlcollection crypt pthread )
+ endif(NOT WIN32 AND NOT APPLE)
+--
+2.8.1
+