summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ams
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ams')
-rw-r--r--media-sound/ams/Manifest2
-rw-r--r--media-sound/ams/ams-2.0.1.ebuild37
-rw-r--r--media-sound/ams/ams-2.1.1.ebuild37
-rw-r--r--media-sound/ams/files/ams-2.0.1-dl.patch21
-rw-r--r--media-sound/ams/files/ams-2.1.1-dl.patch13
-rw-r--r--media-sound/ams/metadata.xml8
6 files changed, 118 insertions, 0 deletions
diff --git a/media-sound/ams/Manifest b/media-sound/ams/Manifest
new file mode 100644
index 000000000000..bae24ec607c5
--- /dev/null
+++ b/media-sound/ams/Manifest
@@ -0,0 +1,2 @@
+DIST ams-2.0.1.tar.bz2 286609 SHA256 1fb95261a302ff464b20a6b7363faed82dcbc0fa50b6580964e384ef0832ed64
+DIST ams-2.1.1.tar.bz2 342456 SHA256 a2fdd93f5f1eb96d0903d1d3f4709fcec28842e44b9e7420ea42618affc767d9 SHA512 04627c15c3e3d0b889c4d17a8393c2417f5004a2bb0035bf9b0d86265d55c214923b9b875cbf3dd2cdb3f0037a0d6f717a9c6b749b68cd786b591d79e06b7580 WHIRLPOOL 1152139cf676707369a3189795833c3a7fdbe2a90e1a557169514a12536fd5279a863058971e36592a4d322d742bed1af704776382c454029d5f718b7ef88a98
diff --git a/media-sound/ams/ams-2.0.1.ebuild b/media-sound/ams/ams-2.0.1.ebuild
new file mode 100644
index 000000000000..12b1a7a52c2b
--- /dev/null
+++ b/media-sound/ams/ams-2.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="Alsa Modular Software Synthesizer"
+HOMEPAGE="http://alsamodular.sourceforge.net"
+SRC_URI="mirror://sourceforge/alsamodular/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/ladspa-sdk
+ media-libs/libclalsadrv
+ !dev-ruby/amrita"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dl.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/qt4
+ econf
+}
diff --git a/media-sound/ams/ams-2.1.1.ebuild b/media-sound/ams/ams-2.1.1.ebuild
new file mode 100644
index 000000000000..9063752a12ee
--- /dev/null
+++ b/media-sound/ams/ams-2.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools eutils flag-o-matic multilib
+
+DESCRIPTION="Alsa Modular Software Synthesizer"
+HOMEPAGE="http://alsamodular.sourceforge.net"
+SRC_URI="mirror://sourceforge/alsamodular/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/alsa-lib
+ media-sound/jack-audio-connection-kit
+ dev-qt/qtgui:4
+ dev-qt/qtopengl:4
+ media-libs/ladspa-sdk
+ media-libs/libclalsadrv
+ !dev-ruby/amrita"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-dl.patch
+ eautoreconf
+}
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/qt4
+ econf
+}
diff --git a/media-sound/ams/files/ams-2.0.1-dl.patch b/media-sound/ams/files/ams-2.0.1-dl.patch
new file mode 100644
index 000000000000..ce2327d210f4
--- /dev/null
+++ b/media-sound/ams/files/ams-2.0.1-dl.patch
@@ -0,0 +1,21 @@
+Missing -ldl for dlsym, dlerror, and dlopen, see http://bugs.gentoo.org/379251
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -232,6 +232,8 @@
+ textedit.h \
+ notelist.h
+
++ams_LDADD = -ldl @QT_LIBS@
++
+ translationsdir = $(pkgdatadir)/translations
+ translations = \
+ translations/ams_de.ts \
+@@ -247,7 +249,6 @@
+ # all generated files to be removed by "make clean"
+ CLEANFILES = $(nodist_ams_SOURCES) $(translations_DATA)
+
+-AM_LDFLAGS = @QT_LIBS@
+ AM_CXXFLAGS = @QT_CXXFLAGS@ @AMS_CXXFLAGS@
+ DEFS = -D_REENTRANT -DLADSPA_PATH=\"$(LADSPA_PATH)\" -DTRANSLATIONSDIR=\"$(translationsdir)\" @DEFS@
+
diff --git a/media-sound/ams/files/ams-2.1.1-dl.patch b/media-sound/ams/files/ams-2.1.1-dl.patch
new file mode 100644
index 000000000000..00bec616c227
--- /dev/null
+++ b/media-sound/ams/files/ams-2.1.1-dl.patch
@@ -0,0 +1,13 @@
+Missing -ldl for dlsym, dlerror, and dlopen, see http://bugs.gentoo.org/379251
+
+--- ams-2.1.1/src/Makefile.am
++++ ams-2.1.1/src/Makefile.am
+@@ -252,6 +252,8 @@
+ textedit.h \
+ notelist.h
+
++ams_LDADD = -ldl
++
+ translationsdir = $(pkgdatadir)/translations
+ translations = \
+ translations/ams_de.ts \
diff --git a/media-sound/ams/metadata.xml b/media-sound/ams/metadata.xml
new file mode 100644
index 000000000000..939a2c64eb67
--- /dev/null
+++ b/media-sound/ams/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <upstream>
+ <remote-id type="sourceforge">alsamodular</remote-id>
+ </upstream>
+</pkgmetadata>