summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/amsynth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest2
-rw-r--r--media-sound/amsynth/amsynth-1.3.2.ebuild55
-rw-r--r--media-sound/amsynth/amsynth-1.5.1.ebuild53
-rw-r--r--media-sound/amsynth/files/amsynth-1.2.3-respect-cflags.patch20
-rw-r--r--media-sound/amsynth/metadata.xml11
5 files changed, 141 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
new file mode 100644
index 000000000000..79ba3f2d3717
--- /dev/null
+++ b/media-sound/amsynth/Manifest
@@ -0,0 +1,2 @@
+DIST amSynth-1.3.2.tar.gz 635901 SHA256 3ad50c20d690865ea0fdef6745cd04a9f758e9ae654ad874902d3da896e0fa75 SHA512 c5f312fd1fa5335ccd2c1e7a81a7c0f9094faabec633fe654f04650e5604bb6d05f1348f6ce3c305e840692e2012ac9501ca83f5e5018a0218d9c35a99678e80 WHIRLPOOL 3b93486378a140ce7feb0789cc46a74375920ae717d38910e0b75011e4f1c827749f795ce38b7408d72adb4abfab090a104fc23f001977c68576bde05e1fa260
+DIST amsynth-1.5.1.tar.gz 1297131 SHA256 38e0764ae02ec38e689204581810adabedd9b4e0d306414c455f51c1dbf0bea4 SHA512 5f1551f9d1398a97738ac6f764f169d8cdd55e94464438adb226d1284fe8845e190fe5dd7a740b33972c1bbe76aa2d60467b7a663ec6717bb9fac75e5aac62d1 WHIRLPOOL 615ae1a55db42a0d6cb628ab84d9167894cb974594c45bf74aae6ad1e74b09f0303844fe54457b805ce4fd50af8ae99d9064531162106ef83c5c8103c24c8a73
diff --git a/media-sound/amsynth/amsynth-1.3.2.ebuild b/media-sound/amsynth/amsynth-1.3.2.ebuild
new file mode 100644
index 000000000000..5ec2071bea4c
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.3.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_P=${P/ams/amS}
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="http://code.google.com/p/amsynth/"
+SRC_URI="http://amsynth.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+DOCS="AUTHORS README"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ CFLAGS="" \
+ CXXFLAGS="${CXXFLAGS}" \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}
diff --git a/media-sound/amsynth/amsynth-1.5.1.ebuild b/media-sound/amsynth/amsynth-1.5.1.ebuild
new file mode 100644
index 000000000000..4bb0d758d2ea
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.5.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/nixxcode/amsynth/"
+SRC_URI="https://github.com/nixxcode/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+DOCS="AUTHORS README"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ CFLAGS="" \
+ CXXFLAGS="${CXXFLAGS}" \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}
diff --git a/media-sound/amsynth/files/amsynth-1.2.3-respect-cflags.patch b/media-sound/amsynth/files/amsynth-1.2.3-respect-cflags.patch
new file mode 100644
index 000000000000..2a640ce17108
--- /dev/null
+++ b/media-sound/amsynth/files/amsynth-1.2.3-respect-cflags.patch
@@ -0,0 +1,20 @@
+--- amSynth-1.2.3/configure.in
++++ amSynth-1.2.3/configure.in
+@@ -90,7 +90,7 @@ AC_ARG_ENABLE(debug,
+ if test "${enable_debug}" = "yes" ; then
+ AC_MSG_RESULT([yes])
+ debugging=yes
+- CXXFLAGS="$CXXFLAGS -g -Wall -D_DEBUG"
++ CXXFLAGS="$CXXFLAGS -Wall -D_DEBUG"
+ COMPOPSTR="debugging $COMPOPSTR"
+ OPTION_DEBUG="yes"
+ else
+@@ -114,7 +114,7 @@ if test "$enable_profile" = "yes" ; then
+ fi
+ else
+ if test "$GCC" = "yes" ; then
+- CXXFLAGS="$CXXFLAGS -O3 -ffast-math -fno-exceptions -fomit-frame-pointer"
++ CXXFLAGS="$CXXFLAGS -ffast-math -fno-exceptions -fomit-frame-pointer"
+ fi
+ AC_MSG_RESULT([no])
+ profiling=no
diff --git a/media-sound/amsynth/metadata.xml b/media-sound/amsynth/metadata.xml
new file mode 100644
index 000000000000..934627feac58
--- /dev/null
+++ b/media-sound/amsynth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="dssi">Enable support for DSSI Soft Synth Interface</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">nixxcode/amsynth</remote-id>
+ </upstream>
+</pkgmetadata>