summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2018-09-25 17:24:00 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2018-09-25 17:25:51 +0300
commit78bff4dfac8ced74932a4311400b359d307b306d (patch)
treefa80cbb20572d90571143ecde49e12af2657540f /media-sound/apulse
parentnet-dns/bind-tools: Bump to versions 9.11.4_p2 and 9.12.2_p2 (diff)
downloadgentoo-78bff4dfac8ced74932a4311400b359d307b306d.tar.gz
gentoo-78bff4dfac8ced74932a4311400b359d307b306d.tar.bz2
gentoo-78bff4dfac8ced74932a4311400b359d307b306d.zip
media-sound/apulse: fix wrapper installation on multilib setups
Wrapper installation was broken on multilib setups with newest bash versions. In order to avoid environment driven eclass problems manual installation of required wrappers is added. Thanks Karl-Johan Karlsson (creideiki+gentoo-bugzilla_lysator.liu.se) for detailed reporting and testing. Closes: https://bugs.gentoo.org/666884 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-sound/apulse')
-rw-r--r--media-sound/apulse/apulse-0.1.12-r4.ebuild (renamed from media-sound/apulse/apulse-0.1.12-r3.ebuild)15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-sound/apulse/apulse-0.1.12-r3.ebuild b/media-sound/apulse/apulse-0.1.12-r4.ebuild
index f934c4816be8..46b1d98a51ad 100644
--- a/media-sound/apulse/apulse-0.1.12-r3.ebuild
+++ b/media-sound/apulse/apulse-0.1.12-r4.ebuild
@@ -48,15 +48,16 @@ multilib_src_test() {
emake check
}
-multilib_src_install() {
+multilib_src_install_all() {
cmake-utils_src_install
+ # The easiest way would be setting MULTILIB_CHOST_TOOLS at global scope, depending
+ # on USE=sdk, but this is no longer permitted, so workaround is required.
+ # See bug 666884 for details.
if ! use sdk; then
- export MULTILIB_CHOST_TOOLS=( /usr/bin/apulse )
- multilib_prepare_wrappers
+ unset BUILD_DIR
+ _install_wrapper() { newbin "${BUILD_DIR}/apulse" "${CHOST}-apulse"; }
+ multilib_foreach_abi _install_wrapper
+ dobin "${T}/apulse"
fi
-}
-
-multilib_src_install_all() {
- use sdk || dobin "${T}/apulse"
einstalldocs
}