summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/ardour/ardour-2.8.14-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/ardour/ardour-2.8.14-r1.ebuild')
-rw-r--r--media-sound/ardour/ardour-2.8.14-r1.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/media-sound/ardour/ardour-2.8.14-r1.ebuild b/media-sound/ardour/ardour-2.8.14-r1.ebuild
new file mode 100644
index 000000000000..5d99b70f2a99
--- /dev/null
+++ b/media-sound/ardour/ardour-2.8.14-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils flag-o-matic toolchain-funcs scons-utils
+
+DESCRIPTION="Digital Audio Workstation"
+HOMEPAGE="http://ardour.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="altivec curl debug nls lv2 cpu_flags_x86_sse"
+
+RDEPEND="media-libs/aubio
+ media-libs/liblo
+ sci-libs/fftw:3.0
+ media-libs/freetype:2
+ >=dev-libs/glib-2.10.1:2
+ dev-cpp/glibmm:2
+ >=x11-libs/gtk+-2.8.1:2
+ >=dev-libs/libxml2-2.6:2
+ >=media-libs/libsndfile-1.0.18
+ >=media-libs/libsamplerate-0.1
+ >=media-libs/rubberband-1.6.0
+ >=media-libs/libsoundtouch-1.6.0
+ media-libs/flac
+ media-libs/raptor:2
+ >=media-libs/liblrdf-0.4.0-r20
+ >=media-sound/jack-audio-connection-kit-0.120
+ >=gnome-base/libgnomecanvas-2
+ media-libs/vamp-plugin-sdk
+ dev-libs/libxslt
+ dev-libs/libsigc++:2
+ >=dev-cpp/gtkmm-2.16:2.4
+ >=dev-cpp/libgnomecanvasmm-2.26:2.6
+ media-libs/alsa-lib
+ x11-libs/pango
+ x11-libs/cairo
+ media-libs/libart_lgpl
+ virtual/libusb:0
+ dev-libs/boost
+ curl? ( net-misc/curl )
+ lv2? (
+ >=media-libs/slv2-0.6.1
+ media-libs/lilv
+ media-libs/suil
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-2.8.11-flags.patch \
+ "${FILESDIR}"/${P}-syslibs.patch \
+ "${FILESDIR}"/${P}-boost-150.patch
+
+}
+
+src_compile() {
+ local FPU_OPTIMIZATION=$($(use altivec || use cpu_flags_x86_sse) && echo 1 || echo 0)
+ tc-export CC CXX
+ mkdir -p "${D}"
+
+ escons \
+ DESTDIR="${D}" \
+ FPU_OPTIMIZATION="${FPU_OPTIMIZATION}" \
+ PREFIX=/usr \
+ SYSLIBS=1 \
+ $(use_scons curl FREESOUND) \
+ $(use_scons debug DEBUG) \
+ $(use_scons nls NLS) \
+ $(use_scons lv2 LV2)
+}
+
+src_install() {
+ escons install
+ doman ${PN}.1
+ newicon icons/icon/ardour_icon_mac.png ${PN}.png
+ make_desktop_entry ardour2 ardour2 ardour AudioVideo
+}