summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-20 10:32:06 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-20 10:48:56 +0200
commit212ba90044f3be8b80ca904ffb6f0e75e1edaef5 (patch)
treef3bb80d8adcd58dcee1406810e8fb14348805230 /media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild
parentdev-perl/Mail-DKIM: stable 0.440.0 for ia64, bug #661196 (diff)
downloadgentoo-212ba90044f3be8b80ca904ffb6f0e75e1edaef5.tar.gz
gentoo-212ba90044f3be8b80ca904ffb6f0e75e1edaef5.tar.bz2
gentoo-212ba90044f3be8b80ca904ffb6f0e75e1edaef5.zip
media-sound/bluez-alsa: Bump to version 1.3.0
Closes: https://bugs.gentoo.org/661534 Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild')
-rw-r--r--media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild b/media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild
new file mode 100644
index 000000000000..6c59d2ee4e2f
--- /dev/null
+++ b/media-sound/bluez-alsa/bluez-alsa-1.3.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools multilib-minimal
+
+DESCRIPTION="Bluetooth Audio ALSA Backend"
+HOMEPAGE="https://github.com/Arkq/bluez-alsa"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Arkq/${PN}"
+else
+ SRC_URI="https://github.com/Arkq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="aac debug hcitop static-libs"
+
+RDEPEND=">=dev-libs/glib-2.26[dbus,${MULTILIB_USEDEP}]
+ >=media-libs/alsa-lib-1.0[${MULTILIB_USEDEP}]
+ >=media-libs/sbc-1.2[${MULTILIB_USEDEP}]
+ >=net-wireless/bluez-5.0[${MULTILIB_USEDEP}]
+ aac? ( >=media-libs/fdk-aac-0.1.1[${MULTILIB_USEDEP}] )
+ hcitop? (
+ dev-libs/libbsd
+ sys-libs/ncurses:0=
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-rfcomm
+ $(use_enable aac)
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(multilib_native_use_enable hcitop)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+
+ newinitd "${FILESDIR}"/bluealsa-init.d bluealsa
+ newconfd "${FILESDIR}"/bluealsa-conf.d-2 bluealsa
+}
+
+pkg_postinst() {
+ elog "Users can use this service when they are members of the \"audio\" group."
+}