summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-10 01:41:31 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-10 01:41:31 +0100
commit69ae4b3b9a2538c9c4507e2a329663ef0303c3b3 (patch)
tree6a1b1086582b439f1215e410c59b1b1bae66ad32 /media-sound/cdtool
parentmedia-sound/ptabtools: Port to EAPI 7 (diff)
downloadgentoo-69ae4b3b9a2538c9c4507e2a329663ef0303c3b3.tar.gz
gentoo-69ae4b3b9a2538c9c4507e2a329663ef0303c3b3.tar.bz2
gentoo-69ae4b3b9a2538c9c4507e2a329663ef0303c3b3.zip
media-sound/cdtool: Port to EAPI 7
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'media-sound/cdtool')
-rw-r--r--media-sound/cdtool/cdtool-2.1.8-r1.ebuild17
-rw-r--r--media-sound/cdtool/files/cdtool-2.1.8-fix-build-system.patch40
2 files changed, 46 insertions, 11 deletions
diff --git a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
index 6706ada72f63..0d81cefca180 100644
--- a/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
+++ b/media-sound/cdtool/cdtool-2.1.8-r1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-inherit eutils
+EAPI=7
DESCRIPTION="collection of command-line utilities to control cdrom devices"
HOMEPAGE="http://hinterhof.net/cdtool/"
@@ -15,11 +14,7 @@ IUSE=""
RDEPEND="!media-sound/cdplay"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-glibc-2.10.patch
- sed -i \
- -e '/INSTALL/s:-o root::' \
- -e '/LINKTARGET/s:/lib/:/$(notdir $(libdir))/:' \
- -e '/^install-links:/s:$: install-files:' \
- Makefile.in || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-glibc-2.10.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
diff --git a/media-sound/cdtool/files/cdtool-2.1.8-fix-build-system.patch b/media-sound/cdtool/files/cdtool-2.1.8-fix-build-system.patch
new file mode 100644
index 000000000000..c059a645112f
--- /dev/null
+++ b/media-sound/cdtool/files/cdtool-2.1.8-fix-build-system.patch
@@ -0,0 +1,40 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -44,11 +44,11 @@
+ install: install-files install-links
+ install-files:
+ mkdir -p $(DESTDIR)$(bindir)
+- $(INSTALL) cdctrl $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdloop $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdadd $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdown $(DESTDIR)$(bindir) -o root
+- $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir) -o root
++ $(INSTALL) cdctrl $(DESTDIR)$(bindir)
++ $(INSTALL) cdloop $(DESTDIR)$(bindir)
++ $(INSTALL) cdadd $(DESTDIR)$(bindir)
++ $(INSTALL) cdown $(DESTDIR)$(bindir)
++ $(INSTALL) cdtool2cddb $(DESTDIR)$(bindir)
+
+ mkdir -p $(DESTDIR)$(mandir)/man1
+ $(INSTALL) cdctrl.1 $(DESTDIR)$(mandir)/man1
+@@ -59,9 +59,9 @@
+ $(INSTALL) cdtool2cddb.1 $(DESTDIR)$(mandir)/man1
+
+ mkdir -p $(DESTDIR)$(libdir)/cdtool
+- $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool -o root
++ $(INSTALL) cdtool $(DESTDIR)$(libdir)/cdtool
+
+-LINKTARGET = ../lib/cdtool/cdtool
++LINKTARGET = ../$(notdir $(libdir))/cdtool/cdtool
+ LINKS = cdplay cdpause cdstop cdclose cdeject cdir cdinfo cdreset \
+ cdvolume cdshuffle
+
+@@ -69,7 +69,7 @@
+ install-links-local: bindir = .
+ install-links-local: install-links
+
+-install-links:
++install-links: install-files
+ for command in $(LINKS); do \
+ if ! test -h $(DESTDIR)$(bindir)/$$command; then \
+ echo installing $$command; \