summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/clementine/clementine-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/clementine/clementine-9999.ebuild')
-rw-r--r--media-sound/clementine/clementine-9999.ebuild164
1 files changed, 164 insertions, 0 deletions
diff --git a/media-sound/clementine/clementine-9999.ebuild b/media-sound/clementine/clementine-9999.ebuild
new file mode 100644
index 000000000000..e8970fff8f50
--- /dev/null
+++ b/media-sound/clementine/clementine-9999.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="https://github.com/clementine-player/Clementine.git"
+
+LANGS=" af ar be bg bn br bs ca cs cy da de el en_CA en_GB eo es es_AR et eu fa fi fr ga gl he hi hr hu hy ia id is it ja ka kk ko lt lv mr ms nb nl oc pa pl pt pt_BR ro ru sk sl sr sr@latin sv te tr uk uz vi zh_CN zh_TW"
+
+inherit cmake-utils flag-o-matic fdo-mime gnome2-utils virtualx
+[[ ${PV} == *9999* ]] && inherit git-2
+
+DESCRIPTION="A modern music player and library organizer based on Amarok 1.4 and Qt4"
+HOMEPAGE="http://www.clementine-player.org https://github.com/clementine-player/Clementine"
+[[ ${PV} == *9999* ]] || \
+SRC_URI="https://github.com/clementine-player/Clementine/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ ${PV} == *9999* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="ayatana box cdda +dbus debug dropbox googledrive ipod lastfm mms moodbar mtp projectm skydrive system-sqlite test ubuntu-one +udisks wiimote"
+IUSE+="${LANGS// / linguas_}"
+
+REQUIRED_USE="
+ udisks? ( dbus )
+ wiimote? ( dbus )
+"
+
+# qca dep is temporary for bug #489850
+COMMON_DEPEND="
+ app-crypt/qca:2[qt4(+)]
+ >=dev-qt/qtgui-4.5:4
+ dbus? ( >=dev-qt/qtdbus-4.5:4 )
+ >=dev-qt/qtopengl-4.5:4
+ >=dev-qt/qtsql-4.5:4[sqlite]
+ system-sqlite? ( dev-db/sqlite[fts3(+)] )
+ >=media-libs/taglib-1.8[mp4]
+ >=dev-libs/glib-2.24.1-r1
+ dev-libs/libxml2
+ dev-libs/protobuf:=
+ dev-libs/qjson
+ media-libs/libechonest:=
+ >=media-libs/libmygpo-qt-1.0.7
+ >=media-libs/chromaprint-0.6
+ media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10
+ dev-libs/crypto++
+ virtual/glu
+ virtual/opengl
+ ayatana? ( dev-libs/libindicate-qt )
+ cdda? ( dev-libs/libcdio )
+ ipod? ( >=media-libs/libgpod-0.8.0 )
+ lastfm? ( >=media-libs/liblastfm-1 )
+ mtp? ( >=media-libs/libmtp-1.0.0 )
+ moodbar? ( sci-libs/fftw:3.0 )
+ projectm? ( media-libs/glew )
+"
+# now only presets are used, libprojectm is internal
+# https://github.com/clementine-player/Clementine/tree/master/3rdparty/libprojectm/patches
+# r1966 "Compile with a static sqlite by default, since Qt 4.7 doesn't seem to expose the symbols we need to use FTS"
+RDEPEND="${COMMON_DEPEND}
+ dbus? ( udisks? ( sys-fs/udisks:0 ) )
+ mms? ( media-plugins/gst-plugins-libmms:0.10 )
+ mtp? ( gnome-base/gvfs )
+ projectm? ( >=media-libs/libprojectm-1.2.0 )
+ media-plugins/gst-plugins-meta:0.10
+ media-plugins/gst-plugins-gio:0.10
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-taglib:0.10
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.39
+ virtual/pkgconfig
+ sys-devel/gettext
+ dev-qt/qttest:4
+ dev-cpp/gmock
+ box? ( dev-cpp/sparsehash )
+ dropbox? ( dev-cpp/sparsehash )
+ googledrive? ( dev-cpp/sparsehash )
+ skydrive? ( dev-cpp/sparsehash )
+ ubuntu-one? ( dev-cpp/sparsehash )
+ test? ( gnome-base/gsettings-desktop-schemas )
+"
+DOCS="Changelog"
+
+# https://github.com/clementine-player/Clementine/issues/3935
+RESTRICT="test"
+
+[[ ${PV} == *9999* ]] || \
+S="${WORKDIR}/${P^}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # some tests fail or hang
+ sed -i \
+ -e '/add_test_file(translations_test.cpp/d' \
+ tests/CMakeLists.txt || die
+}
+
+src_configure() {
+ local langs x
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+=" ${x}"
+ done
+
+ # spotify is not in portage
+ local mycmakeargs=(
+ -DBUILD_WERROR=OFF
+ -DLINGUAS="${langs}"
+ -DBUNDLE_PROJECTM_PRESETS=OFF
+ $(cmake-utils_use cdda ENABLE_AUDIOCD)
+ $(cmake-utils_use dbus ENABLE_DBUS)
+ $(cmake-utils_use udisks ENABLE_DEVICEKIT)
+ $(cmake-utils_use ipod ENABLE_LIBGPOD)
+ $(cmake-utils_use lastfm ENABLE_LIBLASTFM)
+ $(cmake-utils_use mtp ENABLE_LIBMTP)
+ $(cmake-utils_use moodbar ENABLE_MOODBAR)
+ -DENABLE_GIO=ON
+ $(cmake-utils_use wiimote ENABLE_WIIMOTEDEV)
+ $(cmake-utils_use projectm ENABLE_VISUALISATIONS)
+ $(cmake-utils_use ayatana ENABLE_SOUNDMENU)
+ $(cmake-utils_use box ENABLE_BOX)
+ $(cmake-utils_use dropbox ENABLE_DROPBOX)
+ $(cmake-utils_use googledrive ENABLE_GOOGLE_DRIVE)
+ $(cmake-utils_use skydrive ENABLE_SKYDRIVE)
+ $(cmake-utils_use ubuntu-one ENABLE_UBUNTU_ONE)
+ -DENABLE_SPOTIFY_BLOB=OFF
+ -DENABLE_BREAKPAD=OFF
+ $(cmake-utils_use !system-sqlite STATIC_SQLITE)
+ $(cmake-utils_use system-sqlite I_HATE_MY_USERS)
+ $(cmake-utils_use system-sqlite MY_USERS_WILL_SUFFER_BECAUSE_OF_ME)
+ -DUSE_BUILTIN_TAGLIB=OFF
+ -DUSE_SYSTEM_GMOCK=ON
+ # force to find crypto++ see bug #548544
+ -DCRYPTOPP_LIBRARIES="crypto++"
+ -DCRYPTOPP_FOUND=ON
+ )
+
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}" || die
+ Xemake test
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}