summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-09 21:08:05 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-09 21:11:27 +0100
commit7677b6cfdbdc981a7e2f0c90df1392b4125fdbd8 (patch)
treedd19124244877d142aaee983ffc224174d4034b9 /media-sound/cmus
parentdev-libs/hyphen: Drop 2.8.8 (r0) (diff)
downloadgentoo-7677b6cfdbdc981a7e2f0c90df1392b4125fdbd8.tar.gz
gentoo-7677b6cfdbdc981a7e2f0c90df1392b4125fdbd8.tar.bz2
gentoo-7677b6cfdbdc981a7e2f0c90df1392b4125fdbd8.zip
media-sound/cmus: Drop USE cue
Closes: https://bugs.gentoo.org/700122 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/cmus')
-rw-r--r--media-sound/cmus/cmus-2.8.0.ebuild34
-rw-r--r--media-sound/cmus/cmus-9999.ebuild34
-rw-r--r--media-sound/cmus/metadata.xml1
3 files changed, 40 insertions, 29 deletions
diff --git a/media-sound/cmus/cmus-2.8.0.ebuild b/media-sound/cmus/cmus-2.8.0.ebuild
index 83c05f7dc5eb..e4cfd45303e4 100644
--- a/media-sound/cmus/cmus-2.8.0.ebuild
+++ b/media-sound/cmus/cmus-2.8.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ HOMEPAGE="https://cmus.github.io/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="aac alsa ao cddb cdio cue debug discid elogind examples ffmpeg +flac jack libsamplerate
+IUSE="aac alsa ao cddb cdio debug discid elogind examples ffmpeg +flac jack libsamplerate
+mad mikmod modplug mp4 musepack opus oss pidgin pulseaudio systemd tremor +unicode
+vorbis wavpack"
@@ -34,7 +34,6 @@ DEPEND="
ao? ( media-libs/libao )
cddb? ( media-libs/libcddb )
cdio? ( dev-libs/libcdio-paranoia )
- cue? ( media-libs/libcue )
discid? ( media-libs/libdiscid )
elogind? ( sys-auth/elogind )
ffmpeg? ( media-video/ffmpeg:= )
@@ -74,16 +73,24 @@ PATCHES=(
S="${WORKDIR}/${P/_/-}"
-my_config() {
- local value
- use ${1} && value=a || value=n
- myconf="${myconf} ${2}=${value}"
-}
-
src_configure() {
- local debuglevel=1 myconf="CONFIG_ARTS=n CONFIG_SUN=n CONFIG_SNDIO=n CONFIG_WAVEOUT=n CONFIG_VTX=n CONFIG_ROAR=n"
+ my_config() {
+ local value
+ use ${1} && value=a || value=n
+ myconf+=( ${2}=${value} )
+ }
+ local debuglevel=1
use debug && debuglevel=2
+ local myconf=(
+ CONFIG_CUE=y
+ CONFIG_ARTS=n
+ CONFIG_SUN=n
+ CONFIG_SNDIO=n
+ CONFIG_WAVEOUT=n
+ CONFIG_VTX=n
+ CONFIG_ROAR=n
+ )
my_config cddb CONFIG_CDDB
my_config cdio CONFIG_CDIO
@@ -100,7 +107,6 @@ src_configure() {
my_config mp4 CONFIG_MP4
my_config aac CONFIG_AAC
my_config ffmpeg CONFIG_FFMPEG
- my_config cue CONFIG_CUE
my_config pulseaudio CONFIG_PULSE
my_config alsa CONFIG_ALSA
my_config jack CONFIG_JACK
@@ -109,12 +115,12 @@ src_configure() {
my_config oss CONFIG_OSS
if use elogind || use systemd; then
- myconf="${myconf} CONFIG_MPRIS=a"
+ myconf+=( CONFIG_MPRIS=a )
else
- myconf="${myconf} CONFIG_MPRIS=n"
+ myconf+=( CONFIG_MPRIS=n )
fi
- ./configure prefix="${EPREFIX}"/usr ${myconf} \
+ ./configure prefix="${EPREFIX}"/usr "${myconf[@]}" \
exampledir="${EPREFIX}"/usr/share/doc/${PF}/examples \
libdir="${EPREFIX}"/usr/$(get_libdir) DEBUG=${debuglevel} || die
}
diff --git a/media-sound/cmus/cmus-9999.ebuild b/media-sound/cmus/cmus-9999.ebuild
index 6ae109af57a9..283dda195198 100644
--- a/media-sound/cmus/cmus-9999.ebuild
+++ b/media-sound/cmus/cmus-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,7 @@ HOMEPAGE="https://cmus.github.io/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="aac alsa ao cddb cdio cue debug discid elogind examples ffmpeg +flac jack libsamplerate
+IUSE="aac alsa ao cddb cdio debug discid elogind examples ffmpeg +flac jack libsamplerate
+mad mikmod modplug mp4 musepack opus oss pidgin pulseaudio systemd tremor +unicode
+vorbis wavpack"
@@ -34,7 +34,6 @@ DEPEND="
ao? ( media-libs/libao )
cddb? ( media-libs/libcddb )
cdio? ( dev-libs/libcdio-paranoia )
- cue? ( media-libs/libcue )
discid? ( media-libs/libdiscid )
elogind? ( sys-auth/elogind )
ffmpeg? ( media-video/ffmpeg:= )
@@ -68,16 +67,24 @@ DOCS=( AUTHORS README.md )
S="${WORKDIR}/${P/_/-}"
-my_config() {
- local value
- use ${1} && value=a || value=n
- myconf="${myconf} ${2}=${value}"
-}
-
src_configure() {
- local debuglevel=1 myconf="CONFIG_ARTS=n CONFIG_SUN=n CONFIG_SNDIO=n CONFIG_WAVEOUT=n CONFIG_VTX=n CONFIG_ROAR=n"
+ my_config() {
+ local value
+ use ${1} && value=a || value=n
+ myconf+=( ${2}=${value} )
+ }
+ local debuglevel=1
use debug && debuglevel=2
+ local myconf=(
+ CONFIG_CUE=y
+ CONFIG_ARTS=n
+ CONFIG_SUN=n
+ CONFIG_SNDIO=n
+ CONFIG_WAVEOUT=n
+ CONFIG_VTX=n
+ CONFIG_ROAR=n
+ )
my_config cddb CONFIG_CDDB
my_config cdio CONFIG_CDIO
@@ -94,7 +101,6 @@ src_configure() {
my_config mp4 CONFIG_MP4
my_config aac CONFIG_AAC
my_config ffmpeg CONFIG_FFMPEG
- my_config cue CONFIG_CUE
my_config pulseaudio CONFIG_PULSE
my_config alsa CONFIG_ALSA
my_config jack CONFIG_JACK
@@ -103,12 +109,12 @@ src_configure() {
my_config oss CONFIG_OSS
if use elogind || use systemd; then
- myconf="${myconf} CONFIG_MPRIS=a"
+ myconf+=( CONFIG_MPRIS=a )
else
- myconf="${myconf} CONFIG_MPRIS=n"
+ myconf+=( CONFIG_MPRIS=n )
fi
- ./configure prefix="${EPREFIX}"/usr ${myconf} \
+ ./configure prefix="${EPREFIX}"/usr "${myconf[@]}" \
exampledir="${EPREFIX}"/usr/share/doc/${PF}/examples \
libdir="${EPREFIX}"/usr/$(get_libdir) DEBUG=${debuglevel} || die
}
diff --git a/media-sound/cmus/metadata.xml b/media-sound/cmus/metadata.xml
index f19bd0670b18..671a05ce3c84 100644
--- a/media-sound/cmus/metadata.xml
+++ b/media-sound/cmus/metadata.xml
@@ -7,7 +7,6 @@
</maintainer>
<use>
<flag name="cdio">Use libcdio for CD support </flag>
- <flag name="cue">Enable CUE sheet parsing</flag>
<flag name="discid">Enable reading the ID of the inserted CD</flag>
<flag name="elogind">Enable MPRIS support via <pkg>sys-auth/elogind</pkg></flag>
<flag name="pidgin">Install support script for <pkg>net-im/pidgin</pkg></flag>