summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-20 12:58:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-20 13:29:33 +0100
commita39759e8a2d0d5b2398db5861e32106e4d273176 (patch)
treee12440bdf4c7627181e29c3b046ac4f863d22775 /media-sound/cmus
parentmedia-sound/cmus: Fix ffmpeg deprecations being future build errors (diff)
downloadgentoo-a39759e8a2d0d5b2398db5861e32106e4d273176.tar.gz
gentoo-a39759e8a2d0d5b2398db5861e32106e4d273176.tar.bz2
gentoo-a39759e8a2d0d5b2398db5861e32106e4d273176.zip
media-sound/cmus: Add opus file support
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/cmus')
-rw-r--r--media-sound/cmus/cmus-2.8.0.ebuild1
-rw-r--r--media-sound/cmus/files/cmus-2.8.0-opus.patch22
2 files changed, 23 insertions, 0 deletions
diff --git a/media-sound/cmus/cmus-2.8.0.ebuild b/media-sound/cmus/cmus-2.8.0.ebuild
index 22dddaf48737..7ad9b48909d2 100644
--- a/media-sound/cmus/cmus-2.8.0.ebuild
+++ b/media-sound/cmus/cmus-2.8.0.ebuild
@@ -69,6 +69,7 @@ DOCS=( AUTHORS README.md )
PATCHES=(
"${FILESDIR}/${P}-elogind.patch"
"${FILESDIR}/${P}-ffmpeg-deprecations.patch"
+ "${FILESDIR}/${P}-opus.patch"
)
S="${WORKDIR}/${P/_/-}"
diff --git a/media-sound/cmus/files/cmus-2.8.0-opus.patch b/media-sound/cmus/files/cmus-2.8.0-opus.patch
new file mode 100644
index 000000000000..ea95fa8536ce
--- /dev/null
+++ b/media-sound/cmus/files/cmus-2.8.0-opus.patch
@@ -0,0 +1,22 @@
+From 0be981476e019e9fddb5529a73aadf004e94656b Mon Sep 17 00:00:00 2001
+From: tomty89 <tom.ty89@gmail.com>
+Date: Tue, 12 Feb 2019 18:55:09 +0800
+Subject: [PATCH] ip/ffmpeg: enable opus support (#865)
+
+---
+ ip/ffmpeg.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ip/ffmpeg.c b/ip/ffmpeg.c
+index 04b916cc..427257c7 100644
+--- a/ip/ffmpeg.c
++++ b/ip/ffmpeg.c
+@@ -519,7 +519,7 @@ const int ip_priority = 30;
+ const char *const ip_extensions[] = {
+ "aa", "aac", "ac3", "aif", "aifc", "aiff", "ape", "au", "fla", "flac",
+ "m4a", "m4b", "mka", "mkv", "mp+", "mp2", "mp3", "mp4", "mpc", "mpp",
+- "ogg", "shn", "tak", "tta", "wav", "webm", "wma", "wv",
++ "ogg", "opus", "shn", "tak", "tta", "wav", "webm", "wma", "wv",
+ #ifdef USE_FALLBACK_IP
+ "*",
+ #endif